Bluetooth not showing up after kernel update 3.3.6

Asked by oskar truffer on 2012-10-18

So, bluetooth worked fine before I upgraded the kernel to 3.3.6 and now:

-I can't turn it on using the gui or the bluez interface.
-it does NOT have a keyboard button to turn it off/on.
-some infos from the console:
$ hcitool scan
Device is not available: No such device
$ hcitool dev
Devices:
$ hcitools -all
$ rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
 Soft blocked: no
 Hard blocked: no
1: tpacpi_wwan_sw: Wireless WAN
 Soft blocked: no
 Hard blocked: no
2: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
$ hciconfig list
Can't get device info: No such device

so what seems to be the problem? Or is it a bug?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bluez Edit question
Assignee:
No assignee Edit question
Solved by:
oskar truffer
Solved:
2012-10-25
Last query:
2012-10-25
Last reply:
2012-10-22

Can you given the output of:

sudo dmidecode -t 1; lsb_release -a; uname -a; dmesg | grep -i blue

Thanks

oskar truffer (oskar-truffer) said : #2

$ sudo dmidecode -t 1
# dmidecode 2.11
SMBIOS 2.7 present.

Handle 0x000E, DMI type 1, 27 bytes
System Information
 Manufacturer: LENOVO
 Product Name: 2356GCG
 Version: ThinkPad T430s
 Serial Number: R9PH2
 UUID: 79A4B381-5158-11CB-9D99-CAB9250629
 Wake-up Type: Power Switch
 SKU Number: LENOVO_MT_2356
 Family: ThinkPad T430s

$ lsb_release -a;
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

$ uname -a;
Linux ot-thinkpad 3.3.6-030306-generic #201205121335 SMP Sat May 12 17:36:12 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

$ dmesg | grep -i blue
[ 6307.023474] [ 690] 0 690 5297 0 3 0 0 bluetoothd
[ 7277.856240] [ 690] 0 690 5297 0 3 0 0 bluetoothd
[ 7277.878905] [ 690] 0 690 5297 0 3 0 0 bluetoothd
[ 7277.896725] [ 690] 0 690 5297 0 3 0 0 bluetoothd

Then you are using a 3rd party kernel. I suggest you contact the developer and report the issue

oskar truffer (oskar-truffer) said : #4

Okay, I thought i did a regular kernel update, thanks for the answer! Do you have a quick link how I can get back to the default kernel?

oskar truffer (oskar-truffer) said : #5

Okay, I just downgraded the kernel to the default ubuntu 3.3.2 release. Thanks!

Does it work under the default kernel?

oskar truffer (oskar-truffer) said : #7

Yes it does. I had problems with a driver so the system froze completely, that's why i've upgraded the kernel to 3.3.6 in the first place, but it seems to be fixed by now in 3.3.2 as well. Is there a "default" 3.3.6 kernel for ubuntu?

Could try using Quantal, it uses the 3.5.X.X kernel