Configuration file for gnome-file-share-properties in Ubuntu 12.04

Asked by sourav on 2012-09-14

Hi,
I noticed a bug in Ubuntu 12.04. Whenever i try to send a file from my cell phone to a laptop running Ubuntu 12.04 through bluetooth, the file transfer doesn't happen. Now I found that if I run "gnome-file-share-properties" in terminal, it brings up a GUI and we have to check the bluetooth options(they are unchecked by default).
Now, I manage about 5000 laptops all running Ubuntu 12.04(64bit). I want the actaul configuration file which can be modified. I can then easily push it through the puppet master. Please let me know the path.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu bluez Edit question
Assignee:
No assignee Edit question
Last query:
2012-09-19
Last reply:
2012-09-14

If you MD5 test an unmodified $HOME folder then set the option and run an MD5 test you will see files failing MD5sum as they have changed. These are the files which have changed and you can start focussing on those.

sourav (linuxandunix) said : #2

Thanks for the prompt reply. Can you kindly guide me as to how exactly this can be done, I mean the commands.

sourav (linuxandunix) said : #3

I found the file location $HOME/.gconf/desktop/gnome/file_sharing
There is an %gconf.xml file which normally has the following contentes;
<?xml version="1.0"?>
<gconf>
 <entry name="bluetooth_obexpush_enabled" mtime="1347975697" type="bool" value="false"/>
 <entry name="bluetooth_enabled" mtime="1347975696" type="bool" value="false"/>
</gconf>

Now when we enable bluetooth through file sharing properties, the false changes to true. If I manually change this value to true, it doesn't work as it again creates a %gconf.xml~ file having the values as "false".

Any idea as to how can i permanently make it true?

Can you help with this problem?

Provide an answer of your own, or ask sourav for more information if necessary.

To post a message you must log in.