bluetooth how to keep buletooth-settings off

Asked by Ali Nassary on 2012-05-28

I need my Bluetooth not always.
to save power I make bluetooth-settings to Off. But when I restart my netbook, is the bluetooth-setting on again.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bluez Edit question
Assignee:
No assignee Edit question
Solved by:
Paolo Rotolo
Solved:
2012-05-28
Last query:
2012-05-28
Last reply:
2012-05-28
Ali Nassary (ali-nassary) said : #1
Best Paolo Rotolo (paolorotolo) said : #2

Hi, open a terminal and write this:

gksudo gedit /etc/rc.local

Then, write after "Exit 0":

rfkill block bluetooth

So, your /etc/rc.local should be like this:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

rfkill block bluetooth

exit 0

Ali Nassary (ali-nassary) said : #3
Ali Nassary (ali-nassary) said : #4

Hi, Paolo

Thanks for the quickly answer
Now when I turn on my netbook, the bluetooth is off.
But I can manually turn on
That help me for the time until this error is corrected thoroughly from Bluetooth-setting.

Thanks again and goodbye

Ali Nassary