Bluetooth not working in Asus K43U (Ubuntu 11.10)

Asked by Zulfahmi Abidin on 2012-04-25

I have a problem to use my Bluetooth with Ubuntu 11.10. This problem happen only on my Ubuntu. When I use my Windows seems no problem to transfer or receive data by Bluetooth.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bluez Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-04-25
Last query:
2012-04-25
Last reply:
2012-04-25

Can you give the output of:

dmesg | grep -i blue; lsb_release -a; uname -a; lsusb

Also in Windows make sure that the device has power management disabled as well as disable its ability to wake up the PC (look in device manager)

This is the result:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux ubuntu 3.0.0-16-generic #29-Ubuntu SMP Tue Feb 14 12:48:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 058f:a016 Alcor Micro Corp.
Bus 004 Device 002: ID 046d:c52f Logitech, Inc. Wireless Mouse M305
Bus 004 Device 003: ID 04ca:3002 Lite-On Technology Corp.

i've tried to disable the bluetooth on windows but seems there is no different. There are several guideline that i had followed but still had the same problem.

Its not disabling the device in Windows, its disabling the power management feature for the device.

What is the output of:

sudo rfkill list

Thanks

Thanks actionparsnip, that solved my question.

i had disable the device from windows. Now my bluetooth device on Ubuntu work fine. ^_^ tq.

Yes, your dumb windows OS is holding the hardware. You need to disable the feature and it frees the hardware up. Its one of the pitfalls of dual booting. Smart huh. NOT!

ROFL. That's why I am using ubuntu now. ^_^ but still need Windows OS for my Assignment. Thanks.