Using Interwrite software on Ubuntu

Asked by Jonathon Zabel on 2011-04-30

I have been trying for some time now to utilize eInstruction's Linux software for their Interwrite boards and tablets. These are interactive whiteboard technologies used in the classroom setting and connect to my computer through a bluetooth USB dongle. Right now, the bluetooth is recognized and working, but the Interwrite Device Manager (part of the software) does not recognize the bluetooth dongle. I am trying to troubleshoot to see if I actually have all of the "required" components to make the software work because I contact eInstruction (because they will tell me to "see my specific distribution's documentation").

The release notes for this software can be found at the following url:

http://legacy.einstruction.com/support_downloads/files/linux/workspacemaclinux.5.70.0713.releasenotes.htm

I am mostly concerned with the following section of the release notes:

"After confirming that the required bluez packages are installed, please make sure that the rfcomm service is running. See your distribution-specific documentation to determine how you can check this." - How do I do this within Ubuntu 11.04?

I also need to have the following packages installed... do these things come standard with 11.04?
    XDG compliant (Menus and file association)
    "bc" utility
    "finger" utility
    libstdc++6
    "sudo" version 1.6.7p5 or greater

        "sudo" must be installed to a location that is included in the system's default search path; otherwise it will not be found. The default search path on most systems includes '/usr/bin', but you should refer to your system's documentation for more details.

    "ia32-libs" (64 bit support)

        This package adds support for running 32 bit applications within a 64 bit Operating System. Please see your specific distributions documentation for information on installing the "ia32-libs" package.

Other than that, I am looking for anyone who has successfully setup an Interwrite Board or Pad (model SP400) with Linux using the bluetooth connection who could let me know which distro they are using...

Thank you!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bluez Edit question
Assignee:
No assignee Edit question
Solved by:
mycae
Solved:
2011-05-01
Last query:
2011-05-01
Last reply:
2011-05-01
mycae (mycae) said : #1

To check if rfcomm is running

open a terminal( Ctrl+Alt+T) then type

ps | grep rfcomm

this should be blank if rfcomm is not running, otherwise it should show a filtered version of the process table. Alternatively you could use the system monitor GUI and scroll down until you find rfcomm (or not).

sudo - its in by default
libstdc++6 - its in by default

ia32-libs - in the package database, you need to install it from the db
bc - Also needs installing from db

This is not a software package. It just means that they put in menus where they should according to the XDG (X Desktop Group; aka freedesktop.org) standards. Which version of the standard they may or may not say.
https://secure.wikimedia.org/wikipedia/en/wiki/Freedesktop.org
    XDG compliant (Menus and file association)

Jonathon Zabel (zabeljonathon) said : #2

Thank you for the quick response mycae!

I checked to see if rfcomm was running via the terminal... but it was not. My guess is this is the issue.

I checked to see if the other packages were installed through Synaptic Package Manager, and they were.

I am somewhat new to the whole linux scheme. I am comfortable installing packages, using the terminal (although I'm not fluent in the commands), and editing files using vim.

Could someone walk me through the process of getting the rfcomm service up and running? I'm not even certain what it does to be honest but I can post any information that is needed!

Best mycae (mycae) said : #3

ack, I must have been asleep

ps augxw | grep rfcomm

grep is a filtering program and the | symbol takes output from the program on the left, and passes it to the right to process.

ps augxw should show you a listing of all processes on the machine -- ps alone will only show child processes for your session

Jonathon Zabel (zabeljonathon) said : #4

Thank you! - Indeed this displayed an output that confirmed the rfcomm service is running... I can also connect to the bluetooth using devices other than the one I am trying to sync through this program (an Interwrite SP400 tablet).

It would appear that I have all the necessary components to make this software work. I will mark this problem as "solved" since the issue I am facing is probably due to something on eInstruction's end of things. I will contact their technical service.

Thanks again!