Bluetooth Keyboad/Mouse (Logitech MX5500) Combo Issues

Asked by Farbod Teedaynoor on 2010-11-15

I just recently decided to finally give Ubuntu a try. I installed Ubuntu 10.04 using Wubi on my Windows 7 machine.

Everything worked fine, the installation went smooth, and I now have a dual boot system with Windows and Ubuntu. The problem is that I can't do anything in Ubuntu!

My Keyboard/Mouse combo is connected via a Bluetooth receiver to one of the USB ports on my PC.

I searched around a little, and it seems this issue is common, and it CAN be solved...inside Ubuntu. The problem is, I don't have any regular keyboard or mouse to use in order to do ANYTHING in Ubuntu.

If I re-connect the Bluetooth receiver (pull it out, plug it back in), both keyboard and mouse work for like one second (I'd have to re-connect the receiver for each letter that I wanna type!), and I can move the mouse a little. But that is it!

Is there any solution I could try without having to re-connect the receiver a gazillion times just to log into Ubuntu and access the console?

Question information

English Edit question
Ubuntu bluez Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
mycae (mycae) said : #1

Do you have a second computer with a built in keyboard? (what are you posting this from)?

If you were to install ssh open a terminal (Ctrl+Alt+T) and type (maybe this is fewer letters?) "sudo aptitude install openssh-server")), then you could log into the other machine over the network using SSH.

Farbod Teedaynoor (teedayf) said : #2

Unfortunately at this time I only have this one PC. I'm posting this message from the Windows installation on my PC which works just fine with my keyboard and mouse.

The Ubuntu installation is installed on top of the Windows system using Wubi, both on the same machine.

This is one of the solutions posted online that may fix my issue:

Is there any way I can access Ubuntu system files on my machine and modify them from the Windows environment? I looked into a program called ex2explorer to access the Ubuntu files under C:\ubuntu\disks, however I cannot find, edit, or modify the file at /lib/udev/rules.d/70-hid2hci.rules

mycae (mycae) said : #3

Hmm. I don't think that tool does ext4 writing...

You could try booting into a different linux distribution (eg fedora) using a liveCD then loopback mount your wubi disk image using the mount command

(parts of this might be useful)

Its a bit tricky though.

i'd just borrow a keyboard and mouse while you get sorted. It will make life a LOT easier. IMHO bluetooth keyboard and mouse really aren't worth the hastle

Farbod Teedaynoor (teedayf) said : #5

I think that's what I'll eventually do, actionparsnip. mycar's solution seems a bit complicated for someone with my experience.

I was hoping there'd be another way, but oh well. I'll just have to call up a friend and borrow his mouse for a day. Thanks anyways.

Farbod Teedaynoor (teedayf) said : #6

Thanks actionparsnip, that solved my question.