ubuntu jaunty bluetooth dongle not pairing

Asked by deeparaj on 2010-10-06

I am trying to pair a BT headset with BT USB dongle, bluetooth-wizard does not pair the BT headset.
Running this command "pactl load-module module-alsa-sink device=bluetooth"
says "Failure: Module initalization failed".
FYI I have defined bluetooth in ~/.asoundrc

Here is some more info:

I have ubuntu jaunty 9.04.

i have the default installed bluez modules. bluez, bluez-gnome, bluez-utils, bluez-alsa.

I have gone through the BluetoothSetup procedure from https://help.ubuntu.com/community/BluetoothSetup

I have bluetooth dongle connected to USB port.

lsusb output:
***************************
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 007: ID 1caa:0001
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

*****************************
5:7 is the dongle, it does not display the manufacturer name and HCI mode as mentioned in SetupDoc. (Device 005: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode))

lsusb -s 5:7 -v output:
****************************
last few lines:

Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 2
      bAlternateSetting 0
      bNumEndpoints 0
      bInterfaceClass 254 Application Specific Interface
      bInterfaceSubClass 1 Device Firmware Update
      bInterfaceProtocol 0
      iInterface 0
      ** UNRECOGNIZED: 07 21 07 88 13 ff 03
Device Status: 0x0000
  (Bus Powered)
****************************

hcitool scan : is successful.

hcitool info <MAC> : output
***********************

Requesting information ...
 BD Address: 00:0D:3C:B1:DA:21
 Features: 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00

bluetooth-wizard: detects device does not pair. Not just a BT headset, it does not pair any BT device. Even if the target BT device finds my-pc and try to pair, it fails.

What is the problem? Is btusb driver not proper? I suppose I need some patch. where Can I get the patch for this problem. i have searched ubuntu launchpad and there are similar threads and it says fixed and upstream etc. Where is the patch and how to apply the patch.

uname -a : output
**************
2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

Please help.

If it is paired, I would like to test it with BT headset,

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bluez Edit question
Assignee:
No assignee Edit question
Solved by:
deeparaj
Solved:
2010-10-08
Last query:
2010-10-08
Last reply:
2010-10-06

Support for Ubuntu jaunty 9.04 is almost over. Is there some real reason to not upgrade to 9.10 and then to 10.04? In Ubuntu 9.10+ bluetooth headsets are flawlessly supported by BT stack and Pulseaudio server, no need for use terminal commands either, just a few clicks.

Jaunty is EOL on 23rd Oct 2010, I suggest you upgrade ASAP. It may cure the issues you are having

deeparaj (deepa-sundaram1) said : #3

Юрий Чудновский,
Tried on 9.10 as well. It is detected and does not pair.

deeparaj (deepa-sundaram1) said : #4

Hi,

I have installed Ubuntu Lucid Lynx now. I tried pairing and setting up BT headset. No success.

Pairing did n't complete. pactl load-module returned "Failed: Module initalization failed"

I uninstalled gnome-bluetooth and installed blueman, and now when I try to pair . DBus throws - Network is down.

Syslog says: /org/bluez/1049/hci0/dev_00_0D_3C_B1_DA_21: error updating services: Device or resource busy (16)

What is missing? ....

deeparaj (deepa-sundaram1) said : #5

Hi,

This problem got solved. It was not a software issue.

But a hardware issue. I bought a new bluetooth dongle.

Now Jaunty is able to pair and connect with headset.

As per instructions given here http://forums.overclockers.com.au/printthread.php?t=780054

I can play through aplay.

for vlc, add this line in vlcrc

alsadev=btheadset

Thanks All.