How do I disable bluetooth?

Asked by tdn on 2010-06-15

I use Kubuntu 10.04 and I *never* use bluetooth. I do not have any bluetooth aware devices, so I would really like to disable it completely. This means:
 * not having the little blue icon start up in the panel
 * not have bluetooth related daemons running
 * not have any bluetooth kernel modules loaded

How do I accomplish this in Kubuntu 10.04?

I am looking forward to your suggestions.

Question information

English Edit question
Ubuntu bluez Edit question
No assignee Edit question
Last query:
Last reply:

Uninstall all bluetooth related packages. For exampe Bluez.

tdn (spam-thomasdamgaard) said : #2

Ok. I have purged bluez. Which other packages should I remove?
How do I prevent bluetooth kernel modules from loading? I do not want to waste laptop battery in this.

A quick search in synaptic gives me this list


tdn (spam-thomasdamgaard) said : #4

Ok. So how do I disable the kernel modules?

Alex L. (alexal) said : #5

Type the following command to disable the driver:
echo 'alias net-pf-31 off' >> /etc/modprobe.conf

tdn (spam-thomasdamgaard) said : #6

Alex, that did not seem to do the trick:

~ $ lsmod |grep bt
btusb 10925 0
bluetooth 49892 1 btusb

Isn't these two bluetooth modules?

Here's how to prevent a module from loading

Alex L. (alexal) said : #8

Sorry, I clicked “Add Answer” instead of “Just Add a Comment” by mistake.

tdn (spam-thomasdamgaard) said : #9

So should I prevent btusb and bluetooth from loading like this:
echo 'alias bluetooth off' >> /etc/modprobe.conf
echo 'alias btusb off' >> /etc/modprobe.conf

Is my assumption correct -- that btusb and bluetooth are safe to remove as long as I don't need bluetooth?

Federico: the link you paste is about putting the modules in blacklist, but this produces a warning at startup.

What if a friend cames one day and wants to give you a photo from the phone using bluetooth?

tdn (spam-thomasdamgaard) said : #11

Federico: I have never had a need for that use case. If it were to happen, I guess I would just have to enable bluetooth again and reboot. No biggie. Right now, I would really like to get rid of it.

ahambidge (ahambidge) said : #12


If you go to System/Preferences/Startup Applications and un-check Bluetooth.


Allan :)

Can you help with this problem?

Provide an answer of your own, or ask tdn for more information if necessary.

To post a message you must log in.