[intrepid] cannot turn off bluetooth

Asked by Kyle Martin

OS: Ubuntu 8.10 amd64

I am running Ubuntu on a Dell Inspiron 1420N (BIOS A09) with internal bluetooth; I am pretty sure that the bluetooth radio is connected to my PC via an internal USB cable. I am not sure what the problem package is, might be the kernel, might be the USB system, might be the bluetooth systerm. When I run poewrtop though, I cannot get the bluetoth to turn off or USB to suspend, when trying to suspend USB I sometimes get messages like "A USB device is active 100.0% of the time:
USB device 1-2 : BCM2045B2 (Broadcom)" which I presume is my bluetooth card. If I try to manually remove the bluetooth kernel module I receive an error saying that the module is in use, even if I use the --force switch. Same goes for unloading ahci.

Question information

English Edit question
Ubuntu bluez-gnome Edit question
No assignee Edit question
Solved by:
Kyle Martin
Last query:
Last reply:
Revision history for this message
Kyle Martin (martikj2-deactivatedaccount) said :

whoops forgot, I am using kernel 2.6.27-3-generic with all updates applied as of 10:30AM CDT

Revision history for this message
marcobra (Marco Braida) (marcobra) said :

Please check the already known bugs https://bugs.launchpad.net/ubuntu/+source/bluez-gnome
and consider to send your issue as bug report...

Thank you

Revision history for this message
Kyle Martin (martikj2-deactivatedaccount) said :

Cleared up on its own