Blender in Ubuntu

Asked by shawn on 2009-06-15

I am a ubuntu 9.04 upgraded (HAHA) from 8.10. I like Blender but now I am having graphics issues. Here is a screenshot.

http://img30.imageshack.us/img30/2940/blenderdoublefuck.png

And this is Blender on a good day. Usually when I translate an object it leaves crap all over the screen as well as bits of the desktop bleed through. Really pisses me off.

Here is my system information:
System information report, generated by Sysinfo: 6/15/2009 2:59:08 PM
http://sourceforge.net/projects/gsysinfo

SYSTEM INFORMATION
 Running Ubuntu Linux, the 5.0 release.
 GNOME: 2.26.1 (Ubuntu 2009-05-06)
 Kernel version: 2.6.28-11-generic (#42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009)
 GCC: 4.3.3 (i486-linux-gnu)
 Xorg: unknown (24 May 2009 12:33:40AM) (24 May 2009 12:33:40AM)
 Hostname: HAL
 Uptime: 0 days 0 h 33 min

CPU INFORMATION
 GenuineIntel, Intel(R) Celeron(R) M processor 1.50GHz
 Number of CPUs: 1
 CPU clock currently at 1496.269 MHz with 1024 KB cache
 Numbering: family(6) model(13) stepping(8)
 Bogomips: 2992.53
 Flags: fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe up bts

MEMORY INFORMATION
 Total memory: 481 MB
 Total swap: 1419 MB

STORAGE INFORMATION
 SCSI device - scsi0
  Vendor: ATA
  Model: HTS541040G9AT00
 SCSI device - scsi1
  Vendor: MATSHITA
  Model: UJDA760 DVD/CDRW

HARDWARE INFORMATION
MOTHERBOARD
 Host bridge
  Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
  Subsystem: Toshiba America Info Systems Device 0001
 PCI bridge(s)
  Intel Corporation 82801 Mobile PCI Bridge (rev 83)
  Intel Corporation 82801 Mobile PCI Bridge (rev 83)
 USB controller(s)
  Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
  Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
  Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
  Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 03) (prog-if 20)
  Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
  Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
  Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
  Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 03) (prog-if 20)
 ISA bridge
  Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 03)
 IDE interface
  Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03) (prog-if 8a [Master SecP PriP])
  Subsystem: Toshiba America Info Systems Device 0001

GRAPHIC CARD
 VGA controller
  Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
  Subsystem: Toshiba America Info Systems Device 0005

SOUND CARD
 Multimedia controller
  Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
  Subsystem: Toshiba America Info Systems Device 0412

NETWORK
 Ethernet controller
  Intel Corporation 82801DB PRO/100 VE (MOB) Ethernet Controller (rev 83)
  Subsystem: Toshiba America Info Systems Device 0001
 Modem
  Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03)
  Subsystem: Toshiba America Info Systems Device 0001

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu blender Edit question
Assignee:
No assignee Edit question
Solved by:
shawn
Solved:
2009-06-17
Last query:
2009-06-17
Last reply:
2009-06-16
sim-value (sim-value) said : #1

Do you have Compiz turned off ?

shawn (harlequingraphics) said : #2

I have visual effects turned off, is that the same as turning compiz off?

shawn (harlequingraphics) said : #3

How can you tell which windows manager is active? I don't care about wiggly windows or desktop cubes.

shawn (harlequingraphics) said : #4

I fixed my problem. I first tried this http://ubuntuforums.org/showthread.php?t=1130582 all the way up to "bleeding edge". That didn't fix it so I followed the steps to revert everything. I don't know if that contributed to the solution or not. Technically it shouldn't have but I'm just not sure.
The other thing I did which I think fixed it all by itself was to use the metacity command. I had tried the metacity command:
"metacity --replace"
and then closed the terminal each time. I had not tried Blender while the terminal was open but I am pretty sure Blender would have looked "fixed" while the terminal was open.
What fixed it was adding an "&" at the end of the command:

"metacity --replace &"

I guess the "&" makes the command stick after the terminal is closed.

shawn (harlequingraphics) said : #5

I fixed my problem. I first tried this http://ubuntuforums.org/showthread.php?t=1130582 all the way up to "bleeding edge". That didn't fix it so I followed the steps to revert everything. I don't know if that contributed to the solution or not. Technically it shouldn't have but I'm just not sure.
The other thing I did which I think fixed it all by itself was to use the metacity command. I had tried the metacity command:
"metacity --replace"
and then closed the terminal each time. I had not tried Blender while the terminal was open but I am pretty sure Blender would have looked "fixed" while the terminal was open.
What fixed it was adding an "&" at the end of the command:

"metacity --replace &"

I guess the "&" makes the command stick after the terminal is closed.