blender full sceen

Asked by sanjay on 2008-07-03

When I am opening blender in Ubuntu it is coming in full screen

I don't want full screen blender, can you help me

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu blender Edit question
Assignee:
No assignee Edit question
Solved by:
Harvey Muller
Solved:
2008-07-04
Last query:
2008-07-04
Last reply:
2008-07-03
Best Harvey Muller (hlmuller) said : #1

Hi Sanjay,

There are two related bugs for this issue:

    Blender (windowed) run in fullscreen
    https://bugs.launchpad.net/ubuntu/+source/blender/+bug/221651

    blender windowed is not windowed with compiz enable
    https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/151046

It appears compiz causes the problem. There are two ways, to resolve this at the moment:

1. Start blender in a terminal with a command similar to:

    $ blender -w -p 0 0 1024 768

2. Uncheck the "Legacy Fullscreen Support" in Advanced Desktop Effects

    System > Preferences > Advanced Desktop Effects Settings

If this menu option is not available, then you have to install the following:

    $ sudo aptitude install compizconfig-settings-manager

Afterwards you navigate to the application as described above, go to the Utility section, click on the Workarounds button, then uncheck Legacy Fullscreen Support, then close the CompizConfig Settings Manager.

Please report back here and change the question status to Solved if this resolves your question.

Thanks!

Harvey

sanjay (sanjayan16) said : #2

Thanks Harvey Muller, that solved my question.

sanjay (sanjayan16) said : #3

Hi Harvey Muller,

 I just did only these things

              Added one key board shortcut for "Toggle full screen mode"

              System>Preferences>Keyboard shortcuts>Toggle full screen mode

              and then enabled "Resize window"

              System > Preferences > Advanced desktop effects and settings > Window management > Resize window