bind 9.9.6 - Trusty 14.04.5 LTS

Asked by Morgan on 2017-01-16

Hi all,
may is possibile to upgrade bind9 package in Ubuntu "Trusty" 14.04.5 LTS to 9.9.6 version or higher that support DNS CAA?

Repo Version on my Ubuntu Server is:

# cat /etc/issue.net
Ubuntu 14.04.5 LTS

# named -v
BIND 9.9.5-3ubuntu0.11-Ubuntu (Extended Support Version)

that no support DNS CAA.

ISC Release Notes in 9.9.6 version introduced DNS CAA support:

https://ftp.isc.org/isc/bind/9.9.6/RELEASE-NOTES-BIND-9.9.6.txt New Features report:

"Support for CAA record types, as described in RFC 6844 "DNS
   Certification Authority Authorization (CAA) Resource Record",
   was added. [RT#36625] [RT #36737]"

Thx and Regards.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu bind9 Edit question
Assignee:
No assignee Edit question
Last query:
2017-01-16
Last reply:
2017-01-16
Manfred Hampl (m-hampl) said : #1

I suggest that you create a bug report, requesting a backport or SRU for trusty.

Alternatively you can search https://launchpad.net/ubuntu/+ppas?name_filter=bind9 for a PPA that provides such version for installation on your system.

Morgan (morganfw-k) said : #2

Thx for answer, I've already checked PPA, but I prefer an official version, so I've opened a request: https://bugs.launchpad.net/ubuntu/+source/bind9/+bug/1656778.

Regards.

Morgan (morganfw-k) said : #3

For now, I've added LaMont Jones PPA (that is Admin of Ubuntu bind-team): https://launchpad.net/~lamont/+archive/ubuntu/ppa

# sudo add-apt-repository ppa:lamont/ppa
# sudo apt-get update

then I've upgraded Bind9 package only:

# sudo apt-get install bind9 bind9-host bind9utils dnsutils

# named -v
BIND 9.10.3-P4-Ubuntu

finally have disabled repo (for now) and now I'm able to add DNS CAA Records.
I hope Official Ubuntu Trusty Repos will be updated with Bind v9.9.6 or greater.

Can you help with this problem?

Provide an answer of your own, or ask Morgan for more information if necessary.

To post a message you must log in.