Problems With Bind9

Asked by Ozzie on 2014-01-07

First of all,
I am almost a total newbie at Bind9. I know some stuff about configuration, but I still haven't been able to get a dns server working properly. I have DNS port forwarded on my router, server is a clean install of Ubuntu Server 12.04, and I still can't get it running!

I first tried some configuration, got countless errors, and decided to remove bind9, delete /etc/bind, and reinstall it. The only file I changed was named.conf.options, to add the forward DNS servers (only uncommented and changed ip).

After doing so, I tried sudo service bind9 restart, and it gives me this output:

/etc/bind$ sudo service bind9 restart
 * Stopping domain name service... bind9 rndc: connect failed: 127.0.0.1#953: connection refused
                                                                         [ OK ]
 * Starting domain name service... bind9 [fail]

I already tried this tutorial: http://tecadmin.net/configure-rndc-for-bind9/#
and it didn't fix my problem... Can anyone help me out with just getting this thing to work? I am on the verge of throwing my server off a cliff, if anyone has felt like this before...

Thanks in advance,
Ozzie

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bind9 Edit question
Assignee:
No assignee Edit question
Solved by:
Ozzie
Solved:
2014-01-08
Last query:
2014-01-08
Last reply:
Ozzie (ozmedicdoc) said : #1

Solved. I have abso-positively no idea what I did, but it somehow started working...