Ubuntu 12.04 resolving hangs when querying AAAA records against BIND (Ubuntu 10.04) DNS servers

Asked by ICT on 2012-07-02

Hi,

we have recently started installing Ubuntu 12.04 Server. We are using puppet and noticed some very odd behaviour on 12.04. When running puppet on 12.04 the run is very slow when querying our BIND DNS servers. The BIND DNS servers are setup as forwarders to our Windows 2008R2 Servers.

Running tcpdump shows that puppet is trying to query AAAA records without the fullyqualified domain name. For some reason this has a huge impact, as the BIND servers don't respond to the client and so the client runs in a timeout.

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes
10:46:40.740415 IP 172.28.19.52.34257 > gedapvl01.a.space.corp.domain: 64350+ PTR? 0.0.0.0.in-addr.arpa. (38)
10:46:40.740699 IP 172.28.19.52.46768 > gedapvl01.a.space.corp.domain: 15589+ PTR? 11.16.28.172.in-addr.arpa. (43)
10:46:40.741133 IP 172.28.19.52.33600 > gedapvl01.a.space.corp.domain: 19407+ PTR? 52.19.28.172.in-addr.arpa. (43)
10:46:40.849382 IP 172.28.19.52.60961 > gedapvl01.a.space.corp.domain: 39593+ AAAA? puppet.a.space.corp. (37)
10:46:40.849870 IP 172.28.19.52.32963 > gedapvl01.a.space.corp.domain: 61770+ AAAA? puppet.a.space.corp.a.space.corp. (50)
10:46:40.851213 IP 172.28.19.52.43808 > gedapvl01.a.space.corp.domain: 53335+ A? puppet.a.space.corp. (37)
10:46:45.238025 IP 172.28.19.52.47328 > gedapvl01.a.space.corp.domain: 36971+ AAAA? puppet.a.space.corp. (37)
10:46:45.239324 IP 172.28.19.52.53076 > gedapvl01.a.space.corp.domain: 1888+ AAAA? puppet.a.space.corp.a.space.corp. (50)
10:46:45.240345 IP 172.28.19.52.53371 > gedapvl01.a.space.corp.domain: 34589+ A? puppet.a.space.corp. (37)
10:46:47.671963 IP 172.28.19.52.40283 > gedapvl01.a.space.corp.domain: 37664+ AAAA? puppet.a.space.corp. (37)
10:46:47.673165 IP 172.28.19.52.36495 > gedapvl01.a.space.corp.domain: 44009+ AAAA? puppet. (24)

As soon as it tries to resolve "AAAA? puppet." the puppet clients hangs. When the same machine is configured to query our Windows DNS servers instead of the Bind DNS Servers, the problem doesn't exist.

I'm not really sure if this problem is a bug but it only happens on Ubuntu 12.04. On Ubuntu 10.04 or Solaris 10 using the same version of puppet (2.7.11) we don't see this behaviour.

The machines are configured by DHCP. I have started a thread regarding this issue on the ubuntu forums but no one seems to have a clue what is going wrong, so I was told to file a bug report. Before filing a bug report I want to be sure it is a bug so I started this thread. :)

Regards,
Oliver

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bind9 Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-07-26
Last query:
2012-07-26
Last reply:
2012-07-02

I suggest you report a bug

ICT (oliver-weinmann-6) said : #2

done. :)

I suspect we are experiencing the same bug, could you provide a link for the bug you posted so I don't create a duplicate.

ICT (oliver-weinmann-6) said : #4

Hi,

the bug # is:

Bug 1020067

https://bugs.launchpad.net/ubuntu/+source/puppet/+bug/1020067

I have solved it by changing the configuration of my Bind DNS Forwarders:

http://ubuntuforums.org/showthread.php?t=2023315

Regards,
Oliver

ICT (oliver-weinmann-6) said : #5

Thanks actionparsnip, that solved my question.