Can't index Greek modules in Bibletime 2.8.1 in 12.04

Asked by Chuck Bearden

I've used Bibletime for a while, but in 12.04 I seem to be having a lot of trouble with it that I don't have in my 11.10 machine.

Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

Bibletime: 2.8.1-2build1
libsword9: 1.6.2+dfsg-3

The main problem is that Bibltime won't index Greek modules for search, but it will index e.g. English or German modules.
  1. Install e.g. SBLGNT module via Bookshelf Manager;
  2. Select the Search Indexes option on the left in Bookshelf Manager;
  3. Select a Greek module (I've tried both the SBLGNT and TR modules) for indexing, and click Create;
  4. The Greek module now shows up in the Indexed Works list, but the index size is 0 KiB, and searching returns no results.

I am able to index Greek modules in Xiphos, so I tentatively infer that the problem is with Bibletime and not libsword.

A different problem is that I can't use the Bookshelf Manager to remove a module I've installed.
  1. Open Bookshelf Manager;
  2. Select a Bible module (I've tried ESV, SBLGNT, TR) for removal and click Remove;
  3. Confirm removal in the dialog box that pops up;
  4. Nothing happens: the module is still installed.

I've noticed other problems as well, and I suspect others have too. I'd like to install a different version, but I can't back down to the 11.10 build because it depends on libsword8, which in turn depends on libicu44 rather than libicu48, and those libraries seem to be deeply implicated in the dependency graph.

Any suggestions? I saw the answer at
but it appears that this solution won't work for me, since the current bibletime build at Crosswire (2.9.1-1~ppa2~precise) depends on libsword8, for which there is no candidate.

Perhaps the answer is to build bibletime from source, with the libsword-dev package for my current libsword9.

Question information

English Edit question
Ubuntu bibletime Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Can you give the output of:

lsb_release -a; uname -a; dpkg -l | grep -i bible


Revision history for this message
Chuck Bearden (cfbearden) said :

Thanks for responding so quickly!

lsb_release info is above, beginning with "Distributor ID"; I probably should have labeled it.

Here are the dpkg lines for the string 'bible':

ii bibletime 2.8.1-2build1 bible study tool for Qt
ii bibletime-data 2.8.1-2build1 Documentation and data for bibletime, a bible study tool
ii libsword9 1.6.2+dfsg-3 API/library for bible software

That info was also above, but unlabeled alas! Sorry.
Thanks again,

Revision history for this message
Chuck Bearden (cfbearden) said :

Oops, forgot uname -a:
Linux anselm 3.2.0-30-generic #48-Ubuntu SMP Fri Aug 24 16:52:48 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Revision history for this message
actionparsnip (andrew-woodhead666) said :

ok and the output of:

apt-cache policy bibletime


Revision history for this message
Chuck Bearden (cfbearden) said :

  Installed: 2.8.1-2build1
  Candidate: 2.8.1-2build1
  Version table:
 *** 2.8.1-2build1 0
        500 precise/universe amd64 Packages
        100 /var/lib/dpkg/status

Revision history for this message
actionparsnip (andrew-woodhead666) said :

All I can suggest is report a bug to get the package update etc.

Can you help with this problem?

Provide an answer of your own, or ask Chuck Bearden for more information if necessary.

To post a message you must log in.