No beep on 10.10?

Asked by Mannex on 2010-10-18

I am an extensive user of "beep" because it is an easy way for the stuff I write to let me know when it's done (heavy math takes time :)

I just installed 10.10, and installed beep. It used to work fine in 10.04. Now, nothing. I made sure the alsamixer shows it at full volume. Everything else seems to work: music, system sounds, etc.

There used to be a mixer item called "PC Speaker" which is no longer appearing on the mixer. Perhaps it is disabled. Does anyone know how to turn it on, verify that it is enabled, or make beep work for me? Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu beep Edit question
Assignee:
No assignee Edit question
Solved by:
Alexander
Solved:
2011-07-07
Last query:
2011-07-07
Last reply:
2011-07-07
That Bum (jzachariou) said : #1

The kernel module for the motherboard buzzer got put in the blacklist a few releases ago. You need to edit /etc/modprobe.d/blacklist.conf and remove the line 'blacklist pcspkr', then reboot. Or you could run 'sudo modprobe pcspkr' to re-modprobe it and not have to reboot. Beep should work fine.

Beep is into Universe repository then, please first enable the universe repository:

In Ubuntu Ubuntu 10.10
Open System → Administration → Update manager : click on Settings (bottom, left) button Open the → [ Tab Ubuntu software ]
enable "Community Maintained open source software (universe)"
Close and confirm the repository reload.

And install beep

Mannex (russ-mannex) said : #3

Neither worked. I think I may have not fully explained, but I have beep installed. After installing 10.10, I did the old "sudo apt-get install beep" and it installed fine, I think. No apparent error messages. Synaptic is showing it is installed. When I "beep --verbose" I get:

[DEBUG] 1 times 200 ms beeps (100 delay between, 0 delay after) @ 440.00 Hz

So it seems to be installed and thinks it is happily beeping away. But no sound. Alsamixer is also showing the beep turned all the way up. Any ideas? Is there an alsa config file I might need to tweak?

Mannex (russ-mannex) said : #4

Incidentally, I noticed in the modprobe file that the comment mentions "a nice pulseaudio bing." That would be preferable, if someone knows an easy way to do that instead. Thanks.

Mannex (russ-mannex) said : #5

More info. I understand that there are occasionally problems with beep (the section on "IOCTL Wackiness" in the man page). I have tried it as root, and I have also done chmod 4755 to the beep file as root. None of that seems to help either.

I am beginning to suspect that there is a bug here, since beep worked out of the box on 10.04. In order to file a bug, I would like to confirm that others are having the same issue. You can remove beep afterward if you don't want it, and the 'sudo modprobe pcspkr' suggested by "That Bum" (thanks!) is only temporary. Please let me know if you try this whether it is reproducible or not. Thanks.

Launchpad Janitor (janitor) said : #6

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mannex (russ-mannex) said : #7

This is still an issue. Are others experiencing this? If so, I think this needs to be recategorized as a bug, since it worked fine in 10.04. Any info will be greatly helpful.

Launchpad Janitor (janitor) said : #8

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

plux (plux2005) said : #9

I have the same problem. Beep works in 10.04 but after upgrading to 10.10 there is no sound anymore.

Mannex (russ-mannex) said : #10

Plux, I am wondering, are you using a Compaq? I am, and I know there used to be sound issues with the alsa-config. Please let me know. If you are, I may try tweaking that config file to see if I can get it to work. If so, I'll shoot you a copy when I'm finished. Thanks.

plux (plux2005) said : #11

No, I'm having this problem on an Asus 1000H netbook where I upgraded the installation to 10.10. Alsa sound works but beep not. On a second machine (Foxconn Netbox nt525) I have a fresh install and beep does not work either. I checked amixer, alsamixer, modprobed pcspkr, used the "-e" parameter as mentioned in Bug #144022 and other things, but nothing worked. However it's either a configuration problem or a bug.

Mannex (russ-mannex) said : #12

Interesting. Might not be the alsa-config problem I was thinking of. It does sound like a bug. Incidentally, the authors of beep have mentioned somewhere that there were some minor security issues with allowing a user direct access to hardware or something like that, but it was really a non-issue, since the worst they could do was beep someone's machine clandestinely (it could be annoying, but much less annoying than deleting files or gaining access to passwd files).

One other question: did you use the "alternate" install to upgrade?

Launchpad Janitor (janitor) said : #13

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mannex (russ-mannex) said : #14

No, this is still an unresolved issue.

Best Alexander (lxandr) said : #15

For me the problem was in ALSA, snd-hda-intel module.

$ modinfo snd-hda-intel | grep beep
parm: beep_mode:Select HDA Beep registration mode (0=off, 1=on, 2=mute switch on/off) (default=1). (array of int)

So, "modinfo" says that "beep" sound can be manipulated through "beep_mode" module parameter.
By default it is "1", but it's not working.

I've modified /etc/modprobe.d/alsa-base.conf:
...
options snd-hda-intel power_save=10 power_save_controller=Y index=0 beep_mode=1
...

Now after reboot pc-speaker works!

I think that this solution may help only for those who uses integrated audio card (when "beep" sound is produced through audio card).

My config:
Ubuntu 10.10
2.6.37-12-generic #26-Ubuntu SMP Wed Jan 5 18:38:48 UTC 2011 x86_64 GNU/Linux

$ lspci
...
00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]
 Subsystem: Hewlett-Packard Company Device [103c:30c2]
 Flags: bus master, slow devsel, latency 64, IRQ 16
 Memory at 84000000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel
...

Mannex (russ-mannex) said : #16

Sorry for the delay. I will try this in the next few days. Computer crashed bad last night, and I am now recovering it, so it's going to take a while to get everything back up (my internet connection is as slow as two cans with strings between them). Placed on the "to do" list. I'll let you know how it goes.

Flo (flolix) said : #17

I made a very simple solution for a soundcard beep.
I dont know how to upload here, so here is the very short shell script. Take this script and save it somewhere an make it exectuable.
In the same directory with the script you have to put a "beep.wav", you can easily create this file with audacity for example, one second sinewave, at 1000Hz.

After I did this, i found that (grep pcspkr /etc/modprobe.d/blacklist*) it was blacklisted...

Hope this will help you.

Flo

#!/bin/bash
WOAMI=`which $0`

#check if aplay is installed..
if [[ -f $(which aplay 2>/dev/null) ]]
    then
    aplay -q `dirname $WOAMI`"/beep.wav"
 else
#check if mplayer is installed..
  if [[ -f $(which mplayer 2>/dev/null) ]]
  then
  mplayer -quiet `dirname $WOAMI`"/beep.wav"
  fi
fi
exit

Mannex (russ-mannex) said : #18

Thanks for the script. Since I have mplayer, I wrote a small alias in my .bashrc to run a tone. Not a solution, but a workaround. Would rather have the solution, but I'm picky that way :)

Launchpad Janitor (janitor) said : #19

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mannex (russ-mannex) said : #20

This is still an issue.

Launchpad Janitor (janitor) said : #21

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mannex (russ-mannex) said : #22

Still an issue.

Launchpad Janitor (janitor) said : #23

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mannex (russ-mannex) said : #24

Still an issue.

Launchpad Janitor (janitor) said : #25

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mannex (russ-mannex) said : #26

Still an issue.

Launchpad Janitor (janitor) said : #27

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mannex (russ-mannex) said : #28

Still an issue.

Launchpad Janitor (janitor) said : #29

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Same problem here using kubuntu 10.10 (Linux golem 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 18:42:20 UTC 2011 x86_64 GNU/Linux).

Everything worked fine in 10.04. I fixed the blacklist issue noted by That Bum (https://answers.launchpad.net/ubuntu/+source/beep/+question/130004) and rebooted but it did not help. Alsamixer shows beep to be unmuted and at full volume. Beep runs without errors but no sound.
Also tried 'modprobe pcspkr' as suggested by Bobmoe (https://bugs.launchpad.net/ubuntu/+source/beep/+bug/144022) to no avail.
running 'lsmod | grep pcspkr' shows pcspeakers are loaded.
running 'rmmod pcspkr' and 'modprobe pcspkr' reloaded pcspkrs but does not help.

Mannex (russ-mannex) said : #31

Yes, this is still a problem. Hoping it is addressed somehow in 11.04, I am reopening it for now.

Vortex Cortex (vortex-cortex) said : #32

I develop a cross platform terminal environment -- This is an important issue for me as many of my clients require their terminal beeps to work properly, and I can no longer test that my software works properly.

I use Ubuntu because I just want to get in, do work, not mess with settings...

I found this in my blacklist.conf
# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr

Well, disabling features for no good reason other than a ridiculous stylistic choice, esp when a working replacement does not yet exist is getting on my nerves.

(If users are frequently using the terminal enough to be annoyed by a beep, they should be capable enough to deal with it themselves...)

I've found a "fix" for this situation -- install Fedora. Congrats Ubuntu -- Lost another dev / user.

Mannex (russ-mannex) said : #33

Beep (version 1.2.2) still not working in 11.04 (by the way).

As Vortex mentioned above, even though some may consider this not very important, it is to some others (like me and Vortex). It would be nice to see someone who knows what they're doing at least take a look at this and see if it can be OPTIONALLY restored (i.e. restore the functionality, then redirect with an alias that can be commented, or something simple like that). Just a thought. Thanks.

Additionally, I'll gladly place a six-pack of beer on the line to the first person who can fix it :)

Launchpad Janitor (janitor) said : #34

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mannex (russ-mannex) said : #35

This is still an issue in 11.04.

Launchpad Janitor (janitor) said : #36

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mannex (russ-mannex) said : #37

Still an issue.

Launchpad Janitor (janitor) said : #38

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mannex (russ-mannex) said : #39

Still an issue.

jordicoma (jordicoma22) said : #40

I had the seme problem, it was in blacklist, after modprobe pcspkr works.
If it still doesn't work, try to set the volume with "xset b vol pitch"

Mannex (russ-mannex) said : #41

Modified the /etc/modprobe.d/blacklist.conf file to read as follows (unimportant lines not included):

...
# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
#blacklist pcspkr
...

Rebooted. Did the following from a terminal:

mannex@Leviathan:~$ beep
mannex@Leviathan:~$ xset b 100
mannex@Leviathan:~$ beep
mannex@Leviathan:~$ alsamixer
   [checked to ensure beep volume was 100%]
mannex@Leviathan:~$ beep
mannex@Leviathan:~$ beep --verbose
[DEBUG] 1 times 200 ms beeps (100 delay between, 0 delay after) @ 440.00 Hz
mannex@Leviathan:~$

No sound. Sorry.

Launchpad Janitor (janitor) said : #42

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mannex (russ-mannex) said : #43

Still an issue.

Mannex (russ-mannex) said : #44

Alexander's solution, to place this line:

options snd-hda-intel power_save=10 power_save_controller=Y index=0 beep_mode=1

in the /etc/modprobe.d/alsa-base.conf file, seems to work. I noticed from the log that I had INTENDED on trying that, although there is no record of whether I actually did. Thus, I am not sure whether I tried that before or not, but since then I am using a more recent OS, 11.04, so if I had tried it, I might have had different results. Anyway, after following #15 above, it works again.

Mannex (russ-mannex) said : #45

Thanks Alexander, that solved my question.

This now works using the solution from post #15.
Thanks Alexander (& Mannex for pointing out that this solution now works)!

I tried this in 10.10 without success, but retrying now in 11.04 fixes the problem.
Currently running:
Linux 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
beep-1.2.2