internet on a hp pavilion 1000tx

Asked by Michael Fahrner on 2011-09-13

I have a hp pavillion 1000tx comp. with the latest ubuntu on it. I have ndisgtk and all that stuff installed correctly, the problem is that I can only find the driver in .exe but it's needed in .inf... how do you get around this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bcmwl Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Fahrner
Solved:
2011-09-14
Last query:
2011-09-14
Last reply:
2011-09-14

Can you give the output of:

sudo lshw -C network; lsb_release -a; sudo rfkill list

You may not need the Windows driver, there may be an open solution available. Immediately running to the WIndows driver without checking this isn't a great idea if you aren't sure that drivers are available in your OSes native language :)

Michael Fahrner (mikeyshadow) said : #2

  *-network
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       resources: irq:19 memory:c8000000-c8003fff
  *-network DISABLED
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 00:1a:73:ca:71:d2
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=b43 driverversion=2.6.38-11-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
0: hp-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no

That came out,
Thanks

I think that your BCM4311 wireless adapter is experiencing the following Broadcom driver bug in Ubuntu 11.04:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677

I suggest installing bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu5) from maverick (Ubuntu 10.10) using gdebi and using a wirED (not wireLESS) Internet connection.

Solution is described here:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677/comments/23

Then reboot your PC and run the following commands to enable your wireless adapter:

rfkill unblock all
sudo rfkill unblock all

Then retest wireless using NetworkManager

Michael Fahrner (mikeyshadow) said : #4

so, I accidentally hanged something, and I couldn't fix it... so, sense I didn't have anything on there I cared about I just reinstalled ubuntu... this time I did it with internet connection (tethered to my mac) and did all the updates at the same time, and when it got done the internet worked!!!! = )

Thanks for the Help!!!