E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

Asked by Mingwei Sun on 2017-08-02

This is shown on my screen:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
root@DESKTOP-PTQ931T:~# sudo dpkg --configure -a
Setting up bbswitch-dkms (0.7-2ubuntu1) ...
Loading new bbswitch-0.7 DKMS files...

Every time when I type in sudo dpkg --configure -a, it got stuck here.
Can anyone teach me how to solve the problem? Thank you very much!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu bbswitch Edit question
Assignee:
No assignee Edit question
Last query:
2017-08-02
Last reply:
2017-08-02
Manfred Hampl (m-hampl) said : #1

1. DKMS install can take several minutes. Have you waited long enough to be sure that this command does not successfully end later?

2. bbswitch is only needed if you have a twin graphic card system with a NVidia display adapter. Do you have such system? If not, then you could deinstall that package and this should help getting rid of the error message.

Mingwei Sun (nestor0612) said : #2

I had waited for more than 12 hours. Nothing happened.
I tried to uninstall the package. But I couldn't. The same error showed: E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

Manfred Hampl (m-hampl) said : #3

try

sudo dpkg --purge bbswitch-dkms

Can you help with this problem?

Provide an answer of your own, or ask Mingwei Sun for more information if necessary.

To post a message you must log in.