learning the shell, some commands don't work

Asked by ronojam on 2009-02-06

Binary package hint: firefox-3.0

in lesson 2 of learning the shell, an example of changing directory
cd /usr/x11r6/bin this should take you to the bin directory.
I get: no such file or directory, I am able to do "cd /usr" and I get to the usr directory, if I do from the usr directory "cd /x11r6" I get no such file or derectory.
also I can't do "cd / (any directories like music or videos or any of the directories) I always get: no such file or directory. If i check my disc information, I can find the usr directory, in it I can find the x11r6 directory and in that directory i fin the bin directory.
Wy does the command not able to find those directory, is my bash program missing some links?

System info: download of ubuntu 8.10 with all updates and upgrade (no change in the problem before or after the updates or upgrade, even removed and reinstalled bash.
Pentium 3 at 200 mghz.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
Package: firefox-3.0 3.0.5+nobinonly-0ubuntu0.8.10.1
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.27-11-generic i686

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bash Edit question
Assignee:
No assignee Edit question
Solved by:
Ansgar Burchardt
Solved:
2009-02-06
Last query:
2009-02-06
Last reply:
2009-02-06

This question was originally filed as bug #325986.

ronojam (ronojam) said : #1
Ansgar Burchardt (aburch) said : #2

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs .

Best Ansgar Burchardt (aburch) said : #3

Hi,

On Linux file names are case sensitive: "X11R6" is different from "x11r6".
If you want to go to /usr/X11R6 with two commands, you have to enter "cd /usr" first, then "cd X11R6" (with no slash because this directory is a sub-directory of /usr).

I hope this answers your question.

Ansgar

ronojam (ronojam) said : #4

Thanks Ansgar Burchardt, that solved my question.

vyom sharma (vyom1990) said : #5

hi
actually im using ubuntu 12.04 but im not able to do shell programming as it does not shows output in d below code :

echo enter 2 nos
read a
read b
((c=$a+$b))
echo add=$c

After entering the vaue the op shown is only "add="