Asked by on 2014-07-16

While installing shallow parser in ubuntu 14.04 64 bit machine I found the following lines. Please suggest me how to solve.

Testing Installation
/home/anupamj/sampark/shallow_parser_hin/bin/sl/morph/hin/morph_hin.exe: error while loading shared libraries: cannot open shared object file: No such file or directory
Can't open /tmp/sl31588.out: No such file or directory at /home/anupamj/sampark/shallow_parser_hin/bin/sl/morph/hin/ line 4. 7: [[: not found


Question information

English Edit question
Ubuntu bash Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Thomas Krüger (thkrueger) said : #1

sudo apt-get install libgdbm3 libgdbm-dev

Also there seems to be a syntax error on your shell script.

Hi Thomas Krüger (thkrueger),
The problem is not solved.
I have downloaded the shallow parser from

Manfred Hampl (m-hampl) said : #4

Please provide the output of the following terminal commands:

uname -a
lsb_release -a
sudo apt-get install --reinstall libgdbm3

Thomas Krüger (thkrueger) said : #5

There seems to be a seperate build environment with special lib directotries. This is out of the scope of our Ubuntu support platform.
Also using google reveals that there seems to be a lot of problems with compiling this tool. The code does not have the best quality possible.

@ Manfred Hampl (m-hampl) , Please find the details here

@Thomas Krüger (thkrueger), Okey.

Manfred Hampl (m-hampl) said : #7

ok, now please provide the output of

ldd home/anupamj/sampark/shallow_parser_hin/bin/sl/morph/hin/morph_hin.exe

Maybe it is possible to get the program running on your system.

anupamj@anupamj-HP-ProBook-4430s:~/Downloads/gdbm-1.11$ ldd home/anupamj/sampark/shallow_parser_hin/bin/sl/morph/hin/morph_hin.exe
ldd: home/anupamj/sampark/shallow_parser_hin/bin/sl/morph/hin/morph_hin.exe: No such file or directory

@Manfred Hampl (m-hampl), Please "ignore* my previous comment.

anupamj@anupamj-HP-ProBook-4430s:~/Downloads/gdbm-1.11$ ldd /home/anupamj/sampark/shallow_parser_hin/bin/sl/morph/hin/morph_hin.exe => (0xf77b0000) => /lib/i386-linux-gnu/ (0xf767a000) => not found => /lib/i386-linux-gnu/ (0xf74ca000) => /lib/i386-linux-gnu/ (0xf748c000) => /lib/i386-linux-gnu/ (0xf7470000)
 /lib/ (0xf77b1000)

Best Manfred Hampl (m-hampl) said : #10


sudo apt-get install libgdbm3:i386
ldd /home/anupamj/sampark/shallow_parser_hin/bin/sl/morph/hin/morph_hin.exe

and copy/paste the output as done before.

anupamj@anupamj-HP-ProBook-4430s:~/Documents/Software_Store/shallow-parser-hin-4.0.fc8$ sudo apt-get install libgdbm3:i386
[sudo] password for anupamj:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libotcl1 libtclcl1
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 6 not upgraded.
Need to get 33.3 kB of archives.
After this operation, 108 kB of additional disk space will be used.
Get:1 trusty/main libgdbm3 i386 1.8.3-12build1 [33.3 kB]
Fetched 33.3 kB in 1s (25.9 kB/s)
Selecting previously unselected package libgdbm3:i386.
(Reading database ... 408730 files and directories currently installed.)
Preparing to unpack .../libgdbm3_1.8.3-12build1_i386.deb ...
Unpacking libgdbm3:i386 (1.8.3-12build1) ...
Processing triggers for man-db ( ...
Processing triggers for install-info (5.2.0.dfsg.1-2) ...
Setting up libgdbm3:i386 (1.8.3-12build1) ...
Processing triggers for libc-bin (2.19-0ubuntu6) ...

anupamj@anupamj-HP-ProBook-4430s:~/Documents/Software_Store/shallow-parser-hin-4.0.fc8$ ldd /home/anupamj/sampark/shallow_parser_hin/bin/sl/morph/hin/morph_hin.exe => (0xf7778000) => /lib/i386-linux-gnu/ (0xf7642000) => /usr/lib/i386-linux-gnu/ (0xf763b000) => /lib/i386-linux-gnu/ (0xf748b000) => /lib/i386-linux-gnu/ (0xf744d000) => /lib/i386-linux-gnu/ (0xf7431000)
 /lib/ (0xf7779000)

Thanks Manfred Hampl, that solved my question.

Manfred Hampl (m-hampl) , Thank you very much. Solved the problem.

sonal khosla (sonal13) said : #14

I am getting this error. Kindly help

ldd /home/sonal/shallow_parser_hin/bin/sl/morph/hin/morph_hin.exe => (0xf7799000) => not found => /usr/lib/i386-linux-gnu/ (0xf7777000) => /lib/i386-linux-gnu/ (0xf75c7000)
    /lib/ (0x5656b000)

Manfred Hampl (m-hampl) said : #15


1. please do not piggyback on somebody else's question that has already been marked as "solved", but create a question document of your own.

2. try the command
sudo apt-get install libglib2.0-0:i386