Disable proxy without restart

Asked by Onno on 2012-11-17

It seems it is not possible to change proxy settings for a terminal without restart.

When I start with wrong proxy settings I can change them using network tool. For example I want direct access rather than access thru proxy server. This works for example for the internet browser. But when I start a terminal the old settings are still active. When I wget something I can see the proxy settings are being used. To do wget without proxy server it seems necessary to restart Ubuntu? Is there a way this can be accomplished without restart? I found some claims that it is possible using vague command but this doesn't work for me on Ubuntu 12.04.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu bash Edit question
Assignee:
No assignee Edit question
Last query:
2012-11-17
Last reply:
2012-11-17

If you run:

echo $http_proxy
echo $ftp_proxy
lsb_release -a; uname -a

What is output?

Thanks

Shaival Dalal (dalalshaival) said : #2

Go to Network Settings
Select Network Proxy
Set it as you wish and then click "Apply System-Wide"
Authenticate it
Done!

Onno (ostraaten) said : #3

user@Ali:~$ echo $http_proxy
http://myproxy.com:80/
user@Ali:~$ echo $ftp_proxy
ftp://myproxy.com:80/
ostraaten@Ali:~$ lsb_release -a; uname -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux Ali 3.2.0-33-generic-pae #52-Ubuntu SMP Thu Oct 18 16:39:21 UTC 2012 i686 i686 i386 GNU/Linux

Onno (ostraaten) said : #4

If do apply system-wide via network settings, output remains the same. I start a new terminal and on echo $http_proxy is still shows the same proxy server.

What is the output of:

grep proxy ~/.bashrc

Thanks

Onno (ostraaten) said : #6

The grep doesnt return anything...

try:

grep proxy /etc/bash.bashrc

anything output?

Thanks

Sebastian Feuerstack (sfeu) said : #8

Same problem here.

Neither

grep proxy /etc/bash.bashrc

nor

grep proxy ~/.bashrc

does return anything.

Go to Network Settings
Select Network Proxy
Set it as you wish and then click "Apply System-Wide"

has unfortunately no effect.

Ankur Goel (ankur1990) said : #9

I have the exact same problem. "Applying system wide" doesn't reset the proxy without a reboot. Every new terminal has the same proxy set.

Can you help with this problem?

Provide an answer of your own, or ask Onno for more information if necessary.

To post a message you must log in.