command programs goes to background automatically

Asked by Ashish on 2012-07-19

Many times running a running a command program , the program goes to background as "stopped" automatically. And no matter hiw many times "bg" command is entered it doesn't come in foreground.

ex:
After this operation, 32.7 MB of additional disk space will be used.
Do you want to continue [Y/n]?
[1]+ Stopped apt-get install evolution

This happens in both konsole and gnome-terminal and from 3-4 past ubuntu releases.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: bash 4.2-2ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic-pae 3.2.19
Uname: Linux 3.2.0-26-generic-pae i686
ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
Date: Thu Jul 19 10:21:06 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 LANGUAGE=en_IN:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: bash
UpgradeStatus: No upgrade log present (probably fresh install)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu bash Edit question
Assignee:
No assignee Edit question
Last query:
2012-07-19
Last reply:
2012-07-19

For me this doesn't look like a bug, but some misconfiguration or a hardware problem.

Some ideas what you could try to do:

Does this happen when you use a tty console? Press <CTRL>-<ALT>-<F1> at the same time to switch to the first tty (you can switch back to your graphical desktop with <CTRL>-<ALT>-<F7>).

Maybe it's a hardware problem. Could you try to use a different keyboard with your computer?

Have you checked, that the keyboard layout that you have selected matches the keyboard that you are using? You might want to set any option of that keyboard layout to it's default value just to see if it has some unwanted side effect.

If you still think this is a bug that you are seeing, you might want to consult the following page to provide more information:

https://wiki.ubuntu.com/DebuggingKeyboardDetection

Jeet (gour-jitendrasingh) said : #2

its purely your keyboard problem .. might be your layout or something..

sometime we do not recognize but some keys keep pushed in keyboard that cause other keys to function wrong

any reason but its hardware reason

Midnight Matt (randygaffer) said : #3

To move a process to the foreground, enter `fg`, not 'bg'.

Can you help with this problem?

Provide an answer of your own, or ask Ashish for more information if necessary.

To post a message you must log in.