Shell doesn't recognize my files

Asked by Claudio Piras on 2011-11-05

Hi, I'm on the shell available on Ubuntu 10.04. I downloaded Centos to install it on another PC I have and now I'm trying to check the checksum with both sha1sum and md5sum, below you can find the script I get. I get it although I copy and paste the file name after the checksum command

claudio@Notebook1:~$ sha1sum CentOS-6.0-x86_64-bin-DVD1.iso
sha1sum: CentOS-6.0-x86_64-bin-DVD1.iso: No such file or directory
claudio@Notebook1:~$

I've experienced this kind of problem with other commands as well

Thank you for the support
Claudio

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu bash Edit question
Assignee:
No assignee Edit question
Solved by:
Chris
Solved:
2011-11-05
Last query:
2011-11-05
Last reply:
2011-11-05

You are doing the command from the wrong directory ( is not the place where the iso file was saved) or the file name is different...

Please type:

find $HOME | grep -i .iso

to find the path...

Best Chris (fabricator4) said : #2

It appears that the downloaded ISO is in a directory other than the one you are in at the moment. The default directory for downloads is normally Downloads, and the full path to is /home/username/Downloads. The default directory that the shell will give you is your home directory, or /home/username

There's two things you can do, cd (change directory) to the Downloads directory, or give MD5sum the full path to the file that you want to test. The easiest thing for a beginner is probably to just cd to the correct directory and then run the command as you were before. Note that Linux is case sensitive, so you _have_ to get the case right:

cd Downloads

then run the checksum:

md5sum CentOS-6.0-x86_64-bin-DVD1.iso

The shell that Ubuntu uses is probably the most common one: it is called bash. There's lots of bash primers you can find by doing a search and if you spend a short amount of time with one it will probably make things a lot easier in the long run. Here's one I found from a search:
http://lifehacker.com/5633909/who-needs-a-mouse-learn-to-use-the-command-line-for-almost-anything

Chris

Claudio Piras (piras-claudio) said : #3

Hi, it works now, thank you very much

I kept your link, it's interesting

C