Ubuntu

Banshee 1.4.3 not playing MP3 files

Asked by New2Ubuntu on 2009-10-15

hi, i'm running banshee 1.4.3 on jaunty 9.4 and have just started to have problems with Banshee Not Playing Audio Files.when i click a mp3 track or a podcast download i see a small orange square with a cross through. can anyone help with this?
Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu banshee Edit question
Assignee:
No assignee Edit question
Solved by:
New2Ubuntu
Solved:
2009-10-21
Last query:
2009-10-21
Last reply:
2009-10-16
arochester (arochester) said : #1

Have you installed: ubuntu-restricted-extras
...which, among other things, allows MP3s to play...

-------------------------------------------------------------------------------------------------------
Ubuntu Forums - Absolute Beginner Talk - http://ubuntuforums.org/forumdisplay.php?f=326
Kubuntu Forums - Help the New Guy - http://kubuntuforums.net/forums/index.php?board=7.0

Basic Toolkit
1) Download the Linux Starter Pack - http://www.tuxradar.com/linuxstarterpack
2) Look at the UNOFFICIAL Ubuntu Guide - http://ubuntuguide.org/wiki/Ubuntu:Jaunty
3) Look at Psychocats - http://www.psychocats.net/ubuntu
4) Download the Ubuntu Pocket Guide and Reference - http://www.ubuntupocketguide.com/index_main.html

New2Ubuntu (homegrownchillies) said : #2

hi, thanks for the response. i've checked before I posted my question that these were installed. everything was working fine until a couple of days ago. one thing that has changed is that I had to install a new version of adobe flash as I was having problems with youtube videos hanging in firefox. there was also no sound. could this cause the problem??

Please try this...

Play mp3 and dvd under Ubuntu install skype googleearth acroread and other stuffs using Medibuntu

First please install https://help.ubuntu.com/community/RestrictedFormats

You need to have extra repositories enabled..

Please first enable the universe and multiverse repository:

Open System → Administration → Software sources → [ Tab Ubuntu software ]

enable "Community-maintained Open Source software ( universe )"
enable "Proprietary drivers for devices ( restricted )"
enable "Software restrictecd by copyright or legal issue ( multiverse )"

Close and confirm the repository reload.

Then open a Terminal from the menu Applications→Accessories→Terminal

Tip: right click with mouse on the terminal title caption and select the item "Always on Top" doing this you will force the terminal window to stay on top of the other windows and you will find very easy to copy single row from this web page into the terminal...
Something more about using the terminal https://help.ubuntu.com/community/UsingTheTerminal

Then type or better copy and paste a row a time then press enter:
(Tip: select the single row to copy then right click into the terminal and to quick paste click with middle button of mouse )

and type or better copy and paste:

sudo aptitude install vlc smplayer mplayer

To get better dvd playback and optional packages here the medibuntu available software list http://packages.medibuntu.org/
you need to add the medibuntu http://www.medibuntu.org/ repository to your /etc/apt/sources.list file:
( here the medibuntu howto https://help.ubuntu.com/community/Medibuntu but see below )

In short please open a Terminal from the menu Applications → Accessories → Terminal and type or copy and paste:

sudo wget http://www.medibuntu.org/sources.list.d/`lsb_release -cs`.list --output-document=/etc/apt/sources.list.d/medibuntu.list; sudo apt-get -q update; sudo apt-get --yes -q --allow-unauthenticated install medibuntu-keyring; sudo apt-get -q update

-- give your user password when requested, you don't see nothing when you type it, then press enter

Now to install, type:

sudo apt-get update
sudo apt-get install ubuntu-restricted-extras libxine1-ffmpeg
sudo aptitude install libdvdread3 libdvdnav4 libdvdcss2 regionset gnome-mplayer
sudo aptitude install non-free-codecs w32codecs
sudo aptitude install gstreamer0.10-pitfdll gstreamer0.10-plugins-good
sudo aptitude install gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse

give your user password when requested, you don't see nothing when you type it, then press enter.

You can also install other Medibuntu repository provided optional software http://packages.medibuntu.org/ :

sudo apt-get install skype
sudo apt-get install googleearth
sudo apt-get install acroread

Hope this helps

New2Ubuntu (homegrownchillies) said : #4

hi, thanks for the response. i'm not sure why i have to install skype etc. i rebooted the machine and so far no more problems with banshee. i'll save your response though and try it again should I get the problem againn. thanks for your help.

piratemurray (mez-pahlan) said : #5

I'm running Banshee 1.6 Beta 2 (1.5.1) after the Karmic upgrade and now it won't play any music files.

I also get the GStreamer resource error: OpenWrite message in Banshee. I've followed the suggestions on this page and they haven't helped. Can I have some help to further diagnose and fix the problem please?

Thanks