I can't import mp3's into banshee

Asked by bansheeman

I have several MP3 files that I want to put into my ipod, but I can't see them in the banshee directory lookup system. I try to put a whole folder into the ipod and it still doesn't do anything. I tried putting all the music into the music folder specified in the preferences, but that didn't seem to do anything either. Is there some add-on that I need to install? I am not interested in listening to the songs on my computer, I just want them on my ipod.


Question information

English Edit question
Ubuntu banshee Edit question
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Last query:
Last reply:
Revision history for this message
bansheeman (junkmail188) said :

Could it be that I am not converting the mp3 files into files readable by banshee? If so, How do I get a sound converter? I tried sudo apt-get soundconverter to no avail.


Revision history for this message
marcobra (Marco Braida) (marcobra) said :

Soundconverter is listed into Universe repositories so you must enable them from menu:
System->Administration->Software source: Ubuntu software

Then install it, open a terminal and type:

sudo apt-get update
sudo apt-get install soundconverter

give your user password when requested, you don't see nothing when you
type it, then press enter.

You will find soundconverter under Applications->Sound & video

Hope this helps

Revision history for this message
bansheeman (junkmail188) said :

The Community-maintained Open Source software (universe) box is checked already. Is this what you meant? I installed the sound converter using the synaptic package manager instead. However, the synaptic package manager doesn't seem to see the mp3's to convert them into files banshee can see. I am not sure how to proceed

Revision history for this message
bansheeman (junkmail188) said :

Nevermind it was in a different folder, lol. I will check to see if this works now

Revision history for this message
bansheeman (junkmail188) said :

Ok so the sound converter worked. However, I still can't import any music. Any ideas?

Revision history for this message
Best marcobra (Marco Braida) (marcobra) said :

I think you must simply tell banshee to scan your mp3 converted directory.
Or better move the converted mp3 to default banshee music scan included directory.
By default is the directory Music under your home directory
/home/your username/Music
so move the converted mp3 into that directory and tell banshee to rescan you music files
Try also to close and restart bashee.

By the way go to Edit->Preferences->"Music library" option of Banshee to see the banshee default scan directory for Music

Hope this helps

Revision history for this message
bansheeman (junkmail188) said :

Thanks marcobra, that solved my question.