syncing an ipod nano 5th generation

Asked by John Wilson on 2013-06-28

What is the best way to get Ubuntu to sync with a 5th generation iPod Nano?
I am using Ubuntu 13.04 and have tried various packages to no avail.
Then I restored the iPod on another Windows computer.
Now I can sync in iTunes on that machine but I would like to use my Linux machine

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu banshee Edit question
Assignee:
No assignee Edit question
Solved by:
John Wilson
Solved:
2013-06-29
Last query:
2013-06-29
Last reply:
2013-06-28

Try rhythmbox. There is no single best way. There are simply options

John Wilson (jwilsondmartin) said : #2

Rhytmbox has a bug that does not let me rip CD's into MP3's
The error message is:
Invalid command line need to install gstreamer|1.0|rhythmbox|MPEG-1 Layer3 (MP3) encoder|
File a bug report.
Dont know howbut would like to
Rippped a CD in Sound Juicer and supposedly I can drag and drop files but Rhythmbox crashes when I try drag and drop or syncing

Try banshee

John Wilson (jwilsondmartin) said : #4

Banshee goes through the motions of transferring files to the iPod but they are not transferred.
If you transfer 1 file using iTunes on a windows machine GTKPod works

Hi John,

I recently acquired an iPod nano 6th generation and this procedure worked for me in Ubuntu 13.10:

1) perform a restore of the ipod nano to factory settings in itunes in Windows
2) set up ipod for first time use in itunes in Windows
3) install spotify-client in Ubuntu 13.10 using these 4 commands:

sudo DEBIAN_FRONTEND=noninteractive apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 94558F59
sudo sh -c 'echo "deb http://repository.spotify.com stable non-free" >> /etc/apt/sources.list.d/spotify.list'
sudo DEBIAN_FRONTEND=noninteractive apt-get update
sudo DEBIAN_FRONTEND=noninteractive apt-get --yes --force-yes install spotify-client

4) then run spotify and it should just work fine... You should be able to sync files between Ubuntu and the ipod nano.

Hope this helps,

Mark