No sound from Banshee "GStreamer core error: StateChange"

Asked by Night Eagle on 2012-11-24

I get no sound output from Banshee.

When I try to play a song, it just jumps to the next track, outputting an error on console "GStreamer core error: StateChange".

Sound does work on my system from Rhythmbox, Wine, even Flash.

Running Precise on AMD64.
A few releases back I did have my system configured for OSS4, and Banshee did work at that time. I don't think it has worked since I switched back to stock Ubunto config of ALSA/Pulse so perhaps that is part of the problem?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu banshee Edit question
Assignee:
No assignee Edit question
Last query:
2013-02-26
Last reply:
2013-02-28

Do other players do the same?

Night Eagle (nighteagle) said : #2

The problem seems localized to Banshee.

totem is the only other player I have that doesn't give me audio (and tends to crash anyway so I don't use it).
Every other player I have works as expected - rythmbox, vlc, clementine.
Even flash and wine produce sound properly through pulse.

Here's some more details from the console in case its helpful:

[Info 11:52:52.880] Running Banshee 2.4.1: [Ubuntu 12.04 LTS (linux-gnu, x86_64) @ 2012-07-17 02:26:43 UTC]
[Info 11:52:57.709] Updating web proxy from GConf
[Info 11:52:57.882] All services are started 3.457706
[Info 11:53:00.113] nereid Client Started
[Info 11:53:00.351] GStreamer version 0.10.36.0, gapless: False, replaygain: False
[Error 11:55:18.803] GStreamer core error: StateChange
[Error 11:55:19.206] GStreamer core error: StateChange

(Banshee:11942): GStreamer-CRITICAL **: Failed to deactivate pad mpegaudioparse2:sink, very bad
[Warn 11:55:19.657] Seem to be stuck loading file:///zgigagig/Audio/MusicLibrary-MP3+AAC/AC_DC-Back%20In%20Black(1980)/AC-DC-Back%20In%20Black-08-Have%20A%20Drink%20On%20Me.mp3, so re-trying
[Error 11:55:19.709] GStreamer core error: StateChange
[Error 11:55:20.116] GStreamer core error: StateChange

(Banshee:11942): GStreamer-CRITICAL **: Failed to deactivate pad mpegaudioparse4:sink, very bad
[Error 11:55:20.584] GStreamer core error: StateChange
[Error 11:55:51.155] GStreamer core error: StateChange
[Error 11:55:51.626] GStreamer core error: StateChange
[Warn 11:55:52.065] Seem to be stuck loading file:///zgigagig/Audio/MusicLibrary-FLAC/Black%20Sabbath-Paranoid/Black%20Sabbath-Paranoid-06-Hand%20of%20Doom.flac, so re-trying
[Error 11:55:52.091] GStreamer core error: StateChange

(Banshee:11942): GStreamer-CRITICAL **: Failed to deactivate pad flacparse3:sink, very bad
[Error 11:55:52.568] GStreamer core error: StateChange
[Error 11:55:53.031] GStreamer core error: StateChange

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

If you make a new Ubuntu user and log in as it on the login screen, is it ok?

Night Eagle (nighteagle) said : #6

When I create a new user, log in as that user, and run Banshee, it works and I get sound output. Yippeee!!
So how do I go about resetting Banshee's configuration on my normal user account so that it is in the same virgin state?

Nathan Dick (drakonai) said : #7

I figured out something that worked for me.

WARNING: use caution when deleting config files without knowing what they are. Make solid judgement, and know what you need to keep. Check modification dates if you have to. (right-click -> Properties)

I booted the Live CD (adding nomodeset to boot line if needed for Nvidia card) and mounted my Linux installation (the home folder for the live CD is separate from your installation's home directory. Should be one of the drives in the file browser). Then, I browsed to the home directory. You may need to browse as root, depending on your distro. (right-clicked on my user home directory and selected "Browse as root". AGAIN: proceed with caution)

Take note: when browsing as root, any file created will be owned as root, meaning a regular user cannot delete them, only read them. You can fix this after my guide, by rebooting into your installation (unless already there), opening a terminal, and (assuming your default terminal opened directory is ~ [home directory]) running the below command:
$ chown insertuserhere:insertuserhere -R *

Ok, so in your home directory using your live CD, backup (I prefer right-click -> compressing) and delete all folders with the name "banshee" contained in them in the following folders:
* Your home folder
* .config
* .local/share
* .cache

Also, delete your .ccache directory. It is safe to do this, and it will free up some space.

Plus, if the .pulse directory, an .asoundrc file, or any sound config files (Jack, qjackctl, oss, etc) are in any of those folders (They might be named differently depending on your distro), it may have configuration entries that can be causing the problem. Thus, I recommend renaming them, or backing them up and deleting them, to make sure they're not the culprit. (Even if you use an alternate audio system like Jack. You can always, redo the config later.

Not only that, but it might be a good idea to do the same with any gstreamer configs and, if you're really paranoid, gnome, gvfs, and gtk configs in all directories EXCEPT .local/share (just in case there's something needed).

Reboot, follow my above instructions for fixing the permissions for written files if needed, and you should be good to go.

Nathan Dick (drakonai) said : #8

Sorry, for that command, you will need to run it as sudo:
$ sudo chown insertuserhere:insertuserhere -R *

Night Eagle (nighteagle) said : #9

I've removed every Banshee-related config folder I could locate in my home directory, rebooted, did a little dance, and still no sound. Result is still the same: no sound, GStreamer core error: StateChange. I give up.

Nathan Dick (drakonai) said : #10

Then, like I stated in my post, you might try also doing the same for all "pulse", "alsa", and "gstreamer" directories.

Also, delete any *.pa and asoundrc files in your home directory. They might be hidden.

Can you help with this problem?

Provide an answer of your own, or ask Night Eagle for more information if necessary.

To post a message you must log in.