Ubuntu

Banshee: Could not import CD - Error creating directory: Permission Denied

Asked by Mark Owen on 2011-11-12

Hi,
I am using 11.10, suddenly Banshee has stopped importing my CDs (it has been working fine until now). Here is the error:
Could not import CD - Error creating directory: Permission Denied.

I don't know if this is linked, but it stopped working after I downloaded the Xubuntu-desktop package. Should I uninstall this and try again?

Mark

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu banshee Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Owen
Solved:
2011-11-12
Last query:
2011-11-12
Last reply:
2011-11-12

Run banshee from the terminal, what is output when the error occurs?

Mark Owen (mark-owen) said : #2

When I run banshee from terminal my music library disappears and the CD disappears. These are the last few lines from terminal:

* (Banshee:3749): WARNING **: Error calling get_info: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

** (Banshee:3749): CRITICAL **: syncdaemon_folder_info_get_subscribed: assertion `SYNCDAEMON_IS_FOLDER_INFO (finfo)' failed

** (Banshee:3749): WARNING **: Error rescanning Purchased Music: No such file or directory

Mark Owen (mark-owen) said : #4

Solved it - For increased storage capacity, my music library is on an external usb hdd. I noticed that the settings in:

banshee/edit/preferences/source specific/source music/music folder.... had changed. Banshee was searching for the library in the media folder rather than the ext hdd.

Changed settings and everything is fine now. I don't know what caused the settings to change - I didn't touch them.

SOLVED -thanks