11.04 - Banshee no longer working

Asked by Patrick Wilson on 2011-04-29

Having upgraded to 11.04, Banshee no longer works - simply crashes within a second of opening. Ive tried uninstalling and reinstalling but no change

Anyone else having this problem?

Question information

By reporting this crash as a bug, we should be able to figure out whether or not other people are experiencing it, as well as better be able to examine its cause. Therefore, while I would be willing to start with other diagnostic techniques if you decide not to report it as a bug, I recommend you start by reporting it as a bug.

To do that, enable Apport (https://wiki.ubuntu.com/Apport#How%20to%20enable%20apport), install the package called banshee-dbg, read https://help.ubuntu.com/community/ReportingBugs carefully, make sure your system is fully up-to-date, produce the crash, and allow Apport to send the bug data to Launchpad. You may be presented with other bugs that your bug might be the same as. If one of them has the same title as the automatically generated title of your bug, and its description is the same as what happened to you, and its status is not Invalid, then you are, generally speaking, safe assuming that it's the same bug. Otherwise, your bug might or might not still be a duplicate of another bug, but if it is, that will be discovered further down the road--go ahead and file the report. In your bug report, make sure to describe in detail what you know about the crash (I recognize that in this case, and as of this point, it's not much). Nonetheless, your bug report should be self-contained. It should not be necessary for the Ubuntu developers to refer to this question page in order to fully understand and appreciate your bug. But it is a good idea, after you report the bug, to link this question and the bug to each other, using the "Link existing bug" link near the top of this page.

Besides linking it to this question, after submitting your bug I recommend also marking bug 773390 a duplicate of the new bug. Your new bug will probably contain a lot of useful information, because Apport automatically attaches highly detailed technical information documenting the crash, as well as other information about how Banshee is set up on your computer.

Patrick Wilson (patrickwilson) said : #2

All done

thanks

You have marked the new bug as a duplicate of the old bug. That is the opposite of what you should do (in this case). Bug 773390 should be a duplicate of the bug you just filed, i.e., of bug 773495. I recommend correcting this as soon as possible. If it remains a duplicate of an Invalid bug, the new bug will not be properly examined.

As a separate matter, the new bug (bug 773495, the one that contains the valuable information) is automatically private, because data collected in a crash, prior to being (either automatically or manually) processed, can sometimes contain sensitive personal or otherwise confidential information. For example, if you were entering a password or a credit card number or the name of one of your patients (if you are, say, a doctor) into an application and the application crashes with that information in memory, then (in one form or another) that could make it into the crash report.

There are three ways you could deal with this, in this case. You could keep it private, and wait for "Apport retracting service" and/or Ubuntu bug triagers to remove the most potentially sensitive information, vet the rest for sensitive-looking stuff, and then mark the bug public. (This usually happens on its own, eventually.)

Or you could do that, but also subscribe me to the bug, so I can use it to continue providing help with this issue sooner. I won't abuse my access to whatever information is present...but then, anybody can say that so you don't know I'm not lying. ;-) (Of course, that also applies to the Ubuntu bug triagers, who are also human volunteers...)

Or you could mark the bug public. You should never mark somebody else's bug public while it still has a CoreDump.gz file attached, and you should be extremely reluctant to mark other people's bugs public even if they don't, but if you know that Banshee wasn't accessing any sensitive information (which only you, as the reporter of the bug, could know), then you may decide to mark your bug public.

Given that it's Banshee, I would personally probably go for the third way. But it's your call. You might want to wait a bit first anyway--it's possible that "Apport retracing service" will remove potentially sensitive data and mark it public before I could get around to providing further assistance anyway. (There's a good chance I won't be able to help you more until this evening.)

Patrick Wilson (patrickwilson) said : #4

Thanks
Ive corrected the duplicate tags and also made the bug public
Patrick

The bug you're having turns out to be a duplicate of bug 529714 (as I mentioned in your bug report itself, the title of that bug is misleading, as it doesn't just occur with RhythmBox). I recommend you try the workaround from that bug.

Specifically, you should first back up /etc/nsswitch.conf, then edit it and remove wins from the the hosts: line.

One way to do this is to open a Terminal window (Ctrl+Alt+T) and run the following commands pasting (I recommend this to reduce the risk of typos) or carefully typing them into the Terminal, one by one, and pressing enter:

cd /etc
sudo cp nsswitch.conf nsswitch.conf.old
gksu gedit nsswitch.conf

When you run the second command, which creates a backup of this file (a good precaution), you might be prompted for your password within the Terminal. As you enter it, you won't see any placeholder characters (like *). That's OK. Just type it in and press enter. When you run the third command, you might be prompted for your password in the more usual way (with a dialog box). That's OK, even if you were prompted for it by the immediately preceding command. The third command will open up a text editor as root, which you can use to make changes to /etc/nsswitch.conf, even though /etc/nsswitch.conf is an important system file (protected from ordinary everyday modification). See https://help.ubuntu.com/community/RootSudo if you're interested in a better explanation of why you have to "be root" to edit this file.

When the text editor opens up, find the line that starts with

hosts:

and find the entry in that line called

wins

and remove this entry. Make sure there is still a space between the entry immediately preceding and the entry immediately following it (unless it was at the very beginning or end). So, if the line originally said

hosts: files mdns4_minimal [NOTFOUND=return] wins dns mdns4

then you would edit it to say:

hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4

Then save the file, quit the text editor, and try running banshee. If the crash still occurs, reboot your computer, and try again. If the crash still occurs then, or you were unable to edit the file for any reason, then please post again with details. This will probably work.

Finally, please note that it is possible that you need to have wins in your /etc/nsswitch.conf line. Possible, but unlikely. This would only be the case if you needed to get a NetBIOS name from a WINS server (see http://en.wikipedia.org/wiki/Windows_Internet_Name_Service if you're interested in what this means, but please note that you don't have to know, because simple trial and error is sufficient to determine if you need this). In particular, you do *not* need wins enabled for your computer to act as a client or server for Windows file sharing. See bug 529714 for details (if you're interested).

Rather than determining whether or not you need wins enabled before making this change, I recommend you make the change, and then see if anything goes wrong. If you experiencing networking problems immediately after making the change (or making the change and rebooting), then you likely did need wins.

Since I cannot advise you about how to revert the change if you cannot access the Internet (though even if you do need wins enabled, it's unlikely disabling it would actually stop your Internet connection from working), I'll give you instructions for doing so now, in case you ever have to. Once again, I emphasize that it is unlikely that making the above change will cause any problems, and thus unlikely that you'll have to revert it.

You made a backup of /etc/nsswitch.conf, so reverting the change can be accomplished by restoring that backup. To do that, you would run this command in the Terminal:

sudo cp /etc/nsswitch.conf.old /etc/nsswitch.conf

Patrick Wilson (patrickwilson) said : #6

Many thanks

This worked

Excellent!

Patrick

Patrick Wilson (patrickwilson) said : #7

Thanks Eliah Kagan, that solved my question.