Broadcom WLAN not detected for my Presario F504EA

Asked by ahs010 on 2009-02-03

Hi,

First of all, thanks for the great community support that makes life much easier with Ubuntu.

I have a similar problem to those reported for Broadcom Wireless LAN device with Ubuntu but with a different flavor.

My Laptop is Compaq Presario F500 (F504EA)- AMD based loaded with Vista Basic. After trying to get ride of Yukky MS Windows, and installing Ubuntu latest release, everything is working fine (Graphics Card, Sound Card, USB Modem "Huawei E220",etc...) except Broadcom WLAN Device.

I tried procedures mentioned in more than 20 web pages with no success. I tried to download many drivers (including windows drivers), ndiswrapper installation, ssb blacklisting and didn't get even closer to a success.

The main issue here is that the device hardware is not detected (although the WLAN LED is orange).

Anyway, I would appreciate your support to resolve this problem in order to begin enjoying my life away from MS.

Important Note: The WLAN device worked once while I was trying one of the procedures (removing something I don't remember what it was - may be ndiswrapper) and then disappeared again after rebooting. Also, I am not sure about my Broadcom WLAN Device Model or how to know about it. I tried hundreds of commands with no success.

Thanks in advance,

Hany Salah

*************************************************************************************************************************************
sshalaby@sshalaby-laptop:~$ sudo iwlist scanning
[sudo] password for sshalaby:
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

pan0 Interface doesn't support scanning.

ppp0 Interface doesn't support scanning.

sshalaby@sshalaby-laptop:~$ nm-tool

NetworkManager Tool

State: connected

- Device: eth0 ----------------------------------------------------------------
  Type: Wired
  Driver: forcedeth
  State: unavailable
  Default: no
  HW Address: 00:1B:24:2B:F9:9C

  Capabilities:
    Supported: yes
    Carrier Detect: yes

  Wired Settings

- Device: ttyUSB0 ----------------------------------------------------------------
  Type: Mobile Broadband (GSM)
  Driver: option
  State: connected
  Default: yes

  Capabilities:
    Supported: yes

  IPv4 Settings:
    Address: 10.70.202.214
    Prefix: 32 (255.255.255.255)
    Gateway: 10.64.64.64

    DNS: 217.52.47.130
    DNS: 4.2.2.2

sshalaby@sshalaby-laptop:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

pan0 no wireless extensions.

ppp0 no wireless extensions.

sshalaby@sshalaby-laptop:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:1b:24:2b:f9:9c
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          Interrupt:21 Base address:0xc000

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:158 errors:0 dropped:0 overruns:0 frame:0
          TX packets:158 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:12520 (12.5 KB) TX bytes:12520 (12.5 KB)

ppp0 Link encap:Point-to-Point Protocol
          inet addr:10.70.202.214 P-t-P:10.64.64.64 Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
          RX packets:3585 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2460 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:5058451 (5.0 MB) TX bytes:163447 (163.4 KB)

sshalaby@sshalaby-laptop:~$ sudo lshw -C network
  *-network DISABLED
       description: Ethernet interface
       physical id: 1
       logical name: pan0
       serial: b6:1f:f7:7e:1e:ec
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes
sshalaby@sshalaby-laptop:~$ lspci
00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:05.0 VGA compatible controller: nVidia Corporation MCP51 PCI-X GeForce Go 6100 (rev a2)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.3 Co-processor: nVidia Corporation MCP51 PMU (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev f1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev f1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
sshalaby@sshalaby-laptop:~$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
sshalaby@sshalaby-laptop:~$ uname -a
Linux sshalaby-laptop 2.6.27-11-generic #1 SMP Thu Jan 29 19:24:39 UTC 2009 i686 GNU/Linux
sshalaby@sshalaby-laptop:~$ dmesg|grep ound
[ 0.000000] found SMP MP-table at [c00f89a0] 000f89a0
[ 0.511201] pnp: PnP ACPI: found 13 devices
[ 1.530924] pcieport-driver 0000:00:02.0: found MSI capability
[ 1.531082] pcieport-driver 0000:00:03.0: found MSI capability
[ 1.884145] isapnp: No Plug & Play device found
[ 1.942737] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 3.423791] No dock devices found.
[ 3.458226] hub 1-0:1.0: USB hub found
[ 3.572254] hub 2-0:1.0: USB hub found
[ 3.676929] nv_probe: set workaround bit for reversed mac addr
[ 19.882506] lp: driver loaded but no devices found
[ 22.937955] powernow-k8: Found 1 Mobile AMD Sempron(tm) Processor 3500+ processors (1 cpu cores) (version 2.20.00)
[ 23.831652] apm: BIOS not found.
[ 1110.544077] usb-storage: device found at 2
[ 1111.611697] usb-storage: device found at 3
[ 2404.850769] Modules linked in: ppp_deflate zlib_deflate bsd_comp ppp_async crc_ccitt ipv6 ppp_generic slhc option usbserial usb_storage libusual binfmt_misc b44 ssb ndiswrapper sco bridge stp rfcomm bnep l2cap bluetooth mii ppdev powernow_k8 cpufreq_ondemand cpufreq_stats cpufreq_userspace cpufreq_conservative freq_table cpufreq_powersave container sbs pci_slot sbshc iptable_filter ip_tables x_tables parport_pc lp parport joydev snd_hda_intel snd_pcm_oss snd_mixer_oss evdev snd_pcm serio_raw snd_seq_dummy psmouse pcspkr snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event k8temp snd_seq isp1760 snd_timer snd_seq_device snd soundcore snd_page_alloc video output wmi battery ac button nvidia(P) i2c_nforce2 agpgart shpchp pci_hotplug i2c_core ext3 jbd mbcache sr_mod cdrom sd_mod crc_t10dif sg pata_acpi pata_amd sata_nv ata_generic libata forcedeth scsi_mod dock ehci_hcd ohci_hcd usbcore thermal processor fan fbcon tileblit font bitblit softcursor fuse [last unloaded: ndiswrapper]
[ 2457.481341] usb-storage: device found at 4
[ 2458.519265] usb-storage: device found at 5
sshalaby@sshalaby-laptop:~$ dmesg|grep etect
[ 0.000000] ACPI: DMI detected: Hewlett-Packard
[ 0.000000] Detected use of extended apic ids on hypertransport bus
[ 0.000000] Detected 1808.218 MHz processor.
[ 1.941640] EISA: Detected 0 cards.
[ 3.458238] hub 1-0:1.0: 8 ports detected
[ 3.572266] hub 2-0:1.0: 8 ports detected
[ 1111.906519] option 1-2:1.0: GSM modem (1-port) converter detected
[ 1111.908094] option 1-2:1.1: GSM modem (1-port) converter detected
[ 2458.450733] option 1-2:1.0: GSM modem (1-port) converter detected
[ 2458.477523] option 1-2:1.1: GSM modem (1-port) converter detected
sshalaby@sshalaby-laptop:~$

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu b43-fwcutter Edit question
Assignee:
No assignee Edit question
Solved by:
Joker Wild
Solved:
2009-02-15
Last query:
2009-02-15
Last reply:
2009-02-06

Hany Salah,
Ok wow great info great running the tests, but I don't see your pci card at all on the laptop is the connect button on or off?

if lspci doesn't show it try the connect button. Make sure it is enable in bios.

type lspci | grep "Wireless"

lajjr@lajjr-laptop:~$ lspci |grep "Wireless"
06:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

with it disabled in my bios it show nothing.

ahs010 (ahs010) said : #2

Hi Leo,

Thanks for your prompt response. I checked the setup of the laptop while booting but I couldn't find any information related to devices status.

Can you please help me with identifying if the WLAN device is malfunctioning or not? Is there a command/package that might help under Ubuntu (like a hardware diagnose utility)?

Thanks in advance for your support,

Thanks & regards,

Hany Salah Shalaby

The Holy Quran / Part 16 / Surah 18 / Verses 103 - 106

     103. Say (O Muhammad صلى الله عليه وسلم): "Shall We tell you the greatest losers in respect of (their) deeds?
     104. "Those whose efforts have been wasted in this life while they thought that they were acquiring good by their deeds.
     105. "They are those who deny the Ayât (proofs, evidence, verses, lessons, signs, revelations, etc.) of their Lord and the Meeting with Him (in the Hereafter). So their works are in vain, and on the Day of Resurrection, We shall assign no weight for them.
     106. "That shall be their recompense, Hell; because they disbelieved and took My Ayât (proofs, evidence, verses, lessons, signs, revelations, etc.) and My Messengers by way of jest and mockery.

> To: <email address hidden>
> From: <email address hidden>
> Subject: Re: [Question #59776]: Broadcom WLAN not detected for my Presario F504EA
> Date: Tue, 3 Feb 2009 21:18:44 +0000
>
> Your question #59776 on b43-fwcutter in ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+source/b43-fwcutter/+question/59776
>
> Status: Open => Answered
>
> Leo Albert Jackson Jr proposed the following answer:
> Hany Salah,
> Ok wow great info great running the tests, but I don't see your pci card at all on the laptop is the connect button on or off?
>
> if lspci doesn't show it try the connect button. Make sure it is enable
> in bios.
>
> type lspci | grep "Wireless"
>
> lajjr@lajjr-laptop:~$ lspci |grep "Wireless"
> 06:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
>
> with it disabled in my bios it show nothing.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.edge.launchpad.net/ubuntu/+source/b43-fwcutter/+question/59776/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.edge.launchpad.net/ubuntu/+source/b43-fwcutter/+question/59776
>
> You received this question notification because you are a direct
> subscriber of the question.

_________________________________________________________________
More than messages–check out the rest of the Windows Live™.
http://www.microsoft.com/windows/windowslive/

Hany Salah,

First it may be just this easy.. On the tool bar do you see a little monitor icon with a triangle in it. Yes?

Right mouse click on it button enable wireless. enable networking.

Sure I can help is the wireless button on HP's it had a transmitting symbol on it..is it lit up?

Also I don't see the pci card at all do you have another OS on the system dual boot?

and can you type

lspci | grep "Wireless"
or lspci |grep "Broadcom"
paste the results again please?

It is also called Air Force one.

You said the driver is installed? Make sure the system is connected by Cat5 or Ethernet or cable.

OK it was working on windows it will work on Ubuntu I hard the card it works great.

This is why I think it is not enabled.
 *-network DISABLED
       description: Ethernet interface
       physical id: 1
       logical name: pan0
       serial: b6:1f:f7:7e:1e:ec
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes

First it may be just this easy.. On the tool bar do you see a little monitor icon with a triangle in it. if you are connected it might not hve the triangle in it.

ahs010 (ahs010) said : #5

Hi Leo,

Thanks for your excellent support. Unfortunately, the device is not detected. I had to use a USB wireless device "Belikan" and it's working fine. Also, I had to get rid of the Ubuntu since my father didn't like OpenOffice with Arabic support.
Anyway, thanks for your help,

Hany Salah Shalaby

Wiplash4 (ranjeet-kuruvilla) said : #6

Hello
I have the same problem. I use a HP tx 1000 and since I updated there is no trace of a wlan device noticed by my system. I tried all broadcom howtos and none of them works. I am thinking of going back to windows with all my notebooks because of that.

ahs010 (ahs010) said : #7

Hi Wiplash4

Actually, I was frustrated little bit with Ubuntu when I faced this problem but when I tried to install Windows Vesta on the same laptop, I discovered that there is a problem with the built-in Wireless LAN (Broadcom) card itself. I checked the Internet and I found that this is a known issue in that model from HP. Any many lucky users managed to get their defected device replaced. I say lucky because they live in US and it's easy to do so :-)

So, my advise is to check the device itself and you may need to replace it.

By the way, I enjoy working with Ubuntu so much and I think I will never convert back to Windows!!!

Thanks & regards,

Hany Salah Shalaby

The Holy Quran / Part 16 / Surah 18 / Verses 103 - 106

     103. Say (O Muhammad صلى الله عليه وسلم): "Shall We tell you the greatest losers in respect of (their) deeds?
     104. "Those whose efforts have been wasted in this life while they thought that they were acquiring good by their deeds.
     105. "They are those who deny the Ayât (proofs, evidence, verses, lessons, signs, revelations, etc.) of their Lord and the Meeting with Him (in the Hereafter). So their works are in vain, and on the Day of Resurrection, We shall assign no weight for them.
     106. "That shall be their recompense, Hell; because they disbelieved and took My Ayât (proofs, evidence, verses, lessons, signs, revelations, etc.) and My Messengers by way of jest and mockery.

> To: <email address hidden>
> From: <email address hidden>
> Subject: RE: [Question #59776]: Broadcom WLAN not detected for my Presario F504EA
> Date: Sun, 26 Apr 2009 16:54:30 +0000
>
> Your question #59776 on b43-fwcutter in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/b43-fwcutter/+question/59776
>
> Wiplash4 posted a new comment:
> Hello
> I have the same problem. I use a HP tx 1000 and since I updated there is no trace of a wlan device noticed by my system. I tried all broadcom howtos and none of them works. I am thinking of going back to windows with all my notebooks because of that.
>
> --
> You received this question notification because you are a direct
> subscriber of the question.

_________________________________________________________________
Invite your mail contacts to join your friends list with Windows Live Spaces. It's easy!
http://spaces.live.com/spacesapi.aspx?wx_action=create&wx_url=/friends.aspx&mkt=en-us