BCM4306 wireless chipset not working in Ubuntu 8.10

Asked by oscarm on 2009-01-09

Hi, I just installed ubuntu 8.10 on my HP laptop (64amd). Everything works fine except for the wireless chipset (broadcom 4306). I've tried diferent online guides but they all seem to fail at the last steps. I've tried ndiswrapper, fwcutter but no luck. I don't have access to a wired internet. Please help me figure this out cause I don't feel like buying a wireless card when I know that what I have works (did last night under windows XP)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu b43-fwcutter Edit question
Assignee:
No assignee Edit question
Last query:
2009-01-11
Last reply:
2009-01-11

Hi,

Please try the following procedure, that Denis R found for us:

http://ubuntuforums.org/showpost.php?p=6077792&postcount=72

You can also take a look at this link, which contains a similar Broadcom 4306 wifi chip problem that Denis R recently experienced:

https://answers.launchpad.net/ubuntu/+source/b43-fwcutter/+question/56393

Regards,

Mark

oscarm (oscar-marruffo) said : #2

I found the link you have me last night. Its seems like it found the adapter but I can't connect to any networks

Hi,

Did you follow all the instructions in http://ubuntuforums.org/showpost.php?p=6077792&postcount=72?

Did you succeed in manually downloading and installing b43-fwcutter and also the Broadcom firmware files in Ubuntu?

Did you reboot your pc afterwards and then retest wireless?

Regards,

Mark

oscarm (oscar-marruffo) said : #4

I did, I dont have a wired connection. everything seems to be working fine. the last few steps it wouldnt take any of the comands so i modify them. it wont find any networks at all. i been able to download all the files from my blackberry. question, if i plug it to a wired connection will it be able to fix it self? it keeps on saying that there is an update available then it tries to connect.

Hi,

I think you will need a wired Internet connection (for your pc) to be able to solve the wireless issue.

Regards,

Mark

oscarm (oscar-marruffo) said : #6

I'm at my friends house using his wired, it downloaded all the updates and what not. Shouldn't it search for available networks?

Hi oscarm,

First reboot your pc.

Then please follow this procedure on your laptop, so we can analyze the current health of your wireless configuration in Ubuntu:

Step 1: Open Terminal from "Applications->Accessories->
Terminal"

Step 2: Run the following commands (type each then hit <enter>)

sudo iwlist scanning
nm-tool
iwconfig
ifconfig
sudo lshw -C network
lspci
lsusb
uname -a
dmesg|grep ound
dmesg|grep etect

Step 3: Post results (cut/paste terminal output from each command) here

Regards,

Mark

oscarm (oscar-marruffo) said : #8

´╗┐root@Oscar-laptop:/home/oscar# sudo iwlist scanning
Lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 No scan results

pan0 Interface doesn't support scanning.

root@Oscar-laptop:/home/oscar# nm-tool

NetworkManager Tool

State: disconnected

- Device: eth0 ----------------------------------------------------------------
  Type: Wired
  Driver: 8139too
  State: unavailable
  Default: no
  HW Address: 00:0F:B0:70:23:BB

  Capabilities:
    Supported: yes
    Carrier Detect: yes
    Speed: 10 Mb/s

  Wired Settings

- Device: wlan0 ----------------------------------------------------------------
  Type: 802.11 WiFi
  Driver: NULL(info.linux.driver)
  State: disconnected
  Default: no
  HW Address: 00:90:4B:EB:EF:60

  Capabilities:
    Supported: yes

  Wireless Settings
    WEP Encryption: yes
    WPA Encryption: yes
    WPA2 Encryption: yes

  Wireless Access Points

root@Oscar-laptop:/home/oscar# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:""
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          Tx-Power=27 dBm
          Retry min limit:7 RTS thr:off Fragment thr=2352 B
          Encryption key:off
          Power Management:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

root@Oscar-laptop:/home/oscar# sudo lshw -C network
  *-network:0
       description: Network controller
       product: BCM4306 802.11b/g Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 2
       bus info: pci@0000:03:02.0
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master
       configuration: driver=b43-pci-bridge latency=64 module=ssb
  *-network:1
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 6
       bus info: pci@0000:03:06.0
       logical name: eth0
       version: 10
       serial: 00:0f:b0:70:23:bb
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=128 link=no maxlatency=64 mingnt=32 module=8139too multicast=yes port=MII speed=10MB/s
  *-network:0
       description: Wireless interface
       physical id: 2
       logical name: wlan0
       serial: 00:90:4b:eb:ef:60
       capabilities: ethernet physical wireless
       configuration: broadcast=yes multicast=yes wireless=IEEE 802.11bg
  *-network:1 DISABLED
       description: Ethernet interface
       physical id: 3
       logical name: pan0
       serial: 2a:1f:82:c4:6b:32
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes
root@Oscar-laptop:/home/oscar# lspci
00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:04.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 10)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 01)
00:14.6 Modem: ATI Technologies Inc SB400 AC'97 Modem Controller (rev 01)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon XPRESS 200M 5955 (PCIE)
03:00.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
03:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
03:04.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
03:04.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller
03:04.4 SD Host controller: Texas Instruments PCI6411/6421/6611/6621/7411/7421/7611/7621 Secure Digital Controller
03:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
root@Oscar-laptop:/home/oscar# lsusb
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
root@Oscar-laptop:/home/oscar# uname -a
Linux Oscar-laptop 2.6.27-9-generic #1 SMP Thu Nov 20 22:15:32 UTC 2008 x86_64 GNU/Linux
root@Oscar-laptop:/home/oscar# dmesg|grep ound
[ 0.000000] No NUMA configuration found
[ 0.000000] found SMP MP-table at [ffff8800000f7e20] 000f7e20
[ 0.004000] No AGP bridge found
[ 0.952175] pnp: PnP ACPI: found 10 devices
[ 2.513947] pcieport-driver 0000:00:04.0: found MSI capability
[ 2.658351] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 4.220456] hub 1-0:1.0: USB hub found
[ 4.256796] No dock devices found.
[ 4.385364] hub 2-0:1.0: USB hub found
[ 4.500426] hub 3-0:1.0: USB hub found
[ 4.608386] ssb: Sonics Silicon Backplane found on PCI device 0000:03:02.0
[ 20.629274] Yenta: CardBus bridge found at 0000:03:04.0 [103c:3085]
[ 20.893355] sdhci-pci 0000:03:04.4: SDHCI controller found [104c:8034] (rev 0)
[ 21.268634] b43-phy0: Broadcom 4306 WLAN found
[ 25.724868] lp: driver loaded but no devices found
[ 29.501624] powernow-k8: Found 1 AMD Athlon(tm) 64 Processor 3200+ processors (1 cpu cores) (version 2.20.00)
[ 31.895146] ssb: Sonics Silicon Backplane found on PCI device 0000:03:02.0
[ 32.066783] b43-phy0: Broadcom 4306 WLAN found
root@Oscar-laptop:/home/oscar# dmesg|grep etect
[ 0.000000] ACPI: DMI detected: Hewlett-Packard
[ 0.000000] Detected 994.888 MHz processor.
[ 0.776037] Detected 12.436 MHz APIC timer.
[ 2.513603] pci 0000:00:00.0: MSI quirk detected; MSI disabled
[ 4.220477] hub 1-0:1.0: 4 ports detected
[ 4.385386] hub 2-0:1.0: 4 ports detected
[ 4.500445] hub 3-0:1.0: 8 ports detected
[ 616.132268] pcmcia: Detected deprecated PCMCIA ioctl usage from process: lshw.
root@Oscar-laptop:/home/oscar#

Hi,

Did you scan for wireless networks at your friend's house? Maybe your friend does not have a wireless network?

Did you also run the following command at your own home again?

sudo iwlist scanning

Regards,

Mark

Can you help with this problem?

Provide an answer of your own, or ask oscarm for more information if necessary.

To post a message you must log in.