dpkg: error processing firmware-b43-installer (--configure): subprocess installed post-installation script returned error exit status 8 -> Wireless Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] not working on Dell Inspiron 6400 in Ubuntu 12.04

Asked by Monica Kelley on 2013-07-26

Just installed Ubuntu 12.04 as dual boot on Dell Inspiron 6400. Wireless internet won't work because of broadcom drivers (I have a 4311). When I try to install fireware-b43-installer, get "package firmware-b43-installer 1:015-9 failed to install/upgrade: subprocess installed post-installation script returned error exit status 8".
[I installed 12.04, tried to installed additional drivers and got an error message. I ran the update, which completed, than tried the additional drivers again. Then I had no ethernet or wireless. I range "sudo modprobe b43" and it hung up. Not sure what I did next that gave me ethernet access, but still no wireless.]

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu b43-fwcutter Edit question
Assignee:
No assignee Edit question
Solved by:
Monica Kelley
Solved:
2013-07-27
Last query:
2013-07-27
Last reply:
2013-07-27
Ubfan (ubfan1) said : #1

Try installing the linux-firmware-nonfree package, that should make a 4311 work.

Monica Kelley (monicakelley) said : #2

Still get the same error message...

HTTP request sent, awaiting response... 403 Forbidden
2013-07-26 18:15:50 ERROR 403: Forbidden.

dpkg: error processing firmware-b43-installer (--configure):
 subprocess installed post-installation script returned error exit status 8
Setting up linux-firmware-nonfree (1.11ubuntu2) ...
Errors were encountered while processing:
 firmware-b43-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ubfan (ubfan1) said : #3

Looks like the problem was with the other package (firmware-b43-installer). Look in the /lib/firmware directory for a b43 directory with the firmware files, if they exist, try turning off wireless, (left click on the wireless icon) then on again, or reboot if that doesn't work. network-manager should scan networks and have the list when you left click on the wireless icon,so you can select yours.

Thomas Krüger (thkrueger) said : #4

It looks like you yre having problems witht he download.
You can switch the Download server under Software Center → Edit → Software sources → Download from
or you can download the right .deb file for your architecture (i386 or amd64) from https://launchpad.net/ubuntu/precise/+package/linux-firmware-nonfree and install manually.

Monica Kelley (monicakelley) said : #5

Got it working. In trying to follow the recommendations above, I got a message that a later version of the driver already existed, so I used synaptic manager to remove the bcm packages that were installed, tried again and still got the same message. Then I went to some instructions I found on zyxware technologies website about this issues and followed their directions. I am using wireless as I type. Thanks for the help!