problems with ubuntu 12.04

Asked by conor hassett on 2012-09-30

i recently installed ubuntu on my hp compaq pesario v4000 laptop, it worked well, found wifi firm ware for it, but had to reboot it due to a problem, when i rebooted the system i couldnt find the firm ware that i used before and in the software centre there was a lot less software to down load.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu b43-fwcutter Edit question
Assignee:
No assignee Edit question
Solved by:
conor hassett
Solved:
2012-10-01
Last query:
2012-10-01
Last reply:
2012-10-01

new to ubuntu so eh basic info or layman terms

Can you give the output of:

sudo lshw -C network; lsb_release -a; uname -a; sudo rfkill list

Thanks

where do i get that?

Its a big terminal command

options can be
 -class CLASS only show a certain class of hardware
 -C CLASS same as '-class CLASS'
 -c CLASS same as '-class CLASS'
 -disable TEST disable a test (like pci, isapnp, cpuid, etc. )
 -enable TEST enable a test (like pci, isapnp, cpuid, etc. )
 -quiet don't display status
 -sanitize sanitize output (remove sensitive information like serial numbers, etc.)
 -numeric output numeric IDs (for PCI, USB, etc.)

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
0: hp-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
conor@conor-Presario-V4000-EK946EA-ABU:~$

sudo lshw -C network

what is output please?

conor@conor-Presario-V4000-EK946EA-ABU:~$ sudo lshw -C network
[sudo] password for conor:
  *-network:0
       description: Network controller
       product: BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 5
       bus info: pci@0000:06:05.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master
       configuration: driver=b43-pci-bridge latency=128
       resources: irq:20 memory:b0100000-b0101fff
  *-network:1
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 7
       bus info: pci@0000:06:07.0
       logical name: eth0
       version: 10
       serial: 00:0a:e4:d8:13:4a
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full ip=192.168.1.23 latency=128 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100Mbit/s
       resources: irq:20 ioport:3000(size=256) memory:b0103000-b01030ff
  *-network DISABLED
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 00:14:a5:17:04:c2
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=b43 driverversion=3.2.0-31-generic-pae firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg
conor@conor-Presario-V4000-EK946EA-ABU:~$

where do i get that?

in ubuntu software centre , system soft ware progammes are all back, the soft ware i was looking for is called Installer package for firmware for the b43 driver, its back and all over software is back, dont know if those terminal commands helped, but every thing is back to normal
thanks