wireless problems

Asked by chuck singh on 2012-06-22

Ubuntu 12.04

Wireless card: linksys wmp54g

Wireless router: NetGear wgr614

the problem that I am Having is that my system is able to see my home network. I have an excellent signal, but my network key is not being accepted by the router. If anyone can give me a hand. Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu b43-fwcutter Edit question
Assignee:
No assignee Edit question
Last query:
2012-07-12
Last reply:
2012-07-12
Ubfan (ubfan1) said : #1

With the Ubuntu 11.x releases, the proprietary Broadcom drivers stopped
working with the 4311 Broadcom chips (see bug 732677).
Your 4306 chip may have the same problem, but it works fine with the open b43 driver.
Remove the proprietary STA driver (and its configuration files which
suppress the working b43 driver) by reversing whatever you did to install them:
sudo apt-get purge bcmwl-kernel-source
and/or run additional-drivers and unselect the Broadcom STA driver

Check that your removal/deactivation above is complete:
all the lines with "blacklist b43" should have
been removed from all files in /etc/modprobe.d. These blacklist lines suppress
the b43 driver, so they must be removed -- just the exact "b43" and b43legacy
ones, leave the bcm43xx alone. Deal with any leftovers:
 sudo rm /etc/modprobe.d/blacklist-bcm43.conf
 gksudo gedit any-file-found-with-b43
   and delete or put a # at the beginning.

The proprietary firmware cannot be distributed with the release,so you
have to manually add it. Use a wired connection, and in a terminal:
 sudo apt-get update
 sudo apt-get install b43-fwcutter

and accept the offer to download the Broadcom files, which
will put the Broadcom firmware into /lib/firmware/b43.
If you don't get the offer to download, then purge the package and try again:
 sudo apt-get purge b43-fwcutter
 sudo apt-get install b43-fwcutter

You can even use the open source firmware (which is what I use):
 sudo apt-get install firmware-b43-installer
but only one set of firmware is needed (and non-4311 users should
check for needing the "lpphy" version of the firmware).

With the firmware in place, NetworkManager may start scanning, if not,
manually load the b43 driver module, or just reboot.
 sudo modprobe b43

NetworkManager should start scanning and offer a list of possible
connection points within a few seconds.

Select your access point, select the correct encryption method, and enter
your key. If you are not broadcasting your ssid and it does not show up in
the list of access points, you might have to left click NetworkManager and
select the menu item "connect to hidden network", and enter your ssid. Next
boot, the connection should be automatic.

chuck singh (srblood68) said : #2

I have done everything that you had instructed but I am having the same issues. I have noticed that that the directory b43 and its files were not put back. Did I not do something right?

chuck singh (srblood68) said : #3

I meant wrong?

Ubfan (ubfan1) said : #4

When on a wired connection, the first installation of the b43-fwcutter package should offer to download the Broadcom firmware files and put them into /lib/firmware/b43. If the offer does not occur when you install, then there must be leftover parts of the package from an incomplete removal of a previous install, so do a complete removal using the command:
sudo apt-get purge b43-fwcutter
then do the install again, and you should get the download offer.

The other set of open firmware would work for you too. Just install the firmware-b43-installer package, and it will put the open firmware into directory /lib/firmware/b43-open.
Either set of firmware needs to be present, if both are present, the b43 files will be used.

Ubfan (ubfan1) said : #5

Oops, just noticed the WMP54G changed chipsets for different versions. Please run the command
sudo lshw -C network
and paste the output here. Only the older ones had the Broadcom chipsets. Include the version from any label on the device if you can see it, that may help.

chuck singh (srblood68) said : #6

*-network
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 06
       serial: 50:e5:49:c8:14:69
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:42 ioport:ee00(size=256) memory:fdeff000-fdefffff memory:fdef8000-fdefbfff
  *-network
       description: Wireless interface
       product: RT2561/RT61 802.11g PCI
       vendor: Ralink corp.
       physical id: 7
       bus info: pci@0000:05:07.0
       logical name: wlan0
       version: 00
       serial: 00:25:9c:9f:fb:d8
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt61pci driverversion=3.2.0-26-generic firmware=0.8 latency=32 link=no multicast=yes wireless=IEEE 802.11bg
       resources: irq:21 memory:fdbf0000-fdbf7fff

Ubfan (ubfan1) said : #7

Your WMP54G has the realtek chip 2561 so must be version 4.1. The link:
https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsLinksys
claims that versions works out of the box with the rt61pci driver.
The broadcom firmware is not needed, and without the broadcom chips, should be ignored, but you may remove any broadcom packages you had installed.
Check that the "blacklist b43" line is back in the file /etc/modprobe.d/blacklist.conf -- again, may not even be necessary with no broadcom chips.
The only other driver conflict would be possibly with ndiswrapper, and if you never tried to install that, it should not be present.
If all else fails for the 2t61pci driver, you may try the ndiswrapper, but hold off on that for now.
When you see your access point, but fail to get the password to work, check the following:
1)You really have a wrong password. Usually all it takes is a button press to reset factory defaults, if you have forgotten the pw. Or maybe someone else pushed the button unknown to you!
2)You must select the correct security protocol, WEP, WPA, WPA2 PSk etc. to match what the router has been set to.
3) (less likely) The router can be set to supply only a limited number of IP addresses. If you have done that, you may have exceeded your limit.
4)Try connecting to the router when security has been turned off. After success at that, then set up a password using your selected procotol.

Can you help with this problem?

Provide an answer of your own, or ask chuck singh for more information if necessary.

To post a message you must log in.