WIFI NOT WORKING B4311 REV 01 Inspiron 1501

Asked by Ronan Ryan on 2011-11-06

I have installed ndiswrapper and installed the driver(bwmcl5.inf) for the wifi card dell 1390 wifi mini card but the wifi card is still not working any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu b43-fwcutter Edit question
Assignee:
No assignee Edit question
Solved by:
Ronan Ryan
Solved:
2011-11-06
Last query:
2011-11-06
Last reply:
2011-11-06

Connect the machine to the Internet using an Ethernet cable, uninstall ndiswrapper, and install firmware-b43-installer (http://linuxwireless.org/en/users/Drivers/b43#Ubuntu.2FDebian).

marcus aurelius (adbiz) said : #2

if you're using version 10.04 or 10.10, you'll have to install b43-fwcutter instead of firmware-b43-install which is for version 11.

@marcus
Good call, for 10.04. But what's wrong with using firmware-b43-installer on 10.10? (http://packages.ubuntu.com/maverick/firmware-b43-installer)

Ubfan (ubfan1) said : #4

@Eliah It's just that the package is not available, the three firmware files it installs into /lib/firmware/b43-open certainly work in 10.04 (and earlier versions).
@Ronan -- After installing the b43-fwcutter and accepting the download offer, you will need to purge/remove completely the ndiswrapper package and check that the exact line "blacklist b43" does not exist in any file in /etc/modprobe.d
You didn't mention the third driver, the Broadcom STA (the wl.ko driver), but that should not be present either

@Ubfan
Right. But it *is* available on 10.10, isn't it? (Just not 10.04.)

Do you recommend advising people to look for and remove/disable the Broadcom STA driver? Do people actually have that installed/enabled without deliberately installing/enabling it?

Ronan Ryan (madryan34) said : #6

I removed the Broadrom STA driver just in case the drivers were conflicting. I'm using lubuntu 11.10.
I will install the b43 firmware and i will report back. Thanks for a good discussion the matter

Ronan Ryan (madryan34) said : #7

Its works i installed the firmware and it worked. Thank you so much im every happy

Ubfan (ubfan1) said : #8

@Eliah -- The Broadcom driver is not present without being "activated", but that is only a click in the "additional drivers", so by the time someone gets around to trying ndiswrapper, I'd expect them to have tried the BroadcomSTA too, (and not uninstalled it). I was actually surprised that 10.04 didn't offer the firmware-b43-installer package, but them I've been dragging the fw files around since I ran through the compile exercise, so never used the package myself.