Ubuntu

Wireless Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01) not working on Dell Inspiron 1520 in Ubuntu 11.10

Asked by Peter Frandsen on 2011-10-16

Hi, I upgraded my Dell Inspiron 1520 to 11.10 and then my wireless network does not work (seems to happen every time I upgrade ubuntu). I have tried the different guides from earlier versions of ubuntu, but nothing seems to work (it seems strange that 4 year old hardware still has problems).

One other thing: After I upgraded the "system" menu in the non-unity desktop has disapeared...

P.S. I do enjoy ubuntu very much, but every 6 month I am about ready to dump it...

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu b43-fwcutter Edit question
Assignee:
No assignee Edit question
Solved by:
Peter Frandsen
Solved:
2011-10-18
Last query:
2011-10-18
Last reply:
2011-10-17
Nathan Heafner (nathan1465-5) said : #1

hello

can you please define what you mean by does not work. What is it doing or not doing ? can you see the wireless menu, can you see your wireless network, does your router have encryption enabled, do you know the password ect ect ect.

also the name and model of the router, and the firmware version (you can find this in the routers admin page)

Peter Frandsen (pfrandsen) said : #2

Hi, I can see the "radar" icon - no signal though. The wireless connection was working before the upgrade. I have multiple wireless routers - Netgear N-300 wnr 2000, a buildin router in my adsl box + plus I used to be able to see 15+ wireless networks in the neigbourhood. I know the password and all, but it is definetly not an issue with the routers.

I have an old harddisk with 10.10 on and it works fine with the wireless network. My Mac also work with no problem. And my Android phone connects to the wireless with no problem.

Peter Frandsen (pfrandsen) said : #3

Is there any shell commands that I can run to provide additional information?

Hi,

Please first connect your wired network adapter to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1:

If you are using the Gnome interface, open the Terminal console via "Applications->Accessories->Terminal"

If you are using the Unity interface, the easiest way to open the Terminal is to use the 'search' function on the dash. Or you can click on the 'More Apps' button, click on the 'See more results' by the installed section, and find it in that list of applications. A third way, available after you click on the 'More Apps' button, is to go to the search bar, and see that the far right end of it says 'All Applications'. You then click on that, and you'll see the full list. Then you can go to Accessories > Terminal after that.

So the methods in Unity are:
Dash > Search for Terminal
Dash > More Apps > 'See More Results' > Terminal
Dash > More Apps > Accessories > Terminal

Step 2: Please copy-paste the following command from https://help.ubuntu.com/community/WirelessTroubleshootingProcedure in Firefox into the Linux Terminal. Do NOT copy-paste from the Email message into the Terminal, as that will only copy PART of the command. The command STARTS with the word sudo and ENDS with the word lsmod. So please copy-paste the ENTIRE command below from Firefox into a Terminal, press <enter>, then enter password when sudo asks for password, then press enter again.

Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the command written on the page. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|ireless|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|ound|p54|prism|rtl|rt2|rt3|rt5|rt6|rt7|usb|witch|wl';sudo dmidecode|egrep 'anufact|roduct|erial|elease'; iwconfig; cat /etc/modprobe.d/* | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|wmi|witch|wl'; cat /var/lib/NetworkManager/NetworkManager.state; sudo hwinfo --netcard ; ps -aux|egrep 'icd|etwork'; sudo lsmod

Step 3: Please post results (copy/paste terminal output) on this thread. The troubleshooters here need to see the full Terminal output from running the above command.

Regards,

Mark

Peter Frandsen (pfrandsen) said : #5

Hi Mark. Here is some additional infomation.

PC is: Dell Inspiron 1520
Ubuntu is running from the harddisk (not live cd)

ldconfig deferred processing now taking place
  *-network
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:0c:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       resources: irq:17 memory:f9ffc000-f9ffffff
  *-network
       description: Ethernet interface
       product: BCM4401-B0 100Base-TX
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 02
       serial: 00:1c:23:9b:93:d9
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=b44 driverversion=2.0 duplex=full ip=192.168.1.13 latency=64 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:17 memory:f9bfe000-f9bfffff
0: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: dell-bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: no
2: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

auto lo
iface lo inet loopback

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
00:01.0 PCI bridge [0604]: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port [8086:2a01] (rev 0c)
00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 [8086:2834] (rev 02)
00:1a.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 02)
00:1a.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 02)
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 02)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 [8086:2841] (rev 02)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 [8086:2845] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev f2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller [8086:2815] (rev 02)
00:1f.1 IDE interface [0101]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller [8086:2850] (rev 02)
00:1f.2 IDE interface [0101]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller [8086:2828] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation 82801H (ICH8 Family) SMBus Controller [8086:283e] (rev 02)
01:00.0 VGA compatible controller [0300]: nVidia Corporation G84 [GeForce 8600M GT] [10de:0407] (rev a1)
03:00.0 Ethernet controller [0200]: Broadcom Corporation BCM4401-B0 100Base-TX [14e4:170c] (rev 02)
03:01.0 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832] (rev 05)
03:01.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 22)
03:01.2 System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter [1180:0592] (rev 12)
03:01.3 System peripheral [0880]: Ricoh Co Ltd xD-Picture Card Controller [1180:0852] (rev 12)
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 05a9:2640 OmniVision Technologies, Inc. OV2640 Webcam
Bus 003 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 003 Device 003: ID 413c:8126 Dell Computer Corp. Wireless 355 Bluetooth
Bus 003 Device 004: ID 0a5c:4502 Broadcom Corp. Keyboard (Boot Interface Subclass)
Bus 003 Device 005: ID 0a5c:4503 Broadcom Corp. Mouse (Boot Interface Subclass)
H/W path Device Class Description
==========================================================
                                   system Portable Computer
/0 bus 0KY768
/0/0 memory 64KiB BIOS
/0/400 processor Intel(R) Core(TM)2 Duo CPU T7
/0/400/700 memory 32KiB L1 cache
/0/400/701 memory 2MiB L2 cache
/0/400/0.1 processor Logical CPU
/0/400/0.2 processor Logical CPU
/0/1000 memory 2GiB System Memory
/0/1000/0 memory 1GiB DIMM DDR Synchronous 667 MHz
/0/1000/1 memory 1GiB DIMM DDR Synchronous 667 MHz
/0/100 bridge Mobile PM965/GM965/GL960 Memory C
/0/100/1 bridge Mobile PM965/GM965/GL960 PCI Expr
/0/100/1/0 display G84 [GeForce 8600M GT]
/0/100/1a bus 82801H (ICH8 Family) USB UHCI Con
/0/100/1a.1 bus 82801H (ICH8 Family) USB UHCI Con
/0/100/1a.7 bus 82801H (ICH8 Family) USB2 EHCI Co
/0/100/1b multimedia 82801H (ICH8 Family) HD Audio Con
/0/100/1c bridge 82801H (ICH8 Family) PCI Express
/0/100/1c.1 bridge 82801H (ICH8 Family) PCI Express
/0/100/1c.1/0 network BCM4311 802.11b/g WLAN
/0/100/1c.3 bridge 82801H (ICH8 Family) PCI Express
/0/100/1d bus 82801H (ICH8 Family) USB UHCI Con
/0/100/1d.1 bus 82801H (ICH8 Family) USB UHCI Con
/0/100/1d.2 bus 82801H (ICH8 Family) USB UHCI Con
/0/100/1d.7 bus 82801H (ICH8 Family) USB2 EHCI Co
/0/100/1e bridge 82801 Mobile PCI Bridge
/0/100/1e/0 eth0 network BCM4401-B0 100Base-TX
/0/100/1e/1 bus R5C832 IEEE 1394 Controller
/0/100/1e/1.1 generic R5C822 SD/SDIO/MMC/MS/MSPro Host
/0/100/1e/1.2 generic R5C592 Memory Stick Bus Host Adap
/0/100/1e/1.3 generic xD-Picture Card Controller
/0/100/1f bridge 82801HEM (ICH8M) LPC Interface Co
/0/100/1f.1 scsi0 storage 82801HBM/HEM (ICH8M/ICH8M-E) IDE
/0/100/1f.1/0.0.0 /dev/cdrom disk DVD+-RW TS-L632H
/0/100/1f.2 scsi2 storage 82801HBM/HEM (ICH8M/ICH8M-E) SATA
/0/100/1f.2/0.0.0 /dev/sda disk 120GB Hitachi HTS54161
/0/100/1f.2/0.0.0/1 /dev/sda1 volume 109GiB EXT4 volume
/0/100/1f.2/0.0.0/2 /dev/sda2 volume 2044MiB Extended partition
/0/100/1f.2/0.0.0/2/5 /dev/sda5 volume 2044MiB Linux swap / Solaris part
/0/100/1f.3 bus 82801H (ICH8 Family) SMBus Contro
/1 power DELL UW28083
Linux Ubuntu-Inspiron-1520 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux
[ 0.000000] Found optimal setting for mtrr clean up
[ 0.202578] ACPI: No dock devices found.
[ 0.202582] HEST: Table not found.
[ 0.264059] usbcore: registered new interface driver usbfs
[ 0.264073] usbcore: registered new interface driver hub
[ 0.264110] usbcore: registered new device driver usb
[ 0.272344] Switching to clocksource hpet
[ 0.275328] Switched to NOHz mode on CPU #0
[ 0.275378] Switched to NOHz mode on CPU #1
[ 0.306550] pnp: PnP ACPI: found 12 devices
[ 0.386019] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input0
[ 0.386436] ACPI: Lid Switch [LID]
[ 0.410380] ERST: Table is not found!
[ 0.787132] isapnp: No Plug & Play device found
[ 1.004183] hub 1-0:1.0: USB hub found
[ 1.024267] hub 2-0:1.0: USB hub found
[ 1.024657] hub 3-0:1.0: USB hub found
[ 1.025008] hub 4-0:1.0: USB hub found
[ 1.025333] hub 5-0:1.0: USB hub found
[ 1.025651] hub 6-0:1.0: USB hub found
[ 1.025975] hub 7-0:1.0: USB hub found
[ 1.046694] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 1.428225] usb 2-6: new high speed USB device number 2 using ehci_hcd
[ 1.804402] usb 3-2: new full speed USB device number 2 using uhci_hcd
[ 1.978642] hub 3-2:1.0: USB hub found
[ 2.261580] usb 3-2.1: new full speed USB device number 3 using uhci_hcd
[ 2.469567] usb 3-2.2: new full speed USB device number 4 using uhci_hcd
[ 2.493659] sdhci-pci 0000:03:01.1: SDHCI controller found [1180:0822] (rev 22)
[ 2.494733] mmc0: no vmmc regulator found
[ 2.618759] input: Broadcom Corp as /devices/pci0000:00/0000:00:1a.0/usb3/3-2/3-2.2/3-2.2:1.0/input/input4
[ 2.618862] generic-usb 0003:0A5C:4502.0001: input,hidraw0: USB HID v1.11 Keyboard [Broadcom Corp] on usb-0000:00:1a.0-2.2/input0
[ 2.618879] usbcore: registered new interface driver usbhid
[ 2.618882] usbhid: USB HID core driver
[ 2.686581] usb 3-2.3: new full speed USB device number 5 using uhci_hcd
[ 2.827468] input: Broadcom Corp as /devices/pci0000:00/0000:00:1a.0/usb3/3-2/3-2.3/3-2.3:1.0/input/input5
[ 2.827591] generic-usb 0003:0A5C:4503.0002: input,hidraw1: USB HID v1.11 Mouse [Broadcom Corp] on usb-0000:00:1a.0-2.3/input0
[ 18.042284] lp: driver loaded but no devices found
[ 19.269497] wl 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 19.269506] wl 0000:0c:00.0: setting latency timer to 64
[ 19.272170] eth%d: 5.100.82.38 driver failed with code 21
[ 19.289018] usbcore: registered new interface driver btusb
[ 19.301082] uvcvideo: Found UVC 1.00 device Laptop Integrated Webcam (05a9:2640)
[ 19.305389] uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
[ 19.306324] input: Laptop Integrated Webcam as /devices/pci0000:00/0000:00:1d.7/usb2/2-6/2-6:1.0/input/input7
[ 19.306595] usbcore: registered new interface driver uvcvideo
[ 19.430269] [Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.
[ 19.469545] b43-pci-bridge 0000:0c:00.0: setting latency timer to 64
[ 19.488080] ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x11, vendor 0x4243)
[ 19.488096] ssb: Core 1 found: IEEE 802.11 (cc 0x812, rev 0x0A, vendor 0x4243)
[ 19.488110] ssb: Core 2 found: USB 1.1 Host (cc 0x817, rev 0x03, vendor 0x4243)
[ 19.488119] ssb: Core 3 found: PCI-E (cc 0x820, rev 0x01, vendor 0x4243)
[ 19.547415] ssb: Sonics Silicon Backplane found on PCI device 0000:0c:00.0
[ 19.572635] input: HDA Intel Mic at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
[ 19.572895] input: HDA Intel HP Out at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
[ 19.641674] ssb: Core 0 found: Fast Ethernet (cc 0x806, rev 0x07, vendor 0x4243)
[ 19.641684] ssb: Core 1 found: V90 (cc 0x807, rev 0x03, vendor 0x4243)
[ 19.641692] ssb: Core 2 found: PCI (cc 0x804, rev 0x0A, vendor 0x4243)
[ 19.700156] ssb: Sonics Silicon Backplane found on PCI device 0000:03:00.0
[ 19.721118] b44 ssb1:0: eth0: Broadcom 44xx/47xx 10/100BaseT Ethernet 00:1c:23:9b:93:d9
[ 19.755969] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 19.844471] vboxdrv: Found 2 processor cores.
[ 19.861550] vboxpci: IOMMU not found (not registered)
[ 20.222463] Console: switching to colour frame buffer device 160x50
[ 22.816234] b44 ssb1:0: eth0: Link is up at 100 Mbps, full duplex
[ 22.816239] b44 ssb1:0: eth0: Flow control is off for TX and off for RX
[ 22.816653] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 33.656217] eth0: no IPv6 routers present
[ 1241.000120] b44 ssb1:0: eth0: Link is down
[ 1517.000329] b44 ssb1:0: eth0: Link is up at 100 Mbps, full duplex
[ 1517.000339] b44 ssb1:0: eth0: Flow control is off for TX and off for RX
[ 2982.000237] b44 ssb1:0: eth0: Link is down
[ 3152.000329] b44 ssb1:0: eth0: Link is up at 100 Mbps, full duplex
[ 3152.000339] b44 ssb1:0: eth0: Flow control is off for TX and off for RX
 Release Date: 08/16/2007
  Serial services are supported (int 14h)
 Manufacturer: Dell Inc.
 Product Name: Inspiron 1520
 Serial Number: 8XDB63J
 Manufacturer: Dell Inc.
 Product Name: 0KY768
 Serial Number: .8XDB63J.CN486437982232.
 Manufacturer: Dell Inc.
 Serial Number: 8XDB63J
 Manufacturer: Intel
 Serial Number: Not Specified
 Manufacturer: 7F7F7F0B00000000
 Serial Number: 2819070E
 Manufacturer: 7F7F7F0B00000000
 Serial Number: E01E0928
 Manufacturer: Sanyo
 SBDS Serial Number: 00B4
 SBDS Manufacture Date: 2008-03-02
lo no wireless extensions.

eth0 no wireless extensions.

install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# which ath5k cannot recover. To prevent this condition, stop
blacklist ath_pci
# Warning: This file is autogenerated by bcmwl. All changes to this file will be lost.
blacklist b43
blacklist b43legacy
blacklist bcm43xx
blacklist brcm80211
install wl modprobe -r b43 b44 b43legacy ssb; modprobe --ignore-install wl ; modprobe --ignore-install b44
blacklist eth1394
# replaced by p54pci
blacklist prism54
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist bcma
blacklist uart6850
blacklist twl4030_wdt

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
> hal.1: read hal dataprocess 6437: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file ../../dbus/dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
27: PCI c00.0: 0280 Network controller
  [Created at pci.318]
  Unique ID: zb5c.AUabv0M9SM3
  Parent ID: qTvu.HImHAakZdI6
  SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:0c:00.0
  SysFS BusID: 0000:0c:00.0
  Hardware Class: network
  Model: "Dell Wireless 1390 WLAN Mini-Card"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4311 "BCM4311 802.11b/g WLAN"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x0007 "Wireless 1390 WLAN Mini-Card"
  Revision: 0x01
  Driver: "b43-pci-bridge"
  Driver Modules: "ssb"
  Memory Range: 0xf9ffc000-0xf9ffffff (rw,non-prefetchable)
  IRQ: 17 (337280 events)
  Module Alias: "pci:v000014E4d00004311sv00001028sd00000007bc02sc80i00"
  Driver Info #0:
    Driver Status: ssb is active
    Driver Activation Cmd: "modprobe ssb"
  Driver Info #1:
    Driver Status: wl is active
    Driver Activation Cmd: "modprobe wl"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #15 (PCI bridge)

28: PCI 300.0: 0200 Ethernet controller
  [Created at pci.318]
  Unique ID: rBUF.DyZpBwGvIn5
  Parent ID: 6NW+.5nvCr7YV8cA
  SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:03:00.0
  SysFS BusID: 0000:03:00.0
  Hardware Class: network
  Model: "Broadcom BCM4401-B0 100Base-TX"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x170c "BCM4401-B0 100Base-TX"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x01f1
  Revision: 0x02
  Driver: "b44"
  Driver Modules: "ssb", "b44"
  Device File: eth0
  Memory Range: 0xf9bfe000-0xf9bfffff (rw,non-prefetchable)
  IRQ: 17 (337280 events)
  HW Address: 00:1c:23:9b:93:d9
  Link detected: yes
  Module Alias: "pci:v000014E4d0000170Csv00001028sd000001F1bc02sc00i00"
  Driver Info #0:
    Driver Status: b44 is active
    Driver Activation Cmd: "modprobe b44"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #21 (PCI bridge)
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root 745 0.0 0.2 27700 4768 ? Ssl 16:34 0:00 NetworkManager
root 3747 0.0 0.0 2736 1228 ? S 17:27 0:00 /sbin/dhclient -d -4 -sf /usr/lib/NetworkManager/nm-dhcp-client.action -pf /var/run/dhclient-eth0.pid -lf /var/lib/dhcp/dhclient-60ea14a8-47f9-4382-a290-f66025008406-eth0.lease -cf /var/run/nm-dhclient-eth0.conf eth0
1000 6449 0.0 0.0 5588 792 pts/1 S+ 21:07 0:00 egrep --color=auto icd|etwork
Module Size Used by
parport_pc 32114 0
ppdev 12849 0
vesafb 13489 1
bnep 17923 2
rfcomm 38408 8
pci_stub 12550 1
vboxpci 22882 0
vboxnetadp 13328 0
vboxnetflt 27211 0
vboxdrv 251814 3 vboxpci,vboxnetadp,vboxnetflt
b44 31443 0
snd_hda_codec_idt 60049 1
joydev 17393 0
ssb 50682 1 b44
dell_wmi 12601 0
sparse_keymap 13658 1 dell_wmi
snd_hda_intel 24262 2
snd_hda_codec 91754 2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep 13276 1 snd_hda_codec
uvcvideo 67271 0
videodev 85626 1 uvcvideo
btusb 18160 2
snd_pcm 80468 2 snd_hda_intel,snd_hda_codec
nvidia 10390874 34
wl 2646601 0
bluetooth 148839 23 bnep,rfcomm,btusb
snd_seq_midi 13132 0
dell_laptop 13519 0
binfmt_misc 17292 1
dcdbas 14098 1 dell_laptop
snd_rawmidi 25241 1 snd_seq_midi
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq 51567 2 snd_seq_midi,snd_seq_midi_event
video 18908 0
snd_timer 28932 2 snd_pcm,snd_seq
snd_seq_device 14172 3 snd_seq_midi,snd_rawmidi,snd_seq
wmi 18744 1 dell_wmi
r852 17901 0
lib80211 14570 1 wl
sm_common 16737 1 r852
nand 49707 2 r852,sm_common
nand_ids 8547 1 nand
nand_bch 13003 1 nand
bch 21757 1 nand_bch
nand_ecc 13070 1 nand
mtd 35852 2 sm_common,nand
snd 55902 13 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
psmouse 73673 0
serio_raw 12990 0
soundcore 12600 1 snd
snd_page_alloc 14115 2 snd_hda_intel,snd_pcm
lp 17455 0
parport 40930 3 parport_pc,ppdev,lp
usbhid 41905 0
hid 77367 1 usbhid
firewire_ohci 35854 0
sdhci_pci 13658 0
sdhci 27360 1 sdhci_pci
firewire_core 56937 1 firewire_ohci
crc_itu_t 12627 1 firewire_core
pfrandsen@Ubuntu-Inspiron-1520:~$

I am pretty sure that your BCM4311 wireless adapter is experiencing the
following Broadcom driver bug in Ubuntu 11.10:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677

I suggest installing bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu5)
from maverick (Ubuntu 10.10) using gdebi

Solution is described here:

https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/732677/comments/23

Then reboot your PC and run the following commands to enable your
wireless adapter:

sudo apt-get update && sudo apt-get install rfkill
rfkill unblock all
sudo rfkill unblock all

Then retest wireless using NetworkManager

Peter Frandsen (pfrandsen) said : #7

Hi Mark, thanx for your comments. I did the following:

sudo dpkg -r bcmwl-kernel-source
downloaded source: http://packages.ubuntu.com/maverick/i386/bcmwl-kernel-source/download
sudo apt-get install gdebi-core
cd Download
gdebi bcmwl-kernel-source_5.60.48.36+bdcom-0ubuntu5_i386.deb
rebooted, then did
sudo apt-get update && sudo apt-get install rfkill
rfkill unblock all
sudo rfkill unblock all

Result: Network shows: Device not ready (firmware missing)

Went to "Additional drivers" installed "Broadcom STA wireless driver" to see if that would give me the firmware - no luck. Back to square one...

/Peter

Try these commands instead:

wget http://mirror.pnl.gov/ubuntu//pool/restricted/b/bcmwl/bcmwl-kernel-source_5.60.48.36+bdcom-0ubuntu5_i386.deb

sudo dpkg -i bcmwl-kernel-source_5.60.48.36+bdcom-0ubuntu5_i386.deb

Then REBOOT and retest wireless.

Peter Frandsen (pfrandsen) said : #9

Hi Mark.

Unfortunately that did not work - and it made my lan connection not work... I then opened "system settings" -> hardware - "Additional drivers" and tried to reinstall "Broadcom STA wireless driver". That failed, but it brought back the lan connection!?!

OK, then please try "Alternate solution 1" in the following link:

http://www.computerandyou.net/2011/05/04/how-to-solve-no-wireless-networks-in-ubuntu-11-04/

Then reboot and retest wireless.

I have no further suggestions to make.

Peter Frandsen (pfrandsen) said : #11

The alternative solution seems* to work. Thanks a lot!

The reason I write seems is that I did a number of other things that might have influenced my system:

Download driver source and patch from http://www.broadcom.com/support/802.11/linux_sta.php
Unpacked it and changed directory to where i unpacked the source.
Then issued the following commands:

patch -p0 < 5_100_82_38.patch
make
sudo cp wl.ko /lib/modules/3.0.0-12-generic/kernel/net/wireless/
sudo depmod -a
sudo modprobe wl
sudo insmod /lib/modules/3.0.0-12-generic/kernel/net/wireless/wl.ko
modprobe lib80211

Rebooted. Wireless network not working. Then I followed this:
http://answers.downloadatoz.com/q,24289,ubuntu-11-10-beta-broadcom-bcm4311-wireless-not-work.html
which seem like the "Alternate solution 1" you point to. Rebooted - and finally I could connect to the wireless network :-) - and the wired network still works too ;-)