Dell D600 b43 wireless driver question

Asked by Chris LaMothe on 2011-10-12

Hello,

I'm fairly new to ubuntu and have a question in regards to the wireless driver on my laptop. It dual boots to windows which give's me some information on what drivers are compatible with my Dell truemobile 1400 wireless card.

in windows I use the broadcom driver 4.10.40.11

should I be able to run the same version of driver in ubuntu? Should I at least get into the right generation? 4.x.x.x

On the linux wireless website it shows my the same card able to work with the standard b43 driver
http://linuxwireless.org/en/users/Devices/PCI
"b43legacy should be used on all BCM4301 cards and BCM4306 cards with a 80211 core revision of 4 or less. b43 should be used on all other cards."

My question:
1. How do I tell which driver is loaded?
2. How do I make sure the latest driver is loaded?

I think my confusion comes from the error if I try to apt-get b43legacy. I get an error that I should use b43.
Also If Ishw -C network it says "driver=b43legacy "
I've tried to force b43-fwcutter to install the later version, but not sure if it's worked.
I've also tried to modprobe and modprobe blacklist to influence the driver selection, and am unsure if that works either.

I appreciate the help.

Thanks

user@ubuntu:~$ sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|ireless|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|ound|p54|prism|rtl|rt2|rt3|rt5|rt6|rt7|usb|witch|wl';sudo dmidecode|egrep 'Manufact|Product'; iwconfig; cat /etc/modprobe.d/* | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|wmi|witch|wl'; cat /var/lib/NetworkManager/NetworkManager.state; sudo hwinfo --netcard ; ps -aux|egrep 'icd|etwork'; sudo lsmod
Ign http://us.archive.ubuntu.com natty InRelease
Ign http://us.archive.ubuntu.com natty-updates InRelease
Ign http://security.ubuntu.com natty-security InRelease
Hit http://us.archive.ubuntu.com natty Release.gpg
Hit http://security.ubuntu.com natty-security Release.gpg
Hit http://us.archive.ubuntu.com natty-updates Release.gpg
Hit http://security.ubuntu.com natty-security Release
Hit http://us.archive.ubuntu.com natty Release
Hit http://us.archive.ubuntu.com natty-updates Release
Hit http://us.archive.ubuntu.com natty/main Sources
Hit http://us.archive.ubuntu.com natty/restricted Sources
Hit http://us.archive.ubuntu.com natty/universe Sources
Hit http://us.archive.ubuntu.com natty/multiverse Sources
Hit http://us.archive.ubuntu.com natty/main i386 Packages
Hit http://us.archive.ubuntu.com natty/restricted i386 Packages
Hit http://us.archive.ubuntu.com natty/universe i386 Packages
Hit http://us.archive.ubuntu.com natty/multiverse i386 Packages
Ign http://us.archive.ubuntu.com natty/main TranslationIndex
Ign http://us.archive.ubuntu.com natty/multiverse TranslationIndex
Ign http://us.archive.ubuntu.com natty/restricted TranslationIndex
Ign http://us.archive.ubuntu.com natty/universe TranslationIndex
Hit http://us.archive.ubuntu.com natty-updates/main Sources
Hit http://us.archive.ubuntu.com natty-updates/restricted Sources
Hit http://security.ubuntu.com natty-security/main Sources
Hit http://us.archive.ubuntu.com natty-updates/universe Sources
Hit http://us.archive.ubuntu.com natty-updates/multiverse Sources
Hit http://us.archive.ubuntu.com natty-updates/main i386 Packages
Hit http://us.archive.ubuntu.com natty-updates/restricted i386 Packages
Hit http://us.archive.ubuntu.com natty-updates/universe i386 Packages
Hit http://security.ubuntu.com natty-security/restricted Sources
Hit http://security.ubuntu.com natty-security/universe Sources
Hit http://security.ubuntu.com natty-security/multiverse Sources
Hit http://security.ubuntu.com natty-security/main i386 Packages
Hit http://us.archive.ubuntu.com natty-updates/multiverse i386 Packages
Ign http://us.archive.ubuntu.com natty-updates/main TranslationIndex
Ign http://us.archive.ubuntu.com natty-updates/multiverse TranslationIndex
Ign http://us.archive.ubuntu.com natty-updates/restricted TranslationIndex
Ign http://us.archive.ubuntu.com natty-updates/universe TranslationIndex
Hit http://security.ubuntu.com natty-security/restricted i386 Packages
Hit http://security.ubuntu.com natty-security/universe i386 Packages
Hit http://security.ubuntu.com natty-security/multiverse i386 Packages
Ign http://security.ubuntu.com natty-security/main TranslationIndex
Ign http://security.ubuntu.com natty-security/multiverse TranslationIndex
Ign http://security.ubuntu.com natty-security/restricted TranslationIndex
Ign http://security.ubuntu.com natty-security/universe TranslationIndex
Ign http://security.ubuntu.com natty-security/main Translation-en_US
Ign http://security.ubuntu.com natty-security/main Translation-en
Ign http://security.ubuntu.com natty-security/multiverse Translation-en_US
Ign http://security.ubuntu.com natty-security/multiverse Translation-en
Ign http://security.ubuntu.com natty-security/restricted Translation-en_US
Ign http://security.ubuntu.com natty-security/restricted Translation-en
Ign http://security.ubuntu.com natty-security/universe Translation-en_US
Ign http://security.ubuntu.com natty-security/universe Translation-en
Ign http://us.archive.ubuntu.com natty/main Translation-en_US
Ign http://us.archive.ubuntu.com natty/main Translation-en
Ign http://us.archive.ubuntu.com natty/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com natty/multiverse Translation-en
Ign http://us.archive.ubuntu.com natty/restricted Translation-en_US
Ign http://us.archive.ubuntu.com natty/restricted Translation-en
Ign http://us.archive.ubuntu.com natty/universe Translation-en_US
Ign http://us.archive.ubuntu.com natty/universe Translation-en
Ign http://us.archive.ubuntu.com natty-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/main Translation-en
Ign http://us.archive.ubuntu.com natty-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/multiverse Translation-en
Ign http://us.archive.ubuntu.com natty-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/restricted Translation-en
Ign http://us.archive.ubuntu.com natty-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com natty-updates/universe Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
grep is already the newest version.
hwinfo is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  *-network:0
       description: Ethernet interface
       product: NetXtreme BCM5705M Gigabit Ethernet
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 01
       serial: 00:0d:56:e6:b1:80
       capacity: 1Gbit/s
       width: 64 bits
       clock: 66MHz
       capabilities: pm vpd msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.116 firmware=5705-v3.16 latency=32 link=no mingnt=64 multicast=yes port=twisted pair
       resources: irq:11 memory:faff0000-faffffff
  *-network:1
       description: Network controller
       product: BCM4309 802.11a/b/g
       vendor: Broadcom Corporation
       physical id: 3
       bus info: pci@0000:02:03.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: driver=b43-pci-bridge latency=32
       resources: irq:5 memory:fafee000-fafeffff
  *-network
       description: Wireless interface
       physical id: 2
       logical name: wlan0
       serial: 00:90:4b:66:bc:ef
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=b43legacy driverversion=2.6.38-11-generic firmware=295.14 ip=192.168.2.107 link=yes multicast=yes wireless=IEEE 802.11bg
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Scan completed :
          Cell 01 - Address: 94:44:52:B5:22:B5
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=59/70 Signal level=-51 dBm
                    Encryption key:on
                    ESSID:"Net"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000002a6bac4b4c
                    Extra: Last beacon: 64ms ago
                    IE: Unknown: 00034E6574
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 030101
                    IE: Unknown: 2A0106
                    IE: Unknown: 32040C183060
                    IE: Unknown: 2D1A6E1117FFFF0000010000000000000000000000000C0000000000
                    IE: Unknown: 3D1601050700000000000000000000000000000000000000
                    IE: Unknown: 3E0100
                    IE: WPA Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: 7F0101
                    IE: Unknown: DD9E0050F204104A00011010440001021041000100103B0001031047001000000000000000011000944452B522B51021001242656C6B696E20436F72706F726174696F6E1023000A4637443233303120763110240007312E30302E31361042000E31323130333747323130333934361054000800060050F20400011011001B42656C6B696E20576972656C65737320526F757465722857464129100800020084
                    IE: Unknown: DD07000C4304000000
                    IE: Unknown: 0706555320010B10
                    IE: Unknown: DD1E00904C336E1117FFFF0000010000000000000000000000000C0000000000
                    IE: Unknown: DD1A00904C3401050700000000000000000000000000000000000000
          Cell 02 - Address: 00:12:FB:DF:86:86
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=38/70 Signal level=-72 dBm
                    Encryption key:on
                    ESSID:"SEC_LinkShare_393858"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=000000007cc4a152
                    Extra: Last beacon: 328ms ago
                    IE: Unknown: 00145345435F4C696E6B53686172655F333933383538
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 030106
                    IE: Unknown: 2A0104
                    IE: Unknown: 32040C183060
                    IE: Unknown: 2D1A6E1017FFFF000001000000000000000000000000000000000000
                    IE: Unknown: 3D1606070000000000000000000000000000000000000000
                    IE: Unknown: 3E0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: 0B0500000F127A
                    IE: Unknown: 7F0101
                    IE: Unknown: DD07000C4300000000
                    IE: Unknown: 0706545720010B10
                    IE: Unknown: DD1E00904C336E1017FFFF000001000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3406070000000000000000000000000000000000000000
                    IE: Unknown: DD9D0050F204104A0001101044000101103B00010310470010BC329E001DD811B286010012FBDF86861021001852616C696E6B20546563686E6F6C6F67792C20436F72702E1023001C52616C696E6B20576972656C6573732041636365737320506F696E74102400065254323836301042000831323334353637381054000800060050F20400011011000952616C696E6B415053100800020084103C000101
          Cell 03 - Address: C0:C1:C0:27:00:CD
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=32/70 Signal level=-78 dBm
                    Encryption key:on
                    ESSID:"ShortTiger"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000046ed89b517
                    Extra: Last beacon: 744ms ago
                    IE: Unknown: 000A53686F72745469676572
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030106
                    IE: Unknown: 050400010000
                    IE: Unknown: 2A0104
                    IE: Unknown: 2F0104
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1606001700000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F0101
                    IE: Unknown: DD0E0050F204104A0001101044000102
                    IE: Unknown: DD090010180203F0040000
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C33FC181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3406001700000000000000000000000000000000000000

auto lo
iface lo inet loopback

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"
00:00.0 Host bridge [0600]: Intel Corporation 82855PM Processor to I/O Controller [8086:3340] (rev 03)
00:01.0 PCI bridge [0604]: Intel Corporation 82855PM Processor to AGP Controller [8086:3341] (rev 03)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 [8086:24c2] (rev 01)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 [8086:24c4] (rev 01)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 [8086:24c7] (rev 01)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller [8086:24cd] (rev 01)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 81)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge [8086:24cc] (rev 01)
00:1f.1 IDE interface [0101]: Intel Corporation 82801DBM (ICH4-M) IDE Controller [8086:24ca] (rev 01)
00:1f.5 Multimedia audio controller [0401]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller [8086:24c5] (rev 01)
00:1f.6 Modem [0703]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller [8086:24c6] (rev 01)
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] [1002:4c66] (rev 02)
02:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5705M Gigabit Ethernet [14e4:165d] (rev 01)
02:01.0 CardBus bridge [0607]: O2 Micro, Inc. OZ711EC1 SmartCardBus Controller [1217:7113] (rev 20)
02:01.1 CardBus bridge [0607]: O2 Micro, Inc. OZ711EC1 SmartCardBus Controller [1217:7113] (rev 20)
02:03.0 Network controller [0280]: Broadcom Corporation BCM4309 802.11a/b/g [14e4:4324] (rev 02)
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
H/W path Device Class Description
=======================================================
                             system Portable Computer
/0 bus 0G5152
/0/0 memory 64KiB BIOS
/0/400 processor Intel(R) Pentium(R) M processor 1600
/0/400/700 memory 8KiB L1 cache
/0/400/701 memory 1MiB L2 cache
/0/1000 memory 2GiB System Memory
/0/1000/0 memory 1GiB DIMM DDR Synchronous 266 MHz (3
/0/1000/1 memory 1GiB DIMM DDR Synchronous 266 MHz (3
/0/100 bridge 82855PM Processor to I/O Controller
/0/100/1 bridge 82855PM Processor to AGP Controller
/0/100/1/0 display Radeon RV250 [Mobility FireGL 9000]
/0/100/1d bus 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
/0/100/1d.1 bus 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
/0/100/1d.2 bus 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
/0/100/1d.7 bus 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI
/0/100/1e bridge 82801 Mobile PCI Bridge
/0/100/1e/0 eth0 network NetXtreme BCM5705M Gigabit Ethernet
/0/100/1e/1 bridge OZ711EC1 SmartCardBus Controller
/0/100/1e/1.1 bridge OZ711EC1 SmartCardBus Controller
/0/100/1e/3 network BCM4309 802.11a/b/g
/0/100/1f bridge 82801DBM (ICH4-M) LPC Interface Brid
/0/100/1f.1 scsi0 storage 82801DBM (ICH4-M) IDE Controller
/0/100/1f.1/0 /dev/sda disk 40GB TOSHIBA MK4025GA
/0/100/1f.1/0/1 /dev/sda1 volume 37GiB Windows NTFS volume
/0/100/1f.1/1 /dev/cdrom disk RW/DVD GCC-4241N
/0/100/1f.5 multimedia 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
/0/100/1f.6 communication 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
/1 power DELL 0007Y35
/2 wlan0 network Wireless interface
Linux ubuntu 2.6.38-11-generic #50-Ubuntu SMP Mon Sep 12 21:18:14 UTC 2011 i686 i686 i386 GNU/Linux
[ 0.000000] APIC: switched to apic NOOP
[ 0.009447] SMP alternatives: switching to UP code
[ 0.094574] ACPI: ACPI Dock Station Driver: 1 docks/bays found
[ 0.094578] HEST: Table not found.
[ 0.121193] usbcore: registered new interface driver usbfs
[ 0.121211] usbcore: registered new interface driver hub
[ 0.121245] usbcore: registered new device driver usb
[ 0.121727] Switching to clocksource pit
[ 0.154183] pnp: PnP ACPI: found 13 devices
[ 0.191601] Switching to clocksource acpi_pm
[ 0.194330] Switched to NOHz mode on CPU #0
[ 0.250367] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input0
[ 0.250689] ACPI: Lid Switch [LID]
[ 0.269057] ERST: Table is not found!
[ 0.479485] i2c-core: driver [adp5520] using legacy suspend method
[ 0.479487] i2c-core: driver [adp5520] using legacy resume method
[ 0.508458] hub 1-0:1.0: USB hub found
[ 0.509018] hub 2-0:1.0: USB hub found
[ 0.509376] hub 3-0:1.0: USB hub found
[ 0.509938] hub 4-0:1.0: USB hub found
[ 0.564469] device-mapper: multipath: version 1.2.0 loaded
[ 0.564474] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 0.641517] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 0.868085] usb 1-1: new high speed USB device using ehci_hcd and address 2
[ 0.911659] isapnp: No Plug & Play device found
[ 1.519737] usbcore: registered new interface driver uas
[ 1.571514] scsi2 : usb-storage 1-1:1.0
[ 1.571906] usbcore: registered new interface driver usb-storage
[ 1.629499] tg3 0000:02:00.0: eth0: Tigon3 [partno(BCM95705A50) rev 3001] (PCI:33MHz:32-bit) MAC address 00:0d:56:e6:b1:80
[ 1.629507] tg3 0000:02:00.0: eth0: attached PHY is 5705 (10/100/1000Base-T Ethernet) (WireSpeed[1])
[ 1.629512] tg3 0000:02:00.0: eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[ 1.629516] tg3 0000:02:00.0: eth0: dma_rwctrl[763f0000] dma_mask[64-bit]
[ 1.631556] b43-pci-bridge 0000:02:03.0: PCI INT A -> Link[LNKB] -> GSI 5 (level, low) -> IRQ 5
[ 1.631600] ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x02, vendor 0x4243)
[ 1.631607] ssb: Core 1 found: IEEE 802.11 (cc 0x812, rev 0x04, vendor 0x4243)
[ 1.631614] ssb: Core 2 found: PCMCIA (cc 0x80D, rev 0x01, vendor 0x4243)
[ 1.631621] ssb: Core 3 found: V90 (cc 0x807, rev 0x01, vendor 0x4243)
[ 1.631627] ssb: Core 4 found: PCI (cc 0x804, rev 0x07, vendor 0x4243)
[ 1.631634] ssb: Core 5 found: IEEE 802.11 (cc 0x812, rev 0x04, vendor 0x4243)
[ 1.635330] ssb: Sonics Silicon Backplane found on PCI device 0000:02:03.0
[ 29.588884] lp: driver loaded but no devices found
[ 31.722106] yenta_cardbus 0000:02:01.0: CardBus bridge found [1028:011d]
[ 31.886921] yenta_cardbus 0000:02:01.1: CardBus bridge found [1028:011d]
[ 32.468347] Console: switching to colour frame buffer device 128x48
[ 32.488713] b43legacy-phy0: Broadcom 4306 WLAN found
[ 32.556487] b43legacy-phy0 debug: Found PHY: Analog 1, Type 2, Revision 1
[ 32.556510] b43legacy-phy0 debug: Found Radio: Manuf 0x17F, Version 0x2050, Revision 2
[ 32.588077] b43legacy-phy0 debug: Radio initialized
[ 32.665177] b43legacy-phy0 debug: Ignoring unconnected 802.11 core
[ 32.668684] Broadcom 43xx-legacy driver loaded [ Features: PLID, Firmware-ID: FW10 ]
[ 33.881326] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 34.640074] b43legacy-phy0: Loading firmware version 0x127, patch level 14 (2005-04-18 02:36:27)
[ 34.704570] b43legacy-phy0 debug: Chip initialized
[ 34.704844] b43legacy-phy0 debug: 30-bit DMA initialized
[ 34.708915] Registered led device: b43legacy-phy0::tx
[ 34.708955] Registered led device: b43legacy-phy0::rx
[ 34.708992] Registered led device: b43legacy-phy0::radio
[ 34.709026] b43legacy-phy0 debug: Wireless interface started
[ 34.716359] b43legacy-phy0 debug: Adding Interface type 2
[ 34.732335] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 50.280381] wlan0: authenticate with 94:44:52:b5:22:b5 (try 1)
[ 50.283804] wlan0: authenticated
[ 50.288114] wlan0: associate with 94:44:52:b5:22:b5 (try 1)
[ 50.291216] wlan0: RX AssocResp from 94:44:52:b5:22:b5 (capab=0x411 status=0 aid=3)
[ 50.291222] wlan0: associated
[ 50.291994] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 61.136032] wlan0: no IPv6 routers present
[ 201.852494] usb 1-1: USB disconnect, address 2
 Manufacturer: Dell Computer Corporation
 Product Name: Latitude D600
 Manufacturer: Dell Computer Corporation
 Product Name: 0G5152
 Manufacturer: Dell Computer Corporation
 Manufacturer: Intel
 Manufacturer: Not Specified
 Manufacturer: Not Specified
 Manufacturer: Sanyo
 SBDS Manufacture Date: 2004-08-07
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:"Net"
          Mode:Managed Frequency:2.412 GHz Access Point: 94:44:52:B5:22:B5
          Bit Rate=24 Mb/s Tx-Power=27 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off
          Link Quality=62/70 Signal level=-48 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:117 Invalid misc:410 Missed beacon:0

install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# which ath5k cannot recover. To prevent this condition, stop
blacklist ath_pci
blacklist eth1394
# replaced by p54pci
blacklist prism54
# replaced by b43 and ssb.
blacklist bcm43xx
#blacklist b43legacy
#blacklist b43
blacklist ndiswrapper
blacklist uart6850
blacklist twl4030_wdt
alias pci:v000014E4d00004311sv00000007sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004311sv00000008sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004311sv*sd*bc*sc*i* ndiswrapper
alias pci:v000014E4d00004312sv00000007sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004312sv00000008sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004312sv*sd*bc*sc*i* ndiswrapper
alias pci:v000014E4d00004318sv00000005sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004318sv00000006sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004318sv*sd*bc*sc*i* ndiswrapper
alias pci:v000014E4d00004319sv00000005sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004319sv00000006sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004319sv*sd*bc*sc*i* ndiswrapper
alias pci:v000014E4d00004320sv00000001sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004320sv00000002sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004320sv00000003sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004320sv00000004sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004320sv*sd*bc*sc*i* ndiswrapper
alias pci:v000014E4d00004324sv00000001sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004324sv00000002sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004324sv00000003sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004324sv00000004sd00001028bc*sc*i* ndiswrapper
alias pci:v000014E4d00004324sv*sd*bc*sc*i* ndiswrapper

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
> hal.1: read hal dataprocess 2273: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
21: PCI 200.0: 0200 Ethernet controller
  [Created at pci.318]
  Unique ID: rBUF.jGtOSOS7XzF
  Parent ID: 6NW+.+ISWpD3pbdC
  SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Dell Latitude D400"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x165d "NetXtreme BCM5705M Gigabit Ethernet"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x865d "Latitude D400"
  Revision: 0x01
  Driver: "tg3"
  Driver Modules: "tg3"
  Device File: eth0
  Memory Range: 0xfaff0000-0xfaffffff (rw,non-prefetchable)
  IRQ: 11 (145097 events)
  HW Address: 00:0d:56:e6:b1:80
  Link detected: no
  Module Alias: "pci:v000014E4d0000165Dsv00001028sd0000865Dbc02sc00i00"
  Driver Info #0:
    Driver Status: tg3 is active
    Driver Activation Cmd: "modprobe tg3"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #15 (PCI bridge)

24: PCI 203.0: 0282 WLAN controller
  [Created at pci.318]
  Unique ID: y9sn.QuElVHVlis5
  Parent ID: 6NW+.+ISWpD3pbdC
  SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:02:03.0
  SysFS BusID: 0000:02:03.0
  Hardware Class: network
  Model: "Dell Truemobile 1400"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4324 "BCM4309 802.11a/b/g"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x0001 "Truemobile 1400"
  Revision: 0x02
  Driver: "b43-pci-bridge"
  Driver Modules: "ssb"
  Device File: wlan0
  Features: WLAN
  Memory Range: 0xfafee000-0xfafeffff (rw,non-prefetchable)
  IRQ: 5 (79833 events)
  HW Address: 00:90:4b:66:bc:ef
  Link detected: yes
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000014E4d00004324sv00001028sd00000001bc02sc80i00"
  Driver Info #0:
    Driver Status: ssb is active
    Driver Activation Cmd: "modprobe ssb"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #15 (PCI bridge)
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root 713 0.0 0.2 25488 4560 ? Ssl 19:03 0:00 NetworkManager
root 1428 0.0 0.0 2552 1200 ? S 19:03 0:00 /sbin/dhclient -d -4 -sf /usr/lib/NetworkManager/nm-dhcp-client.action -pf /var/run/dhclient-wlan0.pid -lf /var/lib/dhcp/dhclient-be8ec322-6142-4574-b149-337271ce5f67-wlan0.lease -cf /var/run/nm-dhclient-wlan0.conf wlan0
user 2287 0.0 0.0 4148 840 pts/0 S+ 19:44 0:00 egrep --color=auto icd|etwork
Module Size Used by
cryptd 19801 0
aes_i586 16956 2
aes_generic 38023 1 aes_i586
nls_iso8859_1 12617 0
nls_cp437 12751 0
vfat 17335 0
fat 55505 1 vfat
binfmt_misc 13213 1
arc4 12473 2
b43legacy 127415 0
radeon 900494 3
snd_intel8x0 33213 2
snd_ac97_codec 105614 1 snd_intel8x0
ac97_bus 12642 1 snd_ac97_codec
snd_pcm 80042 2 snd_intel8x0,snd_ac97_codec
ttm 65184 1 radeon
mac80211 257001 1 b43legacy
drm_kms_helper 40745 1 radeon
snd_seq_midi 13132 0
snd_rawmidi 25269 1 snd_seq_midi
pcmcia 39671 0
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq 51291 2 snd_seq_midi,snd_seq_midi_event
joydev 17322 0
drm 184164 5 radeon,ttm,drm_kms_helper
snd_timer 28659 2 snd_pcm,snd_seq
cfg80211 156212 2 b43legacy,mac80211
yenta_socket 27230 0
ppdev 12849 0
snd_seq_device 14110 3 snd_seq_midi,snd_rawmidi,snd_seq
pcmcia_rsrc 18292 1 yenta_socket
pcmcia_core 21505 3 pcmcia,yenta_socket,pcmcia_rsrc
snd 55295 11 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
dcdbas 14054 0
i2c_algo_bit 13184 1 radeon
psmouse 73312 0
parport_pc 32111 1
soundcore 12600 1 snd
shpchp 32345 0
serio_raw 12990 0
snd_page_alloc 14073 2 snd_intel8x0,snd_pcm
video 18951 0
lp 13349 0
parport 36746 3 ppdev,parport_pc,lp
tg3 131476 0
usb_storage 43946 0
ssb 45942 1 b43legacy
uas 17676 0
user@ubuntu:~$

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu b43-fwcutter Edit question
Assignee:
No assignee Edit question
Solved by:
Chris LaMothe
Solved:
2011-10-19
Last query:
2011-10-19
Last reply:
2011-10-15
Ubfan (ubfan1) said : #1

the 4309 number is one I have not seen before, but the 4324 is listed under a 4306 and it clearly needs the b43legacy driver, which you have gotten setup and working.
02:03.0 Network controller [0280]: Broadcom Corporation BCM4309 802.11a/b/g [14e4:4324] (rev 02)
You have the correct driver for your chip, no need to "upgrade".
The lsmod output shows what is loaded, and b43legacy is there.
The b43-fwcutter installs the Broadcom firmware, the b43 and b43legacy are present by default I think.

Chris LaMothe (clamothe) said : #2

Ubfan,

Thanks for the reply. This is a bit strange as I noticed earlier that 14e4:4324 is listed as BCM4306. If I do "sudo apt-get install firmware-b43legacy-installer" it tells me that no compatible hardware is present. When I do "sudo apt-get install firmware-b43-installer" I get a similar message.

I think I finally have it working by blacklisting all others then "modprobe -r ssb ndiswrapper b43 b43legacy" and "modprobe -v b43legacy"

The only issue I have now is that it doesn't stay on reboot. Do you know how I make that change stick?

You could add those commands (*without* sudo) to the file /etc/rc.local, below the comments (lines starting with #) and above the line that says "exit 0".

You can first back up this file by running:

sudo cp /etc/rc.local /etc/rc.local.old

Then you can open the file as root (so you can make changes to it) with:

gksu gedit /etc/rc.local

Chris LaMothe (clamothe) said : #4

Hmm. It now isn't working at all.

Lsmod shows :
Kernel driver in use b43-pci-bridge
Kernel modules: SSB

It associates with the AP and gets an IP address. I can't ping the ap though.

Lsmod shows ssb being used by b43legacy.

I tried to rmmod -f ssb but it says error: in use.

Any ideas?

Did it stop working since you edited /etc/rc.local, or did it stop working by itself, without your having edited that file?

Chris LaMothe (clamothe) said : #6

I rebooted it at least 4 times to make sure I was giving the right information. On the 5th reboot, it connected to wireless which was different. I didn't make any changes to make this happen.

I then decided to blow the whole installation and install 11.10. I have exactly the same problem with a completely clean install.

Why does SSB continue to load even though it's blacklisted

Chris LaMothe (clamothe) said : #7

solved:

After a clean install of 11.10 I found the best solution was to not install "firmware-b43legacy-installer" It errors out and tells you to install "firmware-b43-installer". The b43 installer then tells you to install b43legacy.

I followed the instructions for other distributions at :http://linuxwireless.org/en/users/Drivers/b43

Manually build b43-cutter (to avoid either package above)

   1 wget http://bu3sch.de/b43/fwcutter/b43-fwcutter-015.tar.bz2
   2 tar xjf b43-fwcutter-015.tar.bz2
   3 cd b43-fwcutter-015
   4 make
   5 sudo make install
   6 cd ..

Then manually install firmware

   1 export FIRMWARE_INSTALL_DIR="/lib/firmware"
   2 wget http://downloads.openwrt.org/sources/wl_apsta-3.130.20.0.o
   3 sudo b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" wl_apsta-3.130.20.0.o

Finally mod-probe -r b43legacy and mod-probe -v b43legacy

Valhalla!

The interesting thing to me is you can clearly see in the above logs that it shows this being a BCM4309. The PCI id identifies it as a BCM4306. If I use the installer packages, it gets screwy. If I manually install it shows as being a BCM4306.

I'm still a little new, but does this indicate some sort of bug in the installer package?