b43 driver blacklisted due to installation of bcmwl-kernel-source -> UNCLAIMED Wireless Network controller [0280]: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller [14e4:4320] (rev 03) not working on Evesham Axis 64 MKR in Ubuntu 11.04

Asked by Jamie on 2011-07-19

I am new to Ubuntu and I am trying to install a driver to enable my wireless. I am using this link (https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx) to install the drivers. However, when I get to step two and attempt to enable the driver, none are listed. I have tried re-installation and restarting the computer, is there anything else I could try? Any help would be most appreciated. Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu b43-fwcutter Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2011-07-20
Last query:
2011-07-20
Last reply:
2011-07-20

Hi,

Please first connect your wired network adapter to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1:

If you are using the Gnome interface, open the Terminal console via "Applications->Accessories->Terminal"

If you are using the Unity interface, the easiest way to open the Terminal is to use the 'search' function on the dash. Or you can click on the 'More Apps' button, click on the 'See more results' by the installed section, and find it in that list of applications. A third way, available after you click on the 'More Apps' button, is to go to the search bar, and see that the far right end of it says 'All Applications'. You then click on that, and you'll see the full list. Then you can go to Accessories > Terminal after that.

So the methods in Unity are:
Dash > Search for Terminal
Dash > More Apps > 'See More Results' > Terminal
Dash > More Apps > Accessories > Terminal

Step 2: Please copy-paste the following command from https://help.ubuntu.com/community/WirelessTroubleshootingProcedure in Firefox into the Linux Terminal. Do NOT copy-paste from the Email message into the Terminal, as that will only copy PART of the command. The command STARTS with the word sudo and ENDS with the word lsmod. So please copy-paste the ENTIRE command below from Firefox into a Terminal, press <enter>, then enter password when sudo asks for password, then press enter again.

Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the command written on the page. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|ireless|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|ound|p54|prism|rtl|rt2|rt3|rt5|rt6|rt7|usb|witch|wl';sudo dmidecode|egrep 'Manufact|Product'; iwconfig; cat /etc/modprobe.d/* | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|witch|wl'; cat /var/lib/NetworkManager/NetworkManager.state; sudo hwinfo --netcard ; ps -aux|egrep 'icd|etwork'; sudo lsmod

Step 3: Please post results (copy/paste terminal output) on this thread. The troubleshooters here need to see the full Terminal output from running the above command.

Step 4: Please also specify the exact model and make of your PC (if known) on this thread

Step 5: Please also clarify if you installed Ubuntu to the harddisk and are running from a harddisk install OR if you are only testing Ubuntu in a LiveCD session.

Regards,

Mark

Jamie (jamiecmcf) said : #2

This is the output from that command. Also I am running Ubuntu from the harddisk. As for the make and model of my PC I believe it is an Evesham Axis 64 MKR.

Hit http://ppa.launchpad.net natty/main i386 Packages
Ign http://ppa.launchpad.net natty/main TranslationIndex
Ign http://archive.canonical.com natty/partner TranslationIndex
Get:6 http://security.ubuntu.com natty-security/main Sources [59.6 kB]
Hit http://extras.ubuntu.com natty/main i386 Packages
Ign http://extras.ubuntu.com natty/main TranslationIndex
Hit http://gb.archive.ubuntu.com natty/main Sources
Hit http://gb.archive.ubuntu.com natty/restricted Sources
Hit http://gb.archive.ubuntu.com natty/universe Sources
Hit http://gb.archive.ubuntu.com natty/multiverse Sources
Hit http://gb.archive.ubuntu.com natty/main i386 Packages
Hit http://gb.archive.ubuntu.com natty/restricted i386 Packages
Hit http://gb.archive.ubuntu.com natty/universe i386 Packages
Hit http://gb.archive.ubuntu.com natty/multiverse i386 Packages
Ign http://gb.archive.ubuntu.com natty/main TranslationIndex
Ign http://gb.archive.ubuntu.com natty/multiverse TranslationIndex
Ign http://gb.archive.ubuntu.com natty/restricted TranslationIndex
Get:7 http://security.ubuntu.com natty-security/restricted Sources [14 B]
Get:8 http://security.ubuntu.com natty-security/universe Sources [7,727 B]
Get:9 http://security.ubuntu.com natty-security/multiverse Sources [658 B]
Get:10 http://security.ubuntu.com natty-security/main i386 Packages [153 kB]
Ign http://gb.archive.ubuntu.com natty/universe TranslationIndex
Get:11 http://gb.archive.ubuntu.com natty-updates/main Sources [94.7 kB]
Get:12 http://security.ubuntu.com natty-security/restricted i386 Packages [14 B]
Get:13 http://security.ubuntu.com natty-security/universe i386 Packages [25.3 kB]
Get:14 http://security.ubuntu.com natty-security/multiverse i386 Packages [2,074 B]
Ign http://security.ubuntu.com natty-security/main TranslationIndex
Ign http://security.ubuntu.com natty-security/multiverse TranslationIndex
Ign http://security.ubuntu.com natty-security/restricted TranslationIndex
Ign http://security.ubuntu.com natty-security/universe TranslationIndex
Ign http://archive.canonical.com natty/partner Translation-en_GB
Ign http://ppa.launchpad.net natty/main Translation-en_GB
Ign http://archive.canonical.com natty/partner Translation-en
Ign http://ppa.launchpad.net natty/main Translation-en
Ign http://extras.ubuntu.com natty/main Translation-en_GB
Get:15 http://gb.archive.ubuntu.com natty-updates/restricted Sources [14 B]
Get:16 http://gb.archive.ubuntu.com natty-updates/universe Sources [18.9 kB]
Get:17 http://gb.archive.ubuntu.com natty-updates/multiverse Sources [1,893 B]
Get:18 http://gb.archive.ubuntu.com natty-updates/main i386 Packages [277 kB]
Ign http://extras.ubuntu.com natty/main Translation-en
Ign http://security.ubuntu.com natty-security/main Translation-en_GB
Ign http://security.ubuntu.com natty-security/main Translation-en
Ign http://security.ubuntu.com natty-security/multiverse Translation-en_GB
Ign http://security.ubuntu.com natty-security/multiverse Translation-en
Ign http://security.ubuntu.com natty-security/restricted Translation-en_GB
Ign http://security.ubuntu.com natty-security/restricted Translation-en
Ign http://security.ubuntu.com natty-security/universe Translation-en_GB
Ign http://security.ubuntu.com natty-security/universe Translation-en
Get:19 http://gb.archive.ubuntu.com natty-updates/restricted i386 Packages [14 B]
Get:20 http://gb.archive.ubuntu.com natty-updates/universe i386 Packages [70.5 kB]
Get:21 http://gb.archive.ubuntu.com natty-updates/multiverse i386 Packages [4,267 B]
Ign http://gb.archive.ubuntu.com natty-updates/main TranslationIndex
Ign http://gb.archive.ubuntu.com natty-updates/multiverse TranslationIndex
Ign http://gb.archive.ubuntu.com natty-updates/restricted TranslationIndex
Ign http://gb.archive.ubuntu.com natty-updates/universe TranslationIndex
Hit http://gb.archive.ubuntu.com natty/main Translation-en_GB
Hit http://gb.archive.ubuntu.com natty/multiverse Translation-en_GB
Hit http://gb.archive.ubuntu.com natty/restricted Translation-en_GB
Hit http://gb.archive.ubuntu.com natty/universe Translation-en_GB
Ign http://gb.archive.ubuntu.com natty/main Translation-en
Ign http://gb.archive.ubuntu.com natty/multiverse Translation-en
Ign http://gb.archive.ubuntu.com natty/restricted Translation-en
Ign http://gb.archive.ubuntu.com natty/universe Translation-en
Ign http://gb.archive.ubuntu.com natty-updates/main Translation-en_GB
Ign http://gb.archive.ubuntu.com natty-updates/main Translation-en
Ign http://gb.archive.ubuntu.com natty-updates/multiverse Translation-en_GB
Ign http://gb.archive.ubuntu.com natty-updates/multiverse Translation-en
Ign http://gb.archive.ubuntu.com natty-updates/restricted Translation-en_GB
Ign http://gb.archive.ubuntu.com natty-updates/restricted Translation-en
Ign http://gb.archive.ubuntu.com natty-updates/universe Translation-en_GB
Ign http://gb.archive.ubuntu.com natty-updates/universe Translation-en
Fetched 771 kB in 7s (97.9 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
grep is already the newest version.
The following extra packages will be installed:
  libhal1 libhd16
The following NEW packages will be installed
  hwinfo libhal1 libhd16
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 818 kB of archives.
After this operation, 2,269 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://gb.archive.ubuntu.com/ubuntu/ natty/universe libhal1 i386 0.5.14-5+svn1 [74.4 kB]
Get:2 http://gb.archive.ubuntu.com/ubuntu/ natty/universe libhd16 i386 16.0-2 [698 kB]
Get:3 http://gb.archive.ubuntu.com/ubuntu/ natty/universe hwinfo i386 16.0-2 [46.1 kB]
Fetched 818 kB in 15s (52.1 kB/s)
Selecting previously deselected package libhal1.
(Reading database ... 168665 files and directories currently installed.)
Unpacking libhal1 (from .../libhal1_0.5.14-5+svn1_i386.deb) ...
Selecting previously deselected package libhd16.
Unpacking libhd16 (from .../libhd16_16.0-2_i386.deb) ...
Selecting previously deselected package hwinfo.
Unpacking hwinfo (from .../hwinfo_16.0-2_i386.deb) ...
Processing triggers for man-db ...
Setting up libhal1 (0.5.14-5+svn1) ...
Setting up libhd16 (16.0-2) ...
Setting up hwinfo (16.0-2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
  *-network UNCLAIMED
       description: Network controller
       product: BCM4306 802.11b/g Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 7
       bus info: pci@0000:01:07.0
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master
       configuration: latency=32
       resources: memory:fe9fc000-fe9fdfff
  *-network
       description: Ethernet interface
       product: 88E8053 PCI-E Gigabit Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 15
       serial: 00:11:09:da:18:62
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.28 duplex=full firmware=N/A ip=192.168.1.66 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:44 memory:fe600000-fe603fff ioport:be00(size=256) memory:fe500000-fe51ffff
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth1 Interface doesn't support scanning.

auto lo
iface lo inet loopback

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"
00:00.0 Memory controller [0580]: nVidia Corporation CK804 Memory Controller [10de:005e] (rev a3)
00:01.0 ISA bridge [0601]: nVidia Corporation CK804 ISA Bridge [10de:0050] (rev a3)
00:01.1 SMBus [0c05]: nVidia Corporation CK804 SMBus [10de:0052] (rev a2)
00:02.0 USB Controller [0c03]: nVidia Corporation CK804 USB Controller [10de:005a] (rev a2)
00:02.1 USB Controller [0c03]: nVidia Corporation CK804 USB Controller [10de:005b] (rev a3)
00:04.0 Multimedia audio controller [0401]: nVidia Corporation CK804 AC'97 Audio Controller [10de:0059] (rev a2)
00:06.0 IDE interface [0101]: nVidia Corporation CK804 IDE [10de:0053] (rev a2)
00:07.0 IDE interface [0101]: nVidia Corporation CK804 Serial ATA Controller [10de:0054] (rev a3)
00:09.0 PCI bridge [0604]: nVidia Corporation CK804 PCI Bridge [10de:005c] (rev a2)
00:0a.0 Bridge [0680]: nVidia Corporation CK804 Ethernet Controller [10de:0057] (rev a3)
00:0b.0 PCI bridge [0604]: nVidia Corporation CK804 PCIE Bridge [10de:005d] (rev a3)
00:0c.0 PCI bridge [0604]: nVidia Corporation CK804 PCIE Bridge [10de:005d] (rev a3)
00:0d.0 PCI bridge [0604]: nVidia Corporation CK804 PCIE Bridge [10de:005d] (rev a3)
00:0e.0 PCI bridge [0604]: nVidia Corporation CK804 PCIE Bridge [10de:005d] (rev a3)
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
01:07.0 Network controller [0280]: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller [14e4:4320] (rev 03)
01:09.0 Communication controller [0780]: Conexant Systems, Inc. HSF 56k HSFi Modem [14f1:2f00] (rev 01)
01:0c.0 FireWire (IEEE 1394) [0c00]: VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller [1106:3044] (rev 80)
03:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller [11ab:4362] (rev 15)
05:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV410 [Radeon X700] [1002:5e4f]
05:00.1 Display controller [0380]: ATI Technologies Inc Device [1002:5e6f]
Bus 002 Device 007: ID 1c4f:0003 SiGma Micro HID controller
Bus 002 Device 002: ID 55aa:b012 OnSpec Electronic, Inc. Mitsumi FA402M 8-in-2 Card Reader
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
H/W path Device Class Description
=======================================================
                             system Desktop Computer
/0 bus MS-7125
/0/0 memory 128KiB BIOS
/0/3 processor AMD Athlon(tm) 64 Processor 3200+
/0/3/a memory 128KiB L1 cache
/0/3/b memory 512KiB L2 cache
/0/1b memory 512MiB System Memory
/0/1b/0 memory 256MiB DIMM
/0/1b/1 memory 256MiB DIMM
/0/1b/2 memory DIMM [empty]
/0/1b/3 memory DIMM [empty]
/0/4 memory Memory controller
/0/1 bridge CK804 ISA Bridge
/0/1.1 bus CK804 SMBus
/0/2 bus CK804 USB Controller
/0/2.1 bus CK804 USB Controller
/0/5 multimedia CK804 AC'97 Audio Controller
/0/6 scsi1 storage CK804 IDE
/0/6/0.0.0 /dev/cdrom disk DVD RW DW-D22A
/0/6/0.1.0 /dev/cdrom1 disk CD-RW CRX230ED
/0/7 scsi2 storage CK804 Serial ATA Controller
/0/7/0.0.0 /dev/sda disk 160GB MAXTOR STM316021
/0/7/0.0.0/1 /dev/sda1 volume 49GiB Windows NTFS volume
/0/7/0.0.0/2 /dev/sda2 volume 99GiB Extended partition
/0/7/0.0.0/2/5 /dev/sda5 volume 509MiB Linux swap / Solaris partitio
/0/7/0.0.0/2/6 /dev/sda6 volume 98GiB Linux filesystem partition
/0/7/0.0.0/2/7 /dev/sda7 volume 508MiB Linux swap / Solaris partitio
/0/9 bridge CK804 PCI Bridge
/0/9/7 network BCM4306 802.11b/g Wireless LAN Contr
/0/9/9 communication HSF 56k HSFi Modem
/0/9/c bus VT6306/7/8 [Fire II(M)] IEEE 1394 OH
/0/a eth1 bridge CK804 Ethernet Controller
/0/b bridge CK804 PCIE Bridge
/0/c bridge CK804 PCIE Bridge
/0/c/0 eth0 network 88E8053 PCI-E Gigabit Ethernet Contr
/0/d bridge CK804 PCIE Bridge
/0/e bridge CK804 PCIE Bridge
/0/e/0 display RV410 [Radeon X700]
/0/e/0.1 display ATI Technologies Inc
/0/100 bridge K8 [Athlon64/Opteron] HyperTransport
/0/101 bridge K8 [Athlon64/Opteron] Address Map
/0/102 bridge K8 [Athlon64/Opteron] DRAM Controlle
/0/103 bridge K8 [Athlon64/Opteron] Miscellaneous
/0/8 scsi4 storage
/0/8/0.0.0 /dev/sdb disk SCSI Disk
/0/8/0.0.1 /dev/sdc disk SCSI Disk
Linux jamie-MS-7125 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:05:41 UTC 2011 i686 athlon i386 GNU/Linux
[ 0.000000] found SMP MP-table at [c00f5100] f5100
[ 0.005023] SMP alternatives: switching to UP code
[ 0.078870] ACPI: No dock devices found.
[ 0.078873] HEST: Table not found.
[ 0.109878] usbcore: registered new interface driver usbfs
[ 0.109895] usbcore: registered new interface driver hub
[ 0.109927] usbcore: registered new device driver usb
[ 0.121512] pnp: PnP ACPI: found 13 devices
[ 0.158028] Switching to clocksource acpi_pm
[ 0.169025] Switched to NOHz mode on CPU #0
[ 0.172081] pci 0000:00:00.0: Found enabled HT MSI Mapping
[ 0.172088] pci 0000:00:0b.0: Found disabled HT MSI Mapping
[ 0.172095] pci 0000:00:00.0: Found enabled HT MSI Mapping
[ 0.172135] pci 0000:00:00.0: Found enabled HT MSI Mapping
[ 0.172141] pci 0000:00:0c.0: Found disabled HT MSI Mapping
[ 0.172148] pci 0000:00:00.0: Found enabled HT MSI Mapping
[ 0.172190] pci 0000:00:00.0: Found enabled HT MSI Mapping
[ 0.172196] pci 0000:00:0d.0: Found disabled HT MSI Mapping
[ 0.172203] pci 0000:00:00.0: Found enabled HT MSI Mapping
[ 0.172248] pci 0000:00:00.0: Found enabled HT MSI Mapping
[ 0.172254] pci 0000:00:0e.0: Found disabled HT MSI Mapping
[ 0.172261] pci 0000:00:00.0: Found enabled HT MSI Mapping
[ 0.219590] ERST: Table is not found!
[ 0.354733] i2c-core: driver [adp5520] using legacy suspend method
[ 0.354735] i2c-core: driver [adp5520] using legacy resume method
[ 0.407746] hub 1-0:1.0: USB hub found
[ 0.546204] hub 2-0:1.0: USB hub found
[ 0.552202] device-mapper: multipath: version 1.2.0 loaded
[ 0.552208] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 0.596878] powernow-k8: Found 1 AMD Athlon(tm) 64 Processor 3200+ (1 cpu cores) (version 2.20.00)
[ 0.597474] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 0.816614] isapnp: No Plug & Play device found
[ 1.180079] Switching to clocksource tsc
[ 1.199098] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.64.
[ 1.199311] forcedeth 0000:00:0a.0: PCI INT A -> Link[APCH] -> GSI 20 (level, low) -> IRQ 20
[ 1.199317] forcedeth 0000:00:0a.0: setting latency timer to 64
[ 1.208568] sky2 0000:03:00.0: eth0: addr 00:11:09:da:18:62
[ 1.240049] usb 2-3: new full speed USB device using ohci_hcd and address 2
[ 1.462041] usbcore: registered new interface driver uas
[ 1.720861] forcedeth 0000:00:0a.0: ifname eth1, PHY OUI 0x5043 @ 1, addr 00:11:09:da:18:63
[ 1.720866] forcedeth 0000:00:0a.0: highdma csum gbit lnktim desc-v3
[ 1.760017] usb 2-8: new low speed USB device using ohci_hcd and address 3
[ 2.233702] usb 2-8: USB disconnect, address 3
[ 2.645686] usbcore: registered new interface driver usbhid
[ 2.645690] usbhid: USB HID core driver
[ 2.648314] scsi4 : usb-storage 2-3:1.0
[ 2.650123] usbcore: registered new interface driver usb-storage
[ 3.216019] usb 2-8: new low speed USB device using ohci_hcd and address 4
[ 3.439558] input: SIGMACH1P U+P Mouse as /devices/pci0000:00/0000:00:02.0/usb2/2-8/2-8:1.0/input/input3
[ 3.439683] generic-usb 0003:1C4F:0003.0001: input,hidraw0: USB HID v1.10 Mouse [SIGMACH1P U+P Mouse] on usb-0000:00:02.0-8/input0
[ 12.811619] usb 2-8: USB disconnect, address 4
[ 13.644828] usb 2-8: new low speed USB device using ohci_hcd and address 5
[ 13.719721] lp: driver loaded but no devices found
[ 13.931861] input: SIGMACH1P U+P Mouse as /devices/pci0000:00/0000:00:02.0/usb2/2-8/2-8:1.0/input/input4
[ 13.932059] generic-usb 0003:1C4F:0003.0002: input,hidraw0: USB HID v1.10 Mouse [SIGMACH1P U+P Mouse] on usb-0000:00:02.0-8/input0
[ 14.174014] usb 2-8: USB disconnect, address 5
[ 14.627988] forcedeth 0000:00:0a.0: eth1: no link during initialization
[ 14.632414] ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 14.648665] sky2 0000:03:00.0: eth0: enabling interface
[ 14.653541] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 15.156053] usb 2-8: new low speed USB device using ohci_hcd and address 6
[ 15.382621] input: SIGMACH1P U+P Mouse as /devices/pci0000:00/0000:00:02.0/usb2/2-8/2-8:1.0/input/input5
[ 15.382772] generic-usb 0003:1C4F:0003.0003: input,hidraw0: USB HID v1.10 Mouse [SIGMACH1P U+P Mouse] on usb-0000:00:02.0-8/input0
[ 15.610329] Console: switching to colour frame buffer device 160x64
[ 15.671686] usb 2-8: USB disconnect, address 6
[ 16.351068] sky2 0000:03:00.0: eth0: Link is up at 100 Mbps, full duplex, flow control both
[ 16.351122] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 16.648089] usb 2-8: new low speed USB device using ohci_hcd and address 7
[ 16.876620] input: SIGMACH1P U+P Mouse as /devices/pci0000:00/0000:00:02.0/usb2/2-8/2-8:1.0/input/input6
[ 16.876767] generic-usb 0003:1C4F:0003.0004: input,hidraw0: USB HID v1.10 Mouse [SIGMACH1P U+P Mouse] on usb-0000:00:02.0-8/input0
[ 26.544007] eth0: no IPv6 routers present
[ 79.436280] Switching to clocksource acpi_pm
 Manufacturer: eveshamvale.
 Product Name: MS-7125
 Manufacturer: eveshamvale
 Product Name: MS-7125
 Manufacturer: eveshamvale
 Manufacturer: AMD
 Manufacturer: None
 Manufacturer: None
 Manufacturer: None
 Manufacturer: None
lo no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.

# which ath5k cannot recover. To prevent this condition, stop
blacklist ath_pci
# Warning: This file is autogenerated by bcmwl. All changes to this file will be lost.
blacklist b43
blacklist b43legacy
blacklist bcm43xx
blacklist brcm80211
blacklist eth1394
# replaced by p54pci
blacklist prism54
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist uart6850
blacklist twl4030_wdt

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
> hal.1: read hal dataprocess 2343: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
19: PCI 0a.0: 0200 Ethernet controller
  [Created at pci.318]
  Unique ID: JNkJ.YcJ5ud3aJX9
  SysFS ID: /devices/pci0000:00/0000:00:0a.0
  SysFS BusID: 0000:00:0a.0
  Hardware Class: network
  Model: "nVidia CK804 Ethernet Controller"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0057 "CK804 Ethernet Controller"
  SubVendor: pci 0x1462 "Micro-Star International Co., Ltd."
  SubDevice: pci 0x7125
  Revision: 0xa3
  Driver: "forcedeth"
  Driver Modules: "forcedeth"
  Device File: eth1
  Memory Range: 0xfebfa000-0xfebfafff (rw,non-prefetchable)
  I/O Ports: 0xf500-0xf507 (rw)
  IRQ: 20 (no events)
  HW Address: 00:11:09:da:18:63
  Link detected: no
  Module Alias: "pci:v000010DEd00000057sv00001462sd00007125bc06sc80i00"
  Driver Info #0:
    Driver Status: forcedeth is active
    Driver Activation Cmd: "modprobe forcedeth"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

28: PCI 107.0: 0280 Network controller
  [Created at pci.318]
  Unique ID: 2_DJ.LgLF88rrRc6
  Parent ID: WL76.vuIf6LvchL4
  SysFS ID: /devices/pci0000:00/0000:00:09.0/0000:01:07.0
  SysFS BusID: 0000:01:07.0
  Hardware Class: network
  Model: "Broadcom BCM4306 802.11b/g Wireless LAN Controller"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4320 "BCM4306 802.11b/g Wireless LAN Controller"
  SubVendor: pci 0x1737 "Linksys"
  SubDevice: pci 0x0013
  Revision: 0x03
  Memory Range: 0xfe9fc000-0xfe9fdfff (rw,non-prefetchable)
  IRQ: 12 (no events)
  Module Alias: "pci:v000014E4d00004320sv00001737sd00000013bc02sc80i00"
  Driver Info #0:
    Driver Status: ssb is not active
    Driver Activation Cmd: "modprobe ssb"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #18 (PCI bridge)

31: PCI 300.0: 0200 Ethernet controller
  [Created at pci.318]
  Unique ID: rBUF.BGjDvaZOkLA
  Parent ID: lgGW.wxFwtL2jas4
  SysFS ID: /devices/pci0000:00/0000:00:0c.0/0000:03:00.0
  SysFS BusID: 0000:03:00.0
  Hardware Class: network
  Model: "Micro-Star International Marvell 88E8053 Gigabit Ethernet Controller (MSI)"
  Vendor: pci 0x11ab "Marvell Technology Group Ltd."
  Device: pci 0x4362 "88E8053 PCI-E Gigabit Ethernet Controller"
  SubVendor: pci 0x1462 "Micro-Star International Co., Ltd."
  SubDevice: pci 0x058c "Marvell 88E8053 Gigabit Ethernet Controller (MSI)"
  Revision: 0x15
  Driver: "sky2"
  Driver Modules: "sky2"
  Device File: eth0
  Memory Range: 0xfe600000-0xfe603fff (rw,non-prefetchable)
  I/O Ports: 0xbe00-0xbeff (rw)
  Memory Range: 0xfe500000-0xfe51ffff (ro,non-prefetchable,disabled)
  IRQ: 44 (8592 events)
  HW Address: 00:11:09:da:18:62
  Link detected: yes
  Module Alias: "pci:v000011ABd00004362sv00001462sd0000058Cbc02sc00i00"
  Driver Info #0:
    Driver Status: sky2 is active
    Driver Activation Cmd: "modprobe sky2"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #21 (PCI bridge)
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root 701 0.0 0.5 25748 2808 ? Ssl 12:52 0:00 NetworkManager
root 870 0.0 0.6 21424 3456 ? S 12:52 0:00 /usr/bin/python -O /usr/share/wicd/daemon/wicd-daemon.py
root 1059 0.0 0.1 2552 592 ? S 12:52 0:00 /sbin/dhclient -d -4 -sf /usr/lib/NetworkManager/nm-dhcp-client.action -pf /var/run/dhclient-eth0.pid -lf /var/lib/dhcp/dhclient-93636dd8-a305-4188-a24a-ea3151bf5bc1-eth0.lease -cf /var/run/nm-dhclient-eth0.conf eth0
root 1074 0.0 0.7 12080 4008 ? S 12:52 0:00 /usr/bin/python -O /usr/share/wicd/daemon/monitor.py
jamie 2361 0.0 0.1 4152 836 pts/0 S+ 12:58 0:00 egrep --color=auto icd|etwork
Module Size Used by
joydev 17322 0
binfmt_misc 13213 1
snd_intel8x0 33213 1
snd_ac97_codec 105614 1 snd_intel8x0
ac97_bus 12642 1 snd_ac97_codec
snd_pcm 80042 2 snd_intel8x0,snd_ac97_codec
snd_seq_midi 13132 0
snd_rawmidi 25269 1 snd_seq_midi
radeon 900494 3
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq 51291 2 snd_seq_midi,snd_seq_midi_event
snd_timer 28659 2 snd_pcm,snd_seq
ttm 65184 1 radeon
snd_seq_device 14110 3 snd_seq_midi,snd_rawmidi,snd_seq
ppdev 12849 0
snd 55295 9 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
drm_kms_helper 40745 1 radeon
drm 180037 5 radeon,ttm,drm_kms_helper
soundcore 12600 1 snd
snd_page_alloc 14073 2 snd_intel8x0,snd_pcm
k8temp 12872 0
parport_pc 32111 1
i2c_algo_bit 13184 1 radeon
i2c_nforce2 12906 0
lp 13349 0
parport 36746 3 ppdev,parport_pc,lp
usbhid 41704 0
firewire_ohci 31504 0
usb_storage 43946 0
hid 77084 1 usbhid
uas 17676 0
firewire_core 56138 1 firewire_ohci
crc_itu_t 12627 1 firewire_core
sata_nv 23176 2
sky2 49172 0
forcedeth 58190 0
pata_amd 13762 0
floppy 60032 0

Thanks for all your help,
Jamie

The main problem is that your BCM4306 802.11b/g Wireless LAN Controller does not have any driver loaded for it. This is because the b43 driver is being blacklisted by a configuration file located in the directory /etc/modprobe.d. The configuration file that is blacklisting the b43 driver is likely /etc/modprobe.d/blacklist.conf

You will first need to run the following commands using a WIRED Internet connection:

sudo apt-get update

sudo apt-get remove --purge bcmwl-kernel-source

Then please run the following command:

gksudo gedit /etc/modprobe.d/blacklist.conf

Using the gedit editor, please REMOVE the following configuration lines in
the /etc/modprobe.d/blacklist.conf file:

blacklist b43
blacklist b43legacy

SAVE the change to the /etc/modprobe.d/blacklist.conf file after removing the configuration lines.

Then please proceed with the following commands:

sudo apt-get update
sudo apt-get install b43-fwcutter firmware-b43-installer

b43-fwcutter exists in the Ubuntu repositories, but you will need a
working wired Internet connection in Ubuntu in order to locate it and
install it.

The only way to do that - in your case - is to connect the pc to the
wireless router using a LAN cable, instead of using wireless.

Then reboot your PC and run the following command:

sudo rfkill unblock all

Then retest wireless.

Hope it helps.

Jamie (jamiecmcf) said : #4

Thanks Mark Rijckenberg, that solved my question.

Jamie (jamiecmcf) said : #5

Thanks, that really helped. :)