bcm4306 isn't working||need ucode4.fw

Asked by Kyle Keiper on 2011-05-14

Okay, so I'm using ubuntu 10.10 and I have a Dell latitude d600. My wireless controller is a broadcom bcm4306/2 and I've downloaded the b43-fwcutter, but to no avail, and I've also tried activating the proprietary drivers for the card, and it doesn't work either. I'm getting frustrated with this because it's confining to sit in Dad's office trying to do everything hooked up physically to the router. It tells me in the error messages that I need "b43legacy/ucode4.fw" and I can't find that anywhere. Any help would be appreciated. The only thing that I found that seemed like it would help was a link to a forum site, but when I tried to hit it, it was a broken link.

Thanks for any help that you could give me.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu b43-fwcutter Edit question
Assignee:
No assignee Edit question
Solved by:
Kyle Keiper
Solved:
2011-05-15
Last query:
2011-05-15
Last reply:
2011-05-15
Kyle Keiper (goldentoa11) said : #2

Yeah, and I did what it said, but it still didn't help me. Any other advice?

Try:

sudo apt-get install b43-fwcutter

May help.

Hi,

Please first connect your wired network adapter to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1:

If you are using the Gnome interface, open the Terminal console via "Applications->Accessories->Terminal"

If you are using the Unity interface, the easiest way to open the Terminal is to use the 'search' function on the dash. Or you can click on the 'More Apps' button, click on the 'See more results' by the installed section, and find it in that list of applications. A third way, available after you click on the 'More Apps' button, is to go to the search bar, and see that the far right end of it says 'All Applications'. You then click on that, and you'll see the full list. Then you can go to Accessories > Terminal after that.

So the methods in Unity are:
Dash > Search for Terminal
Dash > More Apps > 'See More Results' > Terminal
Dash > More Apps > Accessories > Terminal

Step 2: Please copy-paste the following command from the https://answers.launchpad.net/ubuntu website in Firefox into the Linux Terminal. Do NOT copy-paste from the Email message into the Terminal, as that will only copy PART of the command. The command STARTS with the word sudo and ENDS with the word lsmod. So please copy-paste the ENTIRE command below from Firefox into a Terminal, press <enter>, then enter password when sudo asks for password, then press enter again.

Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the command written on the page. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|ound|p54|prism|rtl|rt2|rt3|rt6|rt7|usb|witch|wl'; iwconfig; cat /etc/modprobe.d/* | egrep 'acx|at76|ath|b43|bcm|brcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|witch|wl'; sudo hwinfo --netcard ; cat /var/lib/NetworkManager/NetworkManager.state; sudo lsmod

Step 3: Please post results (copy/paste terminal output) on this thread. The troubleshooters here need to see the full Terminal output from running the above command.

Step 4: Please also clarify if you installed Ubuntu to the harddisk and are running from a harddisk install OR if you are only testing Ubuntu in a LiveCD session.

Regards,

Mark

Kyle Keiper (goldentoa11) said : #5

[sudo] password for kyle:
Hit http://us.archive.ubuntu.com maverick Release.gpg
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/main Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/main Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/universe Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick/universe Translation-en_US
Hit http://us.archive.ubuntu.com maverick-updates Release.gpg
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en
Ign http://us.archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en_US
Hit http://us.archive.ubuntu.com maverick Release
Hit http://us.archive.ubuntu.com maverick-updates Release
Hit http://us.archive.ubuntu.com maverick/main Sources
Hit http://us.archive.ubuntu.com maverick/restricted Sources
Hit http://us.archive.ubuntu.com maverick/universe Sources
Hit http://us.archive.ubuntu.com maverick/multiverse Sources
Hit http://us.archive.ubuntu.com maverick/main i386 Packages
Hit http://us.archive.ubuntu.com maverick/restricted i386 Packages
Hit http://us.archive.ubuntu.com maverick/universe i386 Packages
Hit http://us.archive.ubuntu.com maverick/multiverse i386 Packages
Hit http://us.archive.ubuntu.com maverick-updates/main Sources
Hit http://us.archive.ubuntu.com maverick-updates/restricted Sources
Hit http://us.archive.ubuntu.com maverick-updates/universe Sources
Hit http://us.archive.ubuntu.com maverick-updates/multiverse Sources
Hit http://us.archive.ubuntu.com maverick-updates/main i386 Packages
Hit http://us.archive.ubuntu.com maverick-updates/restricted i386 Packages
Hit http://us.archive.ubuntu.com maverick-updates/universe i386 Packages
Hit http://us.archive.ubuntu.com maverick-updates/multiverse i386 Packages
Get:1 http://extras.ubuntu.com maverick Release.gpg [29.5kB]
Get:2 http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en [29.5kB]
99% [2 Translation-en bzip2 0B] [Waiting for headers] [Connecting to security.ubzip2: (stdin) is not a bzip2 file.
Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en
Get:3 http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en_US [29.6kB]
66% [3 Translation-en_US bzip2 0B] [Waiting for headers] [Connecting to securitbzip2: (stdin) is not a bzip2 file.
Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en_US
Get:4 http://extras.ubuntu.com maverick Release [29.6kB]
Err http://extras.ubuntu.com maverick Release

Err http://security.ubuntu.com maverick-security Release.gpg
  Something wicked happened resolving 'security.ubuntu.com:http' (-5 - No address associated with hostname)
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en_US
Hit http://security.ubuntu.com maverick-security Release
Ign http://security.ubuntu.com maverick-security/main Sources/DiffIndex
Ign http://security.ubuntu.com maverick-security/restricted Sources/DiffIndex
Ign http://security.ubuntu.com maverick-security/universe Sources/DiffIndex
Ign http://security.ubuntu.com maverick-security/multiverse Sources/DiffIndex
Ign http://security.ubuntu.com maverick-security/main i386 Packages/DiffIndex
Ign http://security.ubuntu.com maverick-security/restricted i386 Packages/DiffIndex
Ign http://security.ubuntu.com maverick-security/universe i386 Packages/DiffIndex
Ign http://security.ubuntu.com maverick-security/multiverse i386 Packages/DiffIndex
Hit http://security.ubuntu.com maverick-security/main Sources
Hit http://security.ubuntu.com maverick-security/restricted Sources
Hit http://security.ubuntu.com maverick-security/universe Sources
Hit http://security.ubuntu.com maverick-security/multiverse Sources
Hit http://security.ubuntu.com maverick-security/main i386 Packages
Hit http://security.ubuntu.com maverick-security/restricted i386 Packages
Hit http://security.ubuntu.com maverick-security/universe i386 Packages
Hit http://security.ubuntu.com maverick-security/multiverse i386 Packages
Fetched 118kB in 21s (5,455B/s)
Reading package lists... Done
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://extras.ubuntu.com maverick Release: The following signatures were invalid: NODATA 1 NODATA 2

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/maverick-security/Release.gpg Something wicked happened resolving 'security.ubuntu.com:http' (-5 - No address associated with hostname)

W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/maverick/Release

W: Some index files failed to download, they have been ignored, or old ones used instead.
Reading package lists... Done
Building dependency tree
Reading state information... Done
grep is already the newest version.
The following extra packages will be installed:
  libhal1 libhd16
The following NEW packages will be installed:
  hwinfo libhal1 libhd16
0 upgraded, 3 newly installed, 0 to remove and 324 not upgraded.
Need to get 849kB of archives.
After this operation, 2,286kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://us.archive.ubuntu.com/ubuntu/ maverick/main libhal1 i386 0.5.14-0ubuntu6 [106kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ maverick/universe libhd16 i386 16.0-2 [698kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ maverick/universe hwinfo i386 16.0-2 [46.1kB]
Fetched 849kB in 10s (83.2kB/s)
Selecting previously deselected package libhal1.
(Reading database ... 120605 files and directories currently installed.)
Unpacking libhal1 (from .../libhal1_0.5.14-0ubuntu6_i386.deb) ...
Selecting previously deselected package libhd16.
Unpacking libhd16 (from .../libhd16_16.0-2_i386.deb) ...
Selecting previously deselected package hwinfo.
Unpacking hwinfo (from .../hwinfo_16.0-2_i386.deb) ...
Processing triggers for man-db ...
Setting up libhal1 (0.5.14-0ubuntu6) ...
Setting up libhd16 (16.0-2) ...
Setting up hwinfo (16.0-2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
  *-network:0
       description: Ethernet interface
       product: NetXtreme BCM5705M Gigabit Ethernet
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 01
       serial: 00:0d:56:e3:d1:63
       size: 100MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 66MHz
       capabilities: pm vpd msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.110 duplex=full firmware=5705-v3.16 ip=192.168.2.8 latency=32 link=yes mingnt=64 multicast=yes port=twisted pair speed=100MB/s
       resources: irq:11 memory:faff0000-faffffff
  *-network:1
       description: Network controller
       product: BCM4306 802.11b/g Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 3
       bus info: pci@0000:02:03.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: driver=b43-pci-bridge latency=32
       resources: irq:5 memory:fafee000-fafeffff
  *-network DISABLED
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 00:90:4b:18:23:0e
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=b43legacy driverversion=2.6.35-22-generic firmware=N/A link=yes multicast=yes wireless=IEEE 802.11bg
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Interface doesn't support scanning : Network is down

auto lo
iface lo inet loopback

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.10
DISTRIB_CODENAME=maverick
DISTRIB_DESCRIPTION="Ubuntu 10.10"
00:00.0 Host bridge [0600]: Intel Corporation 82855PM Processor to I/O Controller [8086:3340] (rev 03)
00:01.0 PCI bridge [0604]: Intel Corporation 82855PM Processor to AGP Controller [8086:3341] (rev 03)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 [8086:24c2] (rev 01)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 [8086:24c4] (rev 01)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 [8086:24c7] (rev 01)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller [8086:24cd] (rev 01)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 81)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge [8086:24cc] (rev 01)
00:1f.1 IDE interface [0101]: Intel Corporation 82801DBM (ICH4-M) IDE Controller [8086:24ca] (rev 01)
00:1f.5 Multimedia audio controller [0401]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller [8086:24c5] (rev 01)
00:1f.6 Modem [0703]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller [8086:24c6] (rev 01)
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] [1002:4c66] (rev 02)
02:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5705M Gigabit Ethernet [14e4:165d] (rev 01)
02:01.0 CardBus bridge [0607]: O2 Micro, Inc. OZ711EC1 SmartCardBus Controller [1217:7113] (rev 20)
02:01.1 CardBus bridge [0607]: O2 Micro, Inc. OZ711EC1 SmartCardBus Controller [1217:7113] (rev 20)
02:03.0 Network controller [0280]: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller [14e4:4320] (rev 02)
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 046d:c05a Logitech, Inc.
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
H/W path Device Class Description
=========================================================
                               system Latitude D600
/0 bus 0G5152
/0/0 memory 64KiB BIOS
/0/400 processor Intel(R) Pentium(R) M processor 2.
/0/400/700 memory 8KiB L1 cache
/0/400/701 memory 2MiB L2 cache
/0/1000 memory 512MiB System Memory
/0/1000/0 memory DIMM DDR Synchronous 266 MHz (3.8
/0/1000/1 memory 512MiB DIMM DDR Synchronous 266 MH
/0/100 bridge 82855PM Processor to I/O Controlle
/0/100/1 bridge 82855PM Processor to AGP Controlle
/0/100/1/0 display Radeon RV250 [Mobility FireGL 9000
/0/100/1d bus 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-
/0/100/1d.1 bus 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-
/0/100/1d.2 bus 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-
/0/100/1d.7 bus 82801DB/DBM (ICH4/ICH4-M) USB2 EHC
/0/100/1e bridge 82801 Mobile PCI Bridge
/0/100/1e/0 eth0 network NetXtreme BCM5705M Gigabit Etherne
/0/100/1e/1 bridge OZ711EC1 SmartCardBus Controller
/0/100/1e/1.1 bridge OZ711EC1 SmartCardBus Controller
/0/100/1e/3 network BCM4306 802.11b/g Wireless LAN Con
/0/100/1f bridge 82801DBM (ICH4-M) LPC Interface Br
/0/100/1f.1 scsi0 storage 82801DBM (ICH4-M) IDE Controller
/0/100/1f.1/0 /dev/sda disk 40GB FUJITSU MHV2040A
/0/100/1f.1/0/1 /dev/sda1 volume 35GiB EXT4 volume
/0/100/1f.1/0/2 /dev/sda2 volume 1496MiB Extended partition
/0/100/1f.1/0/2/5 /dev/sda5 volume 1496MiB Linux swap / Solaris parti
/0/100/1f.1/1 /dev/cdrom disk CDRW/DVD SBW242U
/0/100/1f.5 multimedia 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-
/0/100/1f.6 communication 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-
/1 wlan0 network Wireless interface
Linux Kyle 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:34:50 UTC 2010 i686 GNU/Linux
[ 0.000000] APIC: switched to apic NOOP
[ 0.005375] SMP alternatives: switching to UP code
[ 0.090541] ACPI: ACPI Dock Station Driver: 1 docks/bays found
[ 0.121256] HEST: Table is not found!
[ 0.121601] usbcore: registered new interface driver usbfs
[ 0.121614] usbcore: registered new interface driver hub
[ 0.121640] usbcore: registered new device driver usb
[ 0.121991] Switching to clocksource tsc
[ 0.160398] pnp: PnP ACPI: found 13 devices
[ 0.243506] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
[ 0.243869] ACPI: Lid Switch [LID]
[ 0.254048] Switching to clocksource acpi_pm
[ 0.265918] ERST: Table is not found!
[ 0.356363] hub 1-0:1.0: USB hub found
[ 0.356803] hub 2-0:1.0: USB hub found
[ 0.357060] hub 3-0:1.0: USB hub found
[ 0.357589] hub 4-0:1.0: USB hub found
[ 0.373313] device-mapper: multipath: version 1.1.1 loaded
[ 0.373318] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 0.491071] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 0.987866] isapnp: No Plug & Play device found
[ 0.987908] usb 3-1: new low speed USB device using uhci_hcd and address 2
[ 1.338002] usbcore: registered new interface driver hiddev
[ 1.370445] input: Logitech USB Optical Mouse as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0/input/input4
[ 1.370669] generic-usb 0003:046D:C05A.0001: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-0000:00:1d.1-1/input0
[ 1.370808] usbcore: registered new interface driver usbhid
[ 1.370811] usbhid: USB HID core driver
[ 1.374068] tg3 0000:02:00.0: eth0: Tigon3 [partno(BCM95705A50) rev 3001] (PCI:33MHz:32-bit) MAC address 00:0d:56:e3:d1:63
[ 1.374074] tg3 0000:02:00.0: eth0: attached PHY is 5705 (10/100/1000Base-T Ethernet) (WireSpeed[1])
[ 1.374078] tg3 0000:02:00.0: eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[ 1.374081] tg3 0000:02:00.0: eth0: dma_rwctrl[763f0000] dma_mask[64-bit]
[ 1.374119] b43-pci-bridge 0000:02:03.0: PCI INT A -> Link[LNKB] -> GSI 5 (level, low) -> IRQ 5
[ 1.374155] ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x02, vendor 0x4243)
[ 1.374161] ssb: Core 1 found: IEEE 802.11 (cc 0x812, rev 0x04, vendor 0x4243)
[ 1.374167] ssb: Core 2 found: PCMCIA (cc 0x80D, rev 0x01, vendor 0x4243)
[ 1.374172] ssb: Core 3 found: V90 (cc 0x807, rev 0x01, vendor 0x4243)
[ 1.374178] ssb: Core 4 found: PCI (cc 0x804, rev 0x07, vendor 0x4243)
[ 1.374184] ssb: Core 5 found: IEEE 802.11 (cc 0x812, rev 0x04, vendor 0x4243)
[ 1.377577] ssb: Sonics Silicon Backplane found on PCI device 0000:02:03.0
[ 18.002420] lp: driver loaded but no devices found
[ 18.319282] yenta_cardbus 0000:02:01.0: CardBus bridge found [1028:011d]
[ 18.504117] yenta_cardbus 0000:02:01.1: CardBus bridge found [1028:011d]
[ 18.684921] b43legacy-phy0: Broadcom 4306 WLAN found
[ 18.708075] b43legacy-phy0 debug: Found PHY: Analog 1, Type 2, Revision 1
[ 18.708099] b43legacy-phy0 debug: Found Radio: Manuf 0x17F, Version 0x2050, Revision 2
[ 18.732052] b43legacy-phy0 debug: Radio initialized
[ 18.835266] Broadcom 43xx-legacy driver loaded [ Features: PLID, Firmware-ID: FW10 ]
[ 19.422105] Console: switching to colour frame buffer device 128x48
[ 19.679165] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 20.097340] b43legacy-phy0 ERROR: Firmware file "b43legacy/ucode4.fw" not found or load failed.
[ 20.097347] b43legacy-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Drivers/b43#devicefirmware and download the correct firmware (version 3).
[ 20.982523] tg3 0000:02:00.0: eth0: Link is up at 100 Mbps, full duplex
[ 20.982528] tg3 0000:02:00.0: eth0: Flow control is on for TX and on for RX
[ 20.982587] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 31.488096] eth0: no IPv6 routers present
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:off/any
          Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off

# which ath5k cannot recover. To prevent this condition, stop
blacklist ath_pci
blacklist eth1394
# replaced by p54pci
blacklist prism54
# replaced by b43 and ssb.
blacklist bcm43xx
blacklist uart6850
blacklist twl4030_wdt
options iwlagn 11n_disable=1
> hal.1: read hal dataprocess 1727: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
21: PCI 200.0: 0200 Ethernet controller
  [Created at pci.318]
  Unique ID: rBUF.jGtOSOS7XzF
  Parent ID: 6NW+.+ISWpD3pbdC
  SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Dell Latitude D400"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x165d "NetXtreme BCM5705M Gigabit Ethernet"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x865d "Latitude D400"
  Revision: 0x01
  Driver: "tg3"
  Driver Modules: "tg3"
  Device File: eth0
  Memory Range: 0xfaff0000-0xfaffffff (rw,non-prefetchable)
  IRQ: 11 (14317 events)
  HW Address: 00:0d:56:e3:d1:63
  Link detected: yes
  Module Alias: "pci:v000014E4d0000165Dsv00001028sd0000865Dbc02sc00i00"
  Driver Info #0:
    Driver Status: tg3 is active
    Driver Activation Cmd: "modprobe tg3"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #15 (PCI bridge)

24: PCI 203.0: 0282 WLAN controller
  [Created at pci.318]
  Unique ID: y9sn.METla+0xbK4
  Parent ID: 6NW+.+ISWpD3pbdC
  SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:02:03.0
  SysFS BusID: 0000:02:03.0
  Hardware Class: network
  Model: "Dell TrueMobile 1300 WLAN Mini-PCI Card"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4320 "BCM4306 802.11b/g Wireless LAN Controller"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x0001 "TrueMobile 1300 WLAN Mini-PCI Card"
  Revision: 0x02
  Driver: "b43-pci-bridge"
  Driver Modules: "ssb"
  Device File: wlan0
  Features: WLAN
  Memory Range: 0xfafee000-0xfafeffff (rw,non-prefetchable)
  IRQ: 5 (135 events)
  HW Address: 00:90:4b:18:23:0e
  Link detected: yes
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000014E4d00004320sv00001028sd00000001bc02sc80i00"
  Driver Info #0:
    Driver Status: ssb is active
    Driver Activation Cmd: "modprobe ssb"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #15 (PCI bridge)

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
Module Size Used by
binfmt_misc 6599 1
joydev 8735 0
snd_intel8x0 25632 2
radeon 825934 3
arc4 1165 2
snd_ac97_codec 99227 1 snd_intel8x0
ac97_bus 1014 1 snd_ac97_codec
snd_pcm 71475 2 snd_intel8x0,snd_ac97_codec
snd_seq_midi 4588 0
b43legacy 115004 0
snd_rawmidi 17783 1 snd_seq_midi
ttm 56633 1 radeon
mac80211 231541 1 b43legacy
drm_kms_helper 30200 1 radeon
snd_seq_midi_event 6047 1 snd_seq_midi
pcmcia 35973 0
snd_seq 47174 2 snd_seq_midi,snd_seq_midi_event
snd_timer 19067 2 snd_pcm,snd_seq
snd_seq_device 5744 3 snd_seq_midi,snd_rawmidi,snd_seq
ppdev 5556 0
cfg80211 144470 2 b43legacy,mac80211
yenta_socket 21518 0
pcmcia_rsrc 10566 1 yenta_socket
parport_pc 26058 1
drm 168054 5 radeon,ttm,drm_kms_helper
video 18712 0
output 1883 1 video
intel_agp 26360 1
snd 49006 11 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
pcmcia_core 14657 3 pcmcia,yenta_socket,pcmcia_rsrc
led_class 2633 1 b43legacy
psmouse 59033 0
i2c_algo_bit 5168 1 radeon
dcdbas 5402 0
serio_raw 4022 0
soundcore 880 1 snd
snd_page_alloc 7120 2 snd_intel8x0,snd_pcm
agpgart 32011 3 ttm,drm,intel_agp
shpchp 29886 0
lp 7342 0
parport 31492 3 ppdev,parport_pc,lp
usbhid 36882 0
tg3 123310 0
ssb 39288 1 b43legacy
hid 67742 1 usbhid

Hi,

Please proceed with the following commands:

sudo apt-get update

sudo apt-get remove firmware-b43legacy-installer

sudo apt-get remove b43-fwcutter

Then execute the following manual installation procedure:

http://ubuntuforums.org/showthread.php?t=1621331

So in this case, you need to manually install b43-fwcutter without using apt-get (to circumvent a certain bug in Ubuntu).

Regards,

Mark

Kyle Keiper (goldentoa11) said : #7

Hi,

I tried the manual installation of b43-fwcutter listed on the linuxwireless forums (http://linuxwireless.org/en/users/Drivers/b43#devicefirmware) instead of using apt-get, and it extracted the correct firmware.

I think this bug technically is fixed, because the card now reads networks, but I'm still having problems, so I'm going to create a new discussion page. I'll link to it in a later post.

Kyle Keiper (goldentoa11) said : #8

https://answers.launchpad.net/ubuntu/+question/157663 is the new discussion page/problem I'm having