Avidemux in oneiric or not?

Asked by Papamatti on 2011-10-15

Is there a chance that avidemux lands in oneiric ocelot? Today 15.10.11 there is no installable package and i need it to convert my sat-strams into a video format with a much less size. In natty it works perfect for me, why is it not the ocelot?

avidemux is still present in Oneiric (and is intended to be present for Precise, too, so it's not going away anytime soon), but for some reason the package manager is acting like it isn't. As a temporary workaround, you should be able to install the .deb packages for your architecture (i386 or amd64) from https://launchpad.net/ubuntu/+source/avidemux (expand "The Oneiric Ocelot"). If you need help with this, please feel free to ask (just post a reply).

Papamatti (matti-lx) said : #2

There is a dependency to the package avidemux-plugins-common. It needs the libx264-106 but in oneiric is libx264-116 so it is not installable.

andy@D420:~$ apt-cache policy avidemux
N: Unable to locate package avidemux

andy@D420:~$ apt-cache search avid | grep x
texlive-latex-base - TeX Live: Basic LaTeX packages
sisu-markup-samples - document markup examples for sisu, publish and search framework
gimp-plugin-registry - repository of optional extensions for GIMP
libacexml-6.0.1 - ACE SAX based XML parsing library
libmoosex-semiaffordanceaccessor-perl - Perl module to generate accessors automatically
socks4-server - SOCKS4 server for proxying IP-based services over a firewall

andy@D420:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric

Doesn't appear here.....

I have same problem on Oneiric amd64,
In https://launchpad.net/ubuntu/+source/avidemux i can download several packages,
but when I intend to install them, i have dependency problems: libx264-106 is necessary for avidemux-plugins-common, but this is unavalliable.
Best regards,
Jesús Pedrós

"Doesn't appear here....."

Yeah, it's weird. avidemux appears for Oneiric -- and you can download the binary .deb packages, but apparently not install it due to dependency problems -- at https://launchpad.net/ubuntu/+source/avidemux. But the binary package is for some reason not available for automatic installation and is not listed at http://packages.ubuntu.com/search?keywords=avidemux&searchon=names&suite=all&section=all. Any idea what would cause that? (If nobody here has any ideas -- actionparsnip? -- then I'll investigate further and perhaps I'll post a new question about that. Unfortunately avidemux has no specific answer contacts...)

@Papamatti
Since this matter is decidedly *not* resolved, you may want to reopen the question next time you post, so that it attracts more attention. Perhaps more people who are affected, or people who may be able to contribute information about what is going on, will see it and post.

As a possible workaround for this issue, I have found that you can install the .deb package for your architecture of x264-106 (x264_0.106.1741-3) from Natty. You can get that at https://launchpad.net/ubuntu/+source/x264 (expand The Natty Narwhal). You don't need the libx264 package to install it, and you should probably not install that unless you find that doing so is necessary. Installing x264 from Natty did not require that I uninstall Oneiric's x264, which was already installed on my system. With the addition of this package, I was able to install and run avidemux2_gtk, though I have not tested its functionality yet and may not have the chance to do so until late today or tomorrow. I would encourage others to try this and report back...

...but this might not be a good solution for a production system and certainly wouldn't be for a mission-critical system, because Natty packages are not supported on Oneiric. Actually, there is a specific reason to expect possible problems (though usually there aren't in these situations): since Natty and Oneiric are separate releases they have different toolchains (which basically means different versions of compilers and core libraries), so there may be incompatibilities (which might cause undesired behavior and/or crashing of the program) arising from using the Natty package on Oneiric.

If anybody wanting to attempt the above workaround has trouble, please feel free to post here and I'll provide assistance. (If you are not the creator of this question, then please make sure to use the "Just Add a Comment" button so as not to change the status of this question when asking for this sort of auxiliary support.) Since there might not yet be a bug reported for this (see below for discussion of that matter), I feel that keeping all the discussion here for now is best, at least so long as it doesn't become too repetitive or complicated. But if you want to post a separate question for help with the workaround or any other element of this situation, then please feel free to do that too. If you do that, please post here with a link to the new question and post a link to this question in the new question's description (and you can feel free to subscribe me to the new question too).

The correct ultimate solution to this problem will be for avidemux packages in Oneiric to have the right dependencies (i.e., for them to depend on the right x264 package, the one that is already in Oneiric). This may simply require their package metadata to be updated, or it might be necessary for avidemux's source to itself be modified to make it compatible with the new version. Ordinarily it would be very appropriate to report a bug against the source package avidemux requesting this (after reading https://help.ubuntu.com/community/ReportingBugs carefully and searching to see if the bug has already been reported), and it would not be wrong to do so now, but the reason I have not yet done that is because, if possible, I want to first understand (so I can report on) the additional complication that avidemux's binary packages are for some reason unavailable for automatic installation, even though (on i386 and amd64) they have been successfully built automatically on Launchpad and are available for download here. If someone here does report a bug, then please link the bug and this question together using "Link existing bug" on this question page.

Javier Bolaños (oretachi) said : #7

I have the same problem. I can't install avidemux from terminal and I know that it's avaible at launchpad but there is a dependency issue, like Papamatti said. I tried to edit the deb package changing the dependency and I achieved install it but then, when I'm in, there's no mpg4 AVC plugin at plugins list (some other plugins are ok, including mpg4 AVS) and that's especifically what I need.

I hope it can be resolved soon.

@Javier Bolaños
Do you still experience this problem if you completely remove all avidemux packages (use "sudo apt-get purge ..." or "sudo dpkg -P ...") and install the packages with their original (broken) dependencies and the x264 package from Natty? Had you previously been able to use the mpg4 AVC plugin (for example, when running avidemux on a Natty system)?

Papamatti, thanks for linking bug 831096.

However, I'm not sure this is bug 831096, though it seems perhaps related to it. Bug 831096 documents avidemux's failure to build on virtual-64, but it builds on i386 and amd64 fine, and those packages are available for manual download and installation from Launchpad. See https://launchpad.net/ubuntu/+source/avidemux/1:2.5.4-0ubuntu7/+build/2501413 and https://launchpad.net/ubuntu/+source/avidemux/1:2.5.4-0ubuntu7/+build/2501412.

Javier Bolaños (oretachi) said : #10

@Eliah Kagan

I was able to use mpg4 AVC plugin in Natty last week.

I've tried installing the packages from Natty without changes (with broken dependencies) but I still have the same issue; the mpg4 AVC plugin (x264) is missing.

Papamatti (matti-lx) said : #11

Perhaps it is a solution to build the 2.6 Version, this is still beta but is compatible with gcc 4.6

For the moment Installing libx264-106 from Natty has been a workaround for me.
Thank's, Eliah Kagan.
Best regards,
J

Javier Bolaños (oretachi) said : #13

@<email address hidden>

I can confirm it. Installing Natty's libx264-106 on Oneiric amd64 lets install the avidemux launchpad packages with mpg4 AVC support (it appears at plugin list, transcode test is pending).

It's not the optimal solution but, for the moment, it's ok for me.

Waiting a final patch.

vlc (vlc) said : #14

Same here. Shouldn't we create a bug report for this?

vlc (vlc) said : #15

Ups, there is already one ...

Papamatti (matti-lx) said : #16

Avidemux is in proposed now and it works very well for me.
Thank you all for the bugfix!