Ubuntu

Sound issues. I know the solution is out there

Asked by Brian Smith on 2011-04-08

I have a device that routes the signal from an external audio source to a USB port.
System>Preferences>Sound>Input, shows me that my PC is receiving the signal. However, I cannot hear it through my speakers. If I use Audacity to record, it gets recorded...but I can only hear it from playing back what was recorded. Deductive logic tells me that if the computer is receiving the audio signal, it can be routed through the speakers of my PC. How can this be accomplished?

I've tried opening up Audacity and checking the "Software Playthrough" box listed under Edit>Preferences>Recording, to no avail. Doing this prevents Audacity from recording anything. The progress bar barely moves, then stops. I do not understand how to route things through JACK, and have not found any help. I have even posted two support requests on Launchpad.net on the subject and received no response yet. Is JACK only designed for routing programs (not external audio)?

I've even went through Synaptic and installed a few key components from Ubuntu Studio, hoping to find the answer there. Even though I appreciate what was installed, it didn't help with this problem. I've also tried Ardour GTK2, but think I need to understand JACK a bit more...in order to find a solution there.

This issue could probably be resolved by going back to Windows, but I would like to figure out how to do this in Ubuntu. I personally feel that Ubuntu is the better OS.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu audacity Edit question
Assignee:
No assignee Edit question
Last query:
2011-04-08
Last reply:
2011-04-10
David Henningsson (diwic) said : #1

> If I use Audacity to record, it gets recorded...but I can only hear it from playing back what was recorded. Deductive logic tells me that if the computer is receiving the audio signal, it can be routed through the speakers of my PC.

That is true, but not without some latency. If you don't mind a small delay between input and output, the easiest way might be PulseAudio's module-loopback.
You can load it with the "pactl load-module module-loopback"
See http://www.pulseaudio.org/wiki/Modules#module-loopback for additional parameters to this command.

If you need lower latency than PulseAudio can provide, you could try setting up JACK using one of the techniques mentioned here: http://jackaudio.org/multiple_devices

Can you help with this problem?

Provide an answer of your own, or ask Brian Smith for more information if necessary.

To post a message you must log in.