Comment 45 for bug 948788

Revision history for this message
In , Alexander Surkov (surkov-alexander) wrote :

Comment on attachment 726580
Implement a replacement of atk_object_set_name() which mimics the behavior without calling atk_object_get_name()

Review of attachment 726580:
-----------------------------------------------------------------

::: i/accessible/src/atk/AccessibleWrap.cpp
@@ +147,5 @@
> #endif
>
> G_BEGIN_DECLS
> +
> +static void AtkObjectSetName(AtkObject *aAtkObj, const gchar *name);

nit: type* name (here and below)

@@ +647,4 @@
>
> NS_ConvertUTF8toUTF16 objName(aAtkObj->name);
> if (!uniName.Equals(objName))
> + AtkObjectSetName(aAtkObj, NS_ConvertUTF16toUTF8(uniName).get());

nit: you can change the code to use one conversion

@@ +654,5 @@
>
> +static void
> +AtkObjectSetName(AtkObject *aAtkObj, const gchar *name)
> +{
> + /* This function duplicates the functionality of atk_object_set_name(),

nit: We use '//' comment style in function body