How to stop downloading upgradeable packages

Asked by doctordruidphd on 2018-11-06

This is kubuntu 18.10.

Problem: It looks like something in systemd is running apticron, which is invoking apt with the 'upgrade -yy -d' options, causing it to automatically download upgradeable packages. This is unacceptable as it is logjamming my network connection when it is needed for other things. I cannot find the configuration file that is specifying the '-yy -d' options; what I need to do is remove the '-d' option. I DO want it to check for upgradeable packages; I DO NOT want it to download them. At present it has been necessary for me to disable apticron altogether; is there any other alternative?

Edit: I have edited /etc/apt/apt.conf.d/10periodic as follows, and the problem still exists:
APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::Download-Upgradeable-Packages-Debdelta "0";
APT::Periodic::Unattended-Upgrade "0";
APT::Periodic::AutocleanInterval "0";

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu apticron Edit question
Assignee:
No assignee Edit question
Last query:
2018-11-06
Last reply:

Can you help with this problem?

Provide an answer of your own, or ask doctordruidphd for more information if necessary.

To post a message you must log in.