issues installing/uninstalling

Asked by Seppe on 2011-05-05

I've recently installed ubuntu 11.04 (32-bit) and at first it seemed to be running pretty fine. However recently I can't seem to install or uninstall anything from the software center. installing files manually is possible but rather tedious.

The error it gives me is that of "an unhandlable error occured"
File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 961, in simulate
    trans.unauthenticated = self._simulate_helper(trans)
  File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 1085, in _simulate_helper
    return depends, self._cache.required_download, \
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 226, in required_download
    pm.get_archives(fetcher, self._list, self._records)
SystemError: E:I wasn't able to locate file for the winbind package. This might mean you need to manually fix this package.

Now I'm guessing the issue is related to aptdaemon, and it says I've got to manually fix the "package" but seeing as this is my first time using ubuntu I've got no clue whatsoever on where to start here, I've tried googling for a solution but I've not found one yet that explains either the issue or the solution properly in lamens terms.

According to launchpad it's a bug that has been fixed but I might be completly wrong.
Any help would be appreciated, thanks in advance.

EDIT1: while I'm asking this, I'd also like to add that links don't show up properly (they look like plain text) and when I hover over my mouse it doesn't change into the hand thing anymore, as well as the previous and forward buttons in mozilla are failing as well.

I'd like to note that this did start to happen after I've installed wine (I recon my pc restarted but wine wasn't fully installed yet) but i can't uninstall it (I can install manually but don't know how to uninstall) as it gives me the very same error.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu aptdaemon Edit question
Assignee:
No assignee Edit question
Solved by:
Seppe
Solved:
2011-05-05
Last query:
2011-05-05
Last reply:
2011-05-05

If you run:

sudo apt-get update; sudo apt-get -y upgrade; sudo apt-get -y dist-upgrade

Does it upgrade ok?

Seppe (seppe-van-holderbeke) said : #2

This seems to have fixed it for as far as I can see, kudos to you sir!

Gracias.... me sirvio a mi tambien !!!!