How to update aptdaemon to the latest version?

Asked by telovin on 2011-04-16

Hi,
How can update apt daemon to the latest version? I have version0.31+bzr506-Ubuntu and it gives many errors. When I try to remove apt daemon, it says I have to remove languges, ubuntu one music and utility for browsing and I say cancel. How can I update aptdaemon to latest version without removing it completely? I am using natty.(Ubuntu 11.04)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu aptdaemon Edit question
Assignee:
No assignee Edit question
Solved by:
telovin
Solved:
2011-05-11
Last query:
2011-05-11
Last reply:
2011-04-17

andy@D420:~$ apt-cache policy aptdaemon
aptdaemon:
  Installed: 0.41+bzr645-0ubuntu1
  Candidate: 0.41+bzr645-0ubuntu1
  Version table:
 *** 0.41+bzr645-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status
andy@D420:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Natty (development branch)
Release: 11.04
Codename: natty

Natty has 0.41 which is later then 0.31......

There is a PPA which may get updated more frequently than the Ubuntu repos.
https://launchpad.net/~aptdaemon-developers/+archive/ppa

May help.

telovin (vinaya-ou-live) said : #2

But my version shows the following

vinu@vinu-desktop:~$ apt-cache policy aptdaemon
aptdaemon:
  Installed: 0.31+bzr506-0ubuntu5
  Candidate: 0.31+bzr506-0ubuntu5
  Version table:
 *** 0.31+bzr506-0ubuntu5 0
        100 /var/lib/dpkg/status

telovin (vinaya-ou-live) said : #3

I try to add the ppa and I get (It was already there but still I added once again) the following error
"W:Failed to fetch http://ppa.launchpad.net/aptdaemon-developers/ppa/ubuntu/dists/maverick/main/source/Sources.gz 404 Not Found
, W:Failed to fetch http://ppa.launchpad.net/aptdaemon-developers/ppa/ubuntu/dists/maverick/main/binary-i386/Packages.gz 404 Not Found
, E:Some index files failed to download, they have been ignored, or old ones used instead."

I went to system and about ubuntu and checked , it is showing as natty nahrwal 11.04. Is it because of the pre release freeze that I am unable to get any updates of aptdaemon?

Then you are using Maverick, not Natty. If you give incorrect information then you will get incorrect help. Can you give the output of:

lsb_release -a; uname -a; cat /etc/apt/sources.list

Thanks

You should also remove the PPA you just add by using software centre.

telovin (vinaya-ou-live) said : #5

Now my problem is solved as I reinstalled the stable version of natty.. i was using unstable natty version which i downloaded in jan.(hence so many problems n I had only maverick links sources). I recently donwloded the stale released version.. so it appears to be solved.

~$ lsb_release -a; uname -a; cat /etc/apt/sources.list
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty