Apt-get very slow. Perhaps because of a high latency of the connection.

Asked by Manuel Masiello


I have a really annoying problem with Apt-get.

I install Ubuntu on a PC and Raspbian on a Rapberry Pi and the "apt-get update" or "apt-get install ...." command is extremely slow or never finished. I tried to mirror or disable IPv6 but it does not change anything.

Yesterday, I wanted to install packages from Nvidia's servers but it took a lot of time.
Surprisingly, if I use the wget command on the Url of the package, the download is done at a good speed.
I tested my installation of Ubuntu on an ADSL connection and the rate of flow is normal.

I think the problem is related to the high latency of my internet connection. Indeed, I use a satellite connection.

Are there options to solve this problem?


Question information

English Edit question
Ubuntu apt Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

You could try apt-fast as an alternative
You could also switch to a package source nearer to yourself

What is the output of:

lsb_release -a; uname -a


Revision history for this message
Manuel Masiello (numael) said :

Hello Andrew,

Thank you for your reply.

- Yesterday I tried to install apt-fast but the repository was not accessible. I will be retesting tonight (UTC+2).

- About the mirror change: I've changed the repository several times and the problems persist. I insist that files are normally accessible with wget while Apt-get is very slow. Apt-get uses HTTP as wget. If it was a flow problem, I should have the problem too with wget.

- I will send commands "lsb_release -a; uname -a" when I go home. But, for information, my version of Ubuntu is 18.10 and I had the same problem with Raspbian.

Another information that may be useful: The problem also exists when I use "apt-get update" from the USB boot. This is not a problem of configuration file of the tool.

Revision history for this message
Manfred Hampl (m-hampl) said :

A suggestion for maybe solving "half" of the problem:

Update the repository information (with apt update or from inside synaptic, probably as slow as before)
Start synaptic, select the packages to upgrade/install and create a download script.
"cd" to an empty directory and execute the download script (this might be fast(er), because there are wget commands)
In Synaptic load and install the downloaded packages.

Revision history for this message
Manuel Masiello (numael) said :

Hello Manfred,
Thank you for your reply.

I think rather use "apt-fast". Yesterday I was finally able to install apt-fast using an ADSL connection. But for the moment, I could not check if apt-fast works on the satellite connection.

In fact, I am not really looking for a substitute for apt-get but to understand why it does not work and how to make apt-get work normally. If I use other tools, I lose the interest of installing a Debian . Moreover, if the solution of my problems can become a fix, the whole community will benefit.

Can you help with this problem?

Provide an answer of your own, or ask Manuel Masiello for more information if necessary.

To post a message you must log in.