The required dependency 'apt (>= 1.0.10.2ubuntu2)' is not installed.

Asked by Peter on 2018-09-12

I am trying to upgrade from version 15 to 16 and I am unable to. The error message is The required dependency 'apt (>= 1.0.10.2ubuntu2)' is not installed. . Any assistance to resolve this will be highly appreciated.

I have tried the options as per the site https://answers.launchpad.net/ubuntu/+source/apt/+question/660149 and the output as per the last instructions are as follows

peter@peter-Aspire-5733Z:~$ cd
peter@peter-Aspire-5733Z:~$ rm -v *apt*.deb*
removed ‘apt_1.0.10.2ubuntu2_amd64.deb’
removed ‘apt-transport-https_1.0.10.2ubuntu2_amd64.deb’
removed ‘apt-utils_1.0.10.2ubuntu2_amd64.deb’
removed ‘libapt-inst1.7_1.0.10.2ubuntu2_amd64.deb’
removed ‘libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb’
peter@peter-Aspire-5733Z:~$ wget http://launchpadlibrarian.net/254524267/apt_1.0.10.2ubuntu2_amd64.deb
--2018-09-12 14:41:50-- http://launchpadlibrarian.net/254524267/apt_1.0.10.2ubuntu2_amd64.deb
Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.229, 91.189.89.228
Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.229|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 986732 (964K) [application/x-debian-package]
Saving to: ‘apt_1.0.10.2ubuntu2_amd64.deb’

apt_1.0.10.2ubuntu2 100%[=====================>] 963.61K 123KB/s in 7.2s

2018-09-12 14:42:02 (133 KB/s) - ‘apt_1.0.10.2ubuntu2_amd64.deb’ saved [986732/986732]

peter@peter-Aspire-5733Z:~$ wget http://launchpadlibrarian.net/254524267/apt_1.0.10.2ubuntu2_amd32.deb
--2018-09-12 14:42:24-- http://launchpadlibrarian.net/254524267/apt_1.0.10.2ubuntu2_amd32.deb
Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.228, 91.189.89.229
Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.228|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2018-09-12 14:42:27 ERROR 404: Not Found.

peter@peter-Aspire-5733Z:~$ wget http://launchpadlibrarian.net/254524264/apt-transport-https_1.0.10.2ubuntu2_amd64.deb
--2018-09-12 14:42:47-- http://launchpadlibrarian.net/254524264/apt-transport-https_1.0.10.2ubuntu2_amd64.deb
Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.229, 91.189.89.228
Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.229|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 25402 (25K) [application/x-debian-package]
Saving to: ‘apt-transport-https_1.0.10.2ubuntu2_amd64.deb’

apt-transport-https 100%[=====================>] 24.81K 60.4KB/s in 0.4s

2018-09-12 14:42:50 (60.4 KB/s) - ‘apt-transport-https_1.0.10.2ubuntu2_amd64.deb’ saved [25402/25402]

peter@peter-Aspire-5733Z:~$ wget http://launchpadlibrarian.net/254524266/apt-utils_1.0.10.2ubuntu2_amd64.deb
--2018-09-12 14:43:09-- http://launchpadlibrarian.net/254524266/apt-utils_1.0.10.2ubuntu2_amd64.deb
Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.228, 91.189.89.229
Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.228|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 180220 (176K) [application/x-debian-package]
Saving to: ‘apt-utils_1.0.10.2ubuntu2_amd64.deb’

apt-utils_1.0.10.2u 100%[=====================>] 176.00K 173KB/s in 1.0s

2018-09-12 14:43:13 (173 KB/s) - ‘apt-utils_1.0.10.2ubuntu2_amd64.deb’ saved [180220/180220]

peter@peter-Aspire-5733Z:~$ wget http://launchpadlibrarian.net/254524269/libapt-inst1.7_1.0.10.2ubuntu2_amd64.deb
--2018-09-12 14:43:27-- http://launchpadlibrarian.net/254524269/libapt-inst1.7_1.0.10.2ubuntu2_amd64.deb
Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.229, 91.189.89.228
Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.229|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 58046 (57K) [application/x-debian-package]
Saving to: ‘libapt-inst1.7_1.0.10.2ubuntu2_amd64.deb’

libapt-inst1.7_1.0. 100%[=====================>] 56.69K 88.3KB/s in 0.6s

2018-09-12 14:43:31 (88.3 KB/s) - ‘libapt-inst1.7_1.0.10.2ubuntu2_amd64.deb’ saved [58046/58046]

peter@peter-Aspire-5733Z:~$
peter@peter-Aspire-5733Z:~$ wget http://launchpadlibrarian.net/254524270/libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb
--2018-09-12 14:43:50-- http://launchpadlibrarian.net/254524270/libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb
Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.228, 91.189.89.229
Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.228|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 636172 (621K) [application/x-debian-package]
Saving to: ‘libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb’

libapt-pkg4.16_1.0. 100%[=====================>] 621.26K 242KB/s in 2.6s

2018-09-12 14:43:55 (242 KB/s) - ‘libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb’ saved [636172/636172]

peter@peter-Aspire-5733Z:~$ ls -l *apt*.deb*
-rw-rw-r-- 1 peter peter 986732 Apr 19 2016 apt_1.0.10.2ubuntu2_amd64.deb
-rw-rw-r-- 1 peter peter 25402 Apr 19 2016 apt-transport-https_1.0.10.2ubuntu2_amd64.deb
-rw-rw-r-- 1 peter peter 180220 Apr 19 2016 apt-utils_1.0.10.2ubuntu2_amd64.deb
-rw-rw-r-- 1 peter peter 58046 Apr 19 2016 libapt-inst1.7_1.0.10.2ubuntu2_amd64.deb
-rw-rw-r-- 1 peter peter 636172 Apr 19 2016 libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb
peter@peter-Aspire-5733Z:~$ sudo dpkg --install apt_1.0.10.2ubuntu2_amd64.deb apt-transport-https_1.0.10.2ubuntu2_amd64.deb apt-utils_1.0.10.2ubuntu2_amd64.deb libapt-inst1.7_1.0.10.2ubuntu2_amd64.deb libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb
dpkg: error processing archive apt_1.0.10.2ubuntu2_amd64.deb (--install):
 package architecture (amd64) does not match system (i386)
dpkg: error processing archive apt-transport-https_1.0.10.2ubuntu2_amd64.deb (--install):
 package architecture (amd64) does not match system (i386)
dpkg: error processing archive apt-utils_1.0.10.2ubuntu2_amd64.deb (--install):
 package architecture (amd64) does not match system (i386)
dpkg: error processing archive libapt-inst1.7_1.0.10.2ubuntu2_amd64.deb (--install):
 package architecture (amd64) does not match system (i386)
dpkg: error processing archive libapt-pkg4.16_1.0.10.2ubuntu2_amd64.deb (--install):
 package architecture (amd64) does not match system (i386)
Errors were encountered while processing:
 apt_1.0.10.2ubuntu2_amd64.deb
 apt-transport-https_1.0.10.2ubuntu2_amd64.deb
 apt-utils_1.0.10.2ubuntu2_amd64.deb
 libapt-inst1.7_1.0.10.2ubuntu2_amd64.deb
 libapt-pkg4.16_1.0.10.2ubuntu2_amd64.d

Question information

Language:
English Edit question
Status:
Needs information
For:
Ubuntu apt Edit question
Assignee:
No assignee Edit question
Last query:
2018-09-12
Last reply:
2018-09-12
Manfred Hampl (m-hampl) said : #1

It is not the best idea to "blindly" follow instructions that have been given to another person, even if the problem seems similar.

The instructions in question 660149 were tailored to the specific situation of that person. Your case is a bit different.

Please provide the output that you receive for the commands

uname -a
lsb_release -crid
sudo dpkg --audit
apt-cache policy apt

(I assume, that for your system a different set of packages has to be downloaded and installed)

Can you help with this problem?

Provide an answer of your own, or ask Peter for more information if necessary.

To post a message you must log in.