apt-get wont work

Asked by inzane


im a noob to linux but have to give it a go :)

Im trying to update my ubuntu server using command apt-get update. When i try that i starts to "connect" to no.archive.ubuntu.com (Yeah i live in Norway) and security.ubuntu.com. It stops after 1 min and says "fail to fetch ......................................" you may want to run apt-get update to correct these problemms" and thats my problem. I cant seem to run em.

What have i done wrong ?? i checked sources.list (everything has no." and resolv.conf (I tried the local DNS and the ISP DNS) But this thing wont work.

Need serious help guys :)

Question information

English Edit question
Ubuntu apt Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Tom (tom6) said :

Don't worry about not getting updates yet. Updates in linux tend to be about increasing functionality rather than being about "security". As long as the rest of the system is running fine then you can relax about the update, obviously we'll try to help you fix this quite quickly but don't worry :)

Linux is built with security in mind right from the start rather than as an optional after-thought layered on top of a wobbly system as seems to be the case with Windows.

Good luck and regards from
Tom :)

Revision history for this message
inzane (reilstad) said :

Another problem with the no update thing is that i cant install any problem. It comes with this error no matter what. Should have said that earlier :) Im trying to install diffrent programs and services but it stops. So actually im quite stuck !!

Revision history for this message
pitwalker (pitwalker) said :

you can try with other sources, example: us.archive.ubuntu.com, pl. ....

Revision history for this message
inzane (reilstad) said :

I tried us.archive.ubuntu and en.archive.ubuntu.

Cant figure this out

Revision history for this message
Arnaud Soyez (weboide) said :

Is your server behind a firewall or a proxy ?

Revision history for this message
inzane (reilstad) said :

Not at the moment. Im going to setup a firewall, but for now it aint. Im not using any proxy either.

Could it be to update the repostitur ??

Revision history for this message
Wim (launchpad-xs4all) said :

Inzane, Arnaud and Tom,

i give you the suggestion to start FireFox and manually try to go to the sites
no.archives.ubuntu.com and us.archives.ubuntu.com ...

If you manage to come that far by firefox, then we know that
1. DNS is OK,
2. connection is OK,
3. sites are reachable from your location.

In Synaptic_ProgramManager you can set the sources you are downloading from; please check if the properties of these sources are correct (probably no.archives.ubuntu.com...)

Reply the reaction of your Ubuntu here...

Revision history for this message
inzane (reilstad) said :

Then i figured out the problem. Since im a noob i think its okay :) hehe, but to everybody else thats noobs to. check the interface settings. :)

thanks for everybody that tried to help.