Installation unstable after attempted upgrade to 16.04

Asked by terzim

Hi, the system froze during the upgrade and now it is extremely unstable. apt-get does not work anymore as intended.

I copy the output of the commands suggested.

massi@massi-pc:~$ cat /etc/dpkg/dpkg.cfg.d/multiarch
cat: /etc/dpkg/dpkg.cfg.d/multiarch: No such file or directory
massi@massi-pc:~$ dpkg --print-foreign-architectures
i386
massi@massi-pc:~$ sudo grep -R proxy /etc/apt/*
[sudo] password for massi:
massi@massi-pc:~$ grep proxy /etc/environment
massi@massi-pc:~$ echo $http_proxy

massi@massi-pc:~$ echo $ftp_proxy

massi@massi-pc:~$ grep proxy /etc/bash.bashrc
massi@massi-pc:~$ grep proxy ~/.bashrc
massi@massi-pc:~$ cat /etc/apt/apt.conf
cat: /etc/apt/apt.conf: No such file or directory
massi@massi-pc:~$ sudo fuser -vvv /var/lib/dpkg/lock
massi@massi-pc:~$ sudo fuser -vvv /var/cache/apt/archives/lock
massi@massi-pc:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS"
massi@massi-pc:~$ uname -a
Linux massi-pc 4.2.0-36-generic #41-Ubuntu SMP Mon Apr 18 15:49:10 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
massi@massi-pc:~$ sudo rm /var/lib/apt/lists/lock
massi@massi-pc:~$ sudo rm /var/cache/apt/archives/lock
massi@massi-pc:~$ sudo rm /var/lib/dpkg/lock
massi@massi-pc:~$ sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
massi@massi-pc:~$ sudo mv /var/lib/dpkg/status /var/lib/dpkg/status-bad
massi@massi-pc:~$ sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status || sudo cp /var/backups/apt.extended_states.0 /var/lib/dpkg/status
massi@massi-pc:~$ sudo mv /var/lib/dpkg/available /var/lib/dpkg/available-bad
massi@massi-pc:~$ sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
cp: cannot stat ‘/var/lib/dpkg/available-old’: No such file or directory
massi@massi-pc:~$ sudo rm -rf /var/lib/dpkg/updates/*
massi@massi-pc:~$ sudo rm -rf /var/lib/apt/lists
massi@massi-pc:~$ sudo rm /var/cache/apt/*.bin
massi@massi-pc:~$ sudo mkdir /var/lib/apt/lists
massi@massi-pc:~$ sudo mkdir /var/lib/apt/lists/partial
massi@massi-pc:~$ LANG=C;sudo apt-get clean
massi@massi-pc:~$ LANG=C;sudo apt-get autoclean
Reading package lists... Done
Building dependency tree
Reading state information... Done
massi@massi-pc:~$ sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of libapt-inst2.0:amd64:
 libapt-inst2.0:amd64 depends on libapt-pkg5.0 (>= 1.1~exp9); however:
  Package libapt-pkg5.0 is not installed.

dpkg: error processing package libapt-inst2.0:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of apt-utils:
 apt-utils depends on apt (= 1.2.10ubuntu1); however:
  Version of apt on system is 1.0.10.2ubuntu2.
 apt-utils depends on libapt-inst2.0 (>= 1.0.5); however:
  Package libapt-inst2.0:amd64 is not configured yet.
 apt-utils depends on libapt-pkg5.0 (>= 1.1~exp15); however:
  Package libapt-pkg5.0 is not installed.

dpkg: error processing package apt-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent processing triggers for systemd:
 systemd depends on libsystemd0 (= 225-1ubuntu9.1); however:
  Version of libsystemd0:amd64 on system is 229-4ubuntu4.

dpkg: error processing package systemd (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for dbus:
 dbus depends on libsystemd0; however:
  Package libsystemd0:amd64 is not configured yet.

dpkg: error processing package dbus (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent configuration of gnome-font-viewer:
 gnome-font-viewer depends on libgnome-desktop-3-12 (>= 3.17.92); however:
  Package libgnome-desktop-3-12 is not installed.

dpkg: error processing package gnome-font-viewer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nautilus:
 nautilus depends on libgnome-desktop-3-12 (>= 3.18.1); however:
  Package libgnome-desktop-3-12 is not installed.

dpkg: error processing package nautilus (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libapt-inst2.0:amd64
 apt-utils
 systemd
 dbus
 gnome-font-viewer
 nautilus
massi@massi-pc:~$ sudo dpkg --clear-avail
massi@massi-pc:~$ LANG=C;sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: The package libsystemd0 needs to be reinstalled, but I can't find an archive for it.
massi@massi-pc:~$ LANG=C;sudo apt-get --fix-missing install
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: The package libsystemd0 needs to be reinstalled, but I can't find an archive for it.
massi@massi-pc:~$ LANG=C;sudo apt-get --purge autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: The package libsystemd0 needs to be reinstalled, but I can't find an archive for it.
massi@massi-pc:~$ LANG=C;sudo apt-get --fix-missing update -o APT::Cache-Limit=100000000
Get:1 http://archive.canonical.com xenial InRelease [11.5 kB]
Get:2 http://archive.ubuntu.com xenial InRelease [247 kB]
Get:3 http://archive.canonical.com xenial/partner Sources [2240 B]
Get:4 http://archive.canonical.com xenial/partner amd64 Packages [2712 B]
Get:5 http://archive.canonical.com xenial/partner i386 Packages [3020 B]
Get:6 http://archive.ubuntu.com xenial-updates InRelease [92.2 kB]
Get:7 http://archive.canonical.com xenial/partner Translation-en [1424 B]
Get:8 http://archive.ubuntu.com xenial-backports InRelease [82.2 kB]
Get:9 http://archive.ubuntu.com xenial-security InRelease [92.2 kB]
Get:10 http://archive.ubuntu.com xenial-proposed InRelease [247 kB]
Get:11 http://archive.ubuntu.com xenial/main Sources [868 kB]
Get:12 http://archive.ubuntu.com xenial/restricted Sources [4808 B]
Get:13 http://archive.ubuntu.com xenial/universe Sources [7728 kB]
Get:14 http://archive.ubuntu.com xenial/multiverse Sources [179 kB]
Get:15 http://archive.ubuntu.com xenial/main amd64 Packages [1201 kB]
Get:16 http://archive.ubuntu.com xenial/restricted amd64 Packages [8344 B]
Get:17 http://archive.ubuntu.com xenial/universe amd64 Packages [7532 kB]
Get:18 http://archive.ubuntu.com xenial/multiverse amd64 Packages [144 kB]
Get:19 http://archive.ubuntu.com xenial/main i386 Packages [1196 kB]
Get:20 http://archive.ubuntu.com xenial/restricted i386 Packages [8684 B]
Get:21 http://archive.ubuntu.com xenial/universe i386 Packages [7512 kB]
Get:22 http://archive.ubuntu.com xenial/multiverse i386 Packages [140 kB]
Get:23 http://archive.ubuntu.com xenial/main Translation-en [568 kB]
Get:24 http://archive.ubuntu.com xenial/multiverse Translation-en [106 kB]
Get:25 http://archive.ubuntu.com xenial/restricted Translation-en [2908 B]
Get:26 http://archive.ubuntu.com xenial/universe Translation-en [4354 kB]
Get:27 http://archive.ubuntu.com xenial-updates/main Sources [2640 B]
Get:28 http://archive.ubuntu.com xenial-updates/restricted Sources [64 B]
Get:29 http://archive.ubuntu.com xenial-updates/universe Sources [64 B]
Get:30 http://archive.ubuntu.com xenial-updates/multiverse Sources [64 B]
Get:31 http://archive.ubuntu.com xenial-updates/main amd64 Packages [3312 B]
Get:32 http://archive.ubuntu.com xenial-updates/restricted amd64 Packages [64 B]
Get:33 http://archive.ubuntu.com xenial-updates/universe amd64 Packages [2688 B]
Get:34 http://archive.ubuntu.com xenial-updates/multiverse amd64 Packages [64 B]
Get:35 http://archive.ubuntu.com xenial-updates/main i386 Packages [3324 B]
Get:36 http://archive.ubuntu.com xenial-updates/restricted i386 Packages [64 B]
Get:37 http://archive.ubuntu.com xenial-updates/universe i386 Packages [2680 B]
Get:38 http://archive.ubuntu.com xenial-updates/multiverse i386 Packages [64 B]
Get:39 http://archive.ubuntu.com xenial-updates/main Translation-en [2012 B]
Get:40 http://archive.ubuntu.com xenial-updates/multiverse Translation-en [64 B]
Get:41 http://archive.ubuntu.com xenial-updates/restricted Translation-en [64 B]
Get:42 http://archive.ubuntu.com xenial-updates/universe Translation-en [2000 B]
Get:43 http://archive.ubuntu.com xenial-backports/main Sources [28 B]
Get:44 http://archive.ubuntu.com xenial-backports/restricted Sources [28 B]
Get:45 http://archive.ubuntu.com xenial-backports/universe Sources [28 B]
Get:46 http://archive.ubuntu.com xenial-backports/multiverse Sources [28 B]
Get:47 http://archive.ubuntu.com xenial-backports/main amd64 Packages [28 B]
Get:48 http://archive.ubuntu.com xenial-backports/restricted amd64 Packages [28 B]
Get:49 http://archive.ubuntu.com xenial-backports/universe amd64 Packages [28 B]
Get:50 http://archive.ubuntu.com xenial-backports/multiverse amd64 Packages [28 B]
Get:51 http://archive.ubuntu.com xenial-backports/main i386 Packages [28 B]
Get:52 http://archive.ubuntu.com xenial-backports/restricted i386 Packages [28 B]
Get:53 http://archive.ubuntu.com xenial-backports/universe i386 Packages [28 B]
Get:54 http://archive.ubuntu.com xenial-backports/multiverse i386 Packages [28 B]
Get:55 http://archive.ubuntu.com xenial-backports/main Translation-en [28 B]
Get:56 http://archive.ubuntu.com xenial-backports/multiverse Translation-en [28 B]
Get:57 http://archive.ubuntu.com xenial-backports/restricted Translation-en [28 B]
Get:58 http://archive.ubuntu.com xenial-backports/universe Translation-en [28 B]
Get:59 http://archive.ubuntu.com xenial-security/main Sources [692 B]
Get:60 http://archive.ubuntu.com xenial-security/restricted Sources [64 B]
Get:61 http://archive.ubuntu.com xenial-security/universe Sources [64 B]
Get:62 http://archive.ubuntu.com xenial-security/multiverse Sources [64 B]
Get:63 http://archive.ubuntu.com xenial-security/main amd64 Packages [632 B]
Get:64 http://archive.ubuntu.com xenial-security/restricted amd64 Packages [64 B]
Get:65 http://archive.ubuntu.com xenial-security/universe amd64 Packages [64 B]
Get:66 http://archive.ubuntu.com xenial-security/multiverse amd64 Packages [64 B]
Get:67 http://archive.ubuntu.com xenial-security/main i386 Packages [632 B]
Get:68 http://archive.ubuntu.com xenial-security/restricted i386 Packages [64 B]
Get:69 http://archive.ubuntu.com xenial-security/universe i386 Packages [64 B]
Get:70 http://archive.ubuntu.com xenial-security/multiverse i386 Packages [64 B]
Get:71 http://archive.ubuntu.com xenial-security/main Translation-en [376 B]
Get:72 http://archive.ubuntu.com xenial-security/multiverse Translation-en [64 B]
Get:73 http://archive.ubuntu.com xenial-security/restricted Translation-en [64 B]
Get:74 http://archive.ubuntu.com xenial-security/universe Translation-en [64 B]
Get:75 http://archive.ubuntu.com xenial-proposed/main amd64 Packages [3060 B]
Get:76 http://archive.ubuntu.com xenial-proposed/universe amd64 Packages [1240 B]
Get:77 http://archive.ubuntu.com xenial-proposed/restricted amd64 Packages [64 B]
Get:78 http://archive.ubuntu.com xenial-proposed/multiverse amd64 Packages [64 B]
Get:79 http://archive.ubuntu.com xenial-proposed/main i386 Packages [3060 B]
Get:80 http://archive.ubuntu.com xenial-proposed/universe i386 Packages [1240 B]
Get:81 http://archive.ubuntu.com xenial-proposed/restricted i386 Packages [64 B]
Get:82 http://archive.ubuntu.com xenial-proposed/multiverse i386 Packages [64 B]
Get:83 http://archive.ubuntu.com xenial-proposed/main Translation-en [1000 B]
Get:84 http://archive.ubuntu.com xenial-proposed/multiverse Translation-en [64 B]
Get:85 http://archive.ubuntu.com xenial-proposed/restricted Translation-en [64 B]
Get:86 http://archive.ubuntu.com xenial-proposed/universe Translation-en [464 B]
Fetched 32.4 MB in 39s (814 kB/s)
Reading package lists... Done
massi@massi-pc:~$ LANG=C;sudo apt-get update -o APT::Cache-Limit=100000000 && sudo apt-get dist-upgrade
Hit http://archive.ubuntu.com xenial InRelease
Hit http://archive.ubuntu.com xenial-updates InRelease
Hit http://archive.canonical.com xenial InRelease
Hit http://archive.ubuntu.com xenial-backports InRelease
Hit http://archive.ubuntu.com xenial-security InRelease
Hit http://archive.ubuntu.com xenial-proposed InRelease
Hit http://archive.ubuntu.com xenial/main Sources
Hit http://archive.ubuntu.com xenial/restricted Sources
Hit http://archive.ubuntu.com xenial/universe Sources
Hit http://archive.ubuntu.com xenial/multiverse Sources
Hit http://archive.ubuntu.com xenial/main amd64 Packages
Hit http://archive.ubuntu.com xenial/restricted amd64 Packages
Hit http://archive.ubuntu.com xenial/universe amd64 Packages
Hit http://archive.ubuntu.com xenial/multiverse amd64 Packages
Hit http://archive.ubuntu.com xenial/main i386 Packages
Hit http://archive.ubuntu.com xenial/restricted i386 Packages
Hit http://archive.canonical.com xenial/partner Sources
Hit http://archive.ubuntu.com xenial/universe i386 Packages
Hit http://archive.ubuntu.com xenial/multiverse i386 Packages
Hit http://archive.ubuntu.com xenial/main Translation-en
Hit http://archive.canonical.com xenial/partner amd64 Packages
Hit http://archive.canonical.com xenial/partner i386 Packages
Hit http://archive.ubuntu.com xenial/multiverse Translation-en
Hit http://archive.ubuntu.com xenial/restricted Translation-en
Hit http://archive.ubuntu.com xenial/universe Translation-en
Hit http://archive.ubuntu.com xenial-updates/main Sources
Hit http://archive.ubuntu.com xenial-updates/restricted Sources
Hit http://archive.ubuntu.com xenial-updates/universe Sources
Hit http://archive.canonical.com xenial/partner Translation-en
Hit http://archive.ubuntu.com xenial-updates/multiverse Sources
Hit http://archive.ubuntu.com xenial-updates/main amd64 Packages
Hit http://archive.ubuntu.com xenial-updates/restricted amd64 Packages
Hit http://archive.ubuntu.com xenial-updates/universe amd64 Packages
Hit http://archive.ubuntu.com xenial-updates/multiverse amd64 Packages
Hit http://archive.ubuntu.com xenial-updates/main i386 Packages
Hit http://archive.ubuntu.com xenial-updates/restricted i386 Packages
Hit http://archive.ubuntu.com xenial-updates/universe i386 Packages
Hit http://archive.ubuntu.com xenial-updates/multiverse i386 Packages
Hit http://archive.ubuntu.com xenial-updates/main Translation-en
Hit http://archive.ubuntu.com xenial-updates/multiverse Translation-en
Hit http://archive.ubuntu.com xenial-updates/restricted Translation-en
Hit http://archive.ubuntu.com xenial-updates/universe Translation-en
Hit http://archive.ubuntu.com xenial-backports/main Sources
Hit http://archive.ubuntu.com xenial-backports/restricted Sources
Hit http://archive.ubuntu.com xenial-backports/universe Sources
Hit http://archive.ubuntu.com xenial-backports/multiverse Sources
Hit http://archive.ubuntu.com xenial-backports/main amd64 Packages
Hit http://archive.ubuntu.com xenial-backports/restricted amd64 Packages
Hit http://archive.ubuntu.com xenial-backports/universe amd64 Packages
Hit http://archive.ubuntu.com xenial-backports/multiverse amd64 Packages
Hit http://archive.ubuntu.com xenial-backports/main i386 Packages
Hit http://archive.ubuntu.com xenial-backports/restricted i386 Packages
Hit http://archive.ubuntu.com xenial-backports/universe i386 Packages
Hit http://archive.ubuntu.com xenial-backports/multiverse i386 Packages
Hit http://archive.ubuntu.com xenial-backports/main Translation-en
Hit http://archive.ubuntu.com xenial-backports/multiverse Translation-en
Hit http://archive.ubuntu.com xenial-backports/restricted Translation-en
Hit http://archive.ubuntu.com xenial-backports/universe Translation-en
Hit http://archive.ubuntu.com xenial-security/main Sources
Hit http://archive.ubuntu.com xenial-security/restricted Sources
Hit http://archive.ubuntu.com xenial-security/universe Sources
Hit http://archive.ubuntu.com xenial-security/multiverse Sources
Hit http://archive.ubuntu.com xenial-security/main amd64 Packages
Hit http://archive.ubuntu.com xenial-security/restricted amd64 Packages
Hit http://archive.ubuntu.com xenial-security/universe amd64 Packages
Hit http://archive.ubuntu.com xenial-security/multiverse amd64 Packages
Hit http://archive.ubuntu.com xenial-security/main i386 Packages
Hit http://archive.ubuntu.com xenial-security/restricted i386 Packages
Hit http://archive.ubuntu.com xenial-security/universe i386 Packages
Hit http://archive.ubuntu.com xenial-security/multiverse i386 Packages
Hit http://archive.ubuntu.com xenial-security/main Translation-en
Hit http://archive.ubuntu.com xenial-security/multiverse Translation-en
Hit http://archive.ubuntu.com xenial-security/restricted Translation-en
Hit http://archive.ubuntu.com xenial-security/universe Translation-en
Hit http://archive.ubuntu.com xenial-proposed/main amd64 Packages
Hit http://archive.ubuntu.com xenial-proposed/universe amd64 Packages
Hit http://archive.ubuntu.com xenial-proposed/restricted amd64 Packages
Hit http://archive.ubuntu.com xenial-proposed/multiverse amd64 Packages
Hit http://archive.ubuntu.com xenial-proposed/main i386 Packages
Hit http://archive.ubuntu.com xenial-proposed/universe i386 Packages
Hit http://archive.ubuntu.com xenial-proposed/restricted i386 Packages
Hit http://archive.ubuntu.com xenial-proposed/multiverse i386 Packages
Hit http://archive.ubuntu.com xenial-proposed/main Translation-en
Hit http://archive.ubuntu.com xenial-proposed/multiverse Translation-en
Hit http://archive.ubuntu.com xenial-proposed/restricted Translation-en
Hit http://archive.ubuntu.com xenial-proposed/universe Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 apt-utils : Depends: apt (= 1.2.10ubuntu1) but 1.0.10.2ubuntu2 is installed
             Depends: libapt-pkg5.0 (>= 1.1~exp15) but it is not installed
 gnome-font-viewer : Depends: libgnome-desktop-3-12 (>= 3.17.92) but it is not installed
 libalgorithm-diff-xs-perl : Depends: perlapi-5.20.0 but it is not installable
 libapt-inst2.0 : Depends: libapt-pkg5.0 (>= 1.1~exp9) but it is not installed
 libapt-pkg-perl : Depends: perlapi-5.20.2 but it is not installable
 libb-hooks-op-check-perl : Depends: perlapi-5.20.0 but it is not installable
 libbareword-filehandles-perl : Depends: perlapi-5.20.0 but it is not installable
 libc-dev-bin : Depends: libc6 (< 2.22) but 2.23-0ubuntu3 is installed
 libc6-dbg : Depends: libc6 (= 2.21-0ubuntu4.1) but 2.23-0ubuntu3 is installed
 libc6-dev : Depends: libc6 (= 2.21-0ubuntu4.1) but 2.23-0ubuntu3 is installed
 libclass-c3-xs-perl : Depends: perlapi-5.20.0 but it is not installable
 libdevel-caller-perl : Depends: perlapi-5.20.0 but it is not installable
 libdevel-lexalias-perl : Depends: perlapi-5.20.0 but it is not installable
 libfcgi-perl : Depends: perlapi-5.20.1 but it is not installable
 libglib-perl : Depends: perlapi-5.20.2 but it is not installable
 libio-pty-perl : Depends: perlapi-5.20.0 but it is not installable
 liblist-moreutils-perl : Depends: perlapi-5.20.2 but it is not installable
 libmultidimensional-perl : Depends: perlapi-5.20.0 but it is not installable
 libnet-dns-perl : Depends: perlapi-5.20.1 but it is not installable
 libnet-libidn-perl : Depends: perlapi-5.20.0 but it is not installable
 libpackage-stash-xs-perl : Depends: perlapi-5.20.0 but it is not installable
 libpango-perl : Depends: perlapi-5.20.1 but it is not installable
 libparams-util-perl : Depends: perlapi-5.20.0 but it is not installable
 libperlio-gzip-perl : Depends: perlapi-5.20.0 but it is not installable
 libsocket6-perl : Depends: perlapi-5.20.0 but it is not installable
 libtext-charwidth-perl : Depends: perlapi-5.20.0 but it is not installable
 libtext-iconv-perl : Depends: perlapi-5.20.0 but it is not installable
 libtext-soundex-perl : Depends: perlapi-5.20.0 but it is not installable
 libunicode-utf8-perl : Depends: perlapi-5.20.0 but it is not installable
 libxml-parser-perl : Depends: perlapi-5.20.0 but it is not installable
 nautilus : Depends: libgnome-desktop-3-12 (>= 3.18.1) but it is not installed
 python3 : Depends: libpython3-stdlib (= 3.4.3-4ubuntu1) but 3.5.1-3 is installed
           PreDepends: python3-minimal (= 3.4.3-4ubuntu1) but 3.5.1-3 is installed
 systemd : Depends: libsystemd0 (= 225-1ubuntu9.1) but 229-4ubuntu4 is installed
 udev : Depends: libudev1 (= 225-1ubuntu9.1) but 229-4ubuntu4 is installed
E: Unmet dependencies. Try using -f.
massi@massi-pc:~$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; cat -n "$1"' _ '{}' \;

/etc/apt/sources.list.d/webupd8team-ubuntu-sublime-text-3-vivid.list

     1 # deb http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu wily main # disabled on upgrade to wily
     2 # deb-src http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu vivid main

/etc/apt/sources.list.d/ethereum-ubuntu-ethereum-qt-wily.list

     1 # deb http://ppa.launchpad.net/ethereum/ethereum-qt/ubuntu xenial main # disabled on upgrade to xenial
     2 # deb-src http://ppa.launchpad.net/ethereum/ethereum-qt/ubuntu wily main

/etc/apt/sources.list.d/ria-repository.list

     1 # deb https://installer.id.ee/media/ubuntu/ vivid main # disabled on upgrade to xenial

/etc/apt/sources.list.d/ethereum-ubuntu-ethereum-wily.list

     1 # deb-src http://ppa.launchpad.net/ethereum/ethereum/ubuntu wily main
     2 # deb-src http://ppa.launchpad.net/ethereum/ethereum/ubuntu wily main

/etc/apt/sources.list.d/pipelight-ubuntu-stable-vivid.list

     1 # deb http://ppa.launchpad.net/pipelight/stable/ubuntu wily main # disabled on upgrade to wily
     2 # deb-src http://ppa.launchpad.net/pipelight/stable/ubuntu vivid main

/etc/apt/sources.list.d/ethereum-ubuntu-ethereum-qt-vivid.list

     1 # deb http://ppa.launchpad.net/ethereum/ethereum-qt/ubuntu trusty main # disabled on upgrade to wily
     2 # deb-src http://ppa.launchpad.net/ethereum/ethereum-qt/ubuntu trusty main # disabled on upgrade to wily

/etc/apt/sources.list.d/ethereum-ubuntu-ethereum-vivid.list

     1 # deb http://ppa.launchpad.net/ethereum/ethereum/ubuntu trusty main # disabled on upgrade to wily
     2 # deb-src http://ppa.launchpad.net/ethereum/ethereum/ubuntu trusty main # disabled on upgrade to wily
     3 # deb http://ppa.launchpad.net/ethereum/ethereum/ubuntu xenial main # disabled on upgrade to wily disabled on upgrade to xenial
     4 # deb-src http://ppa.launchpad.net/ethereum/ethereum/ubuntu vivid main

/etc/apt/sources.list.d/webupd8team-ubuntu-y-ppa-manager-vivid.list

     1 # deb http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu trusty main # disabled on upgrade to wily
     2 # deb-src http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu trusty main

/etc/apt/sources.list.d/ethereum-ubuntu-ethereum-dev-vivid.list

     1 # deb http://ppa.launchpad.net/ethereum/ethereum-dev/ubuntu trusty main # disabled on upgrade to wily
     2 # deb-src http://ppa.launchpad.net/ethereum/ethereum-dev/ubuntu trusty main # disabled on upgrade to wily
     3 # deb http://ppa.launchpad.net/ethereum/ethereum-dev/ubuntu xenial main # disabled on upgrade to wily disabled on upgrade to xenial
     4 # deb-src http://ppa.launchpad.net/ethereum/ethereum-dev/ubuntu vivid main

/etc/apt/sources.list.d/beineri-ubuntu-opt-qt541-trusty-vivid.list

     1 # deb http://ppa.launchpad.net/beineri/opt-qt541-trusty/ubuntu trusty main # disabled on upgrade to wily
     2 # deb-src http://ppa.launchpad.net/beineri/opt-qt541-trusty/ubuntu trusty main # disabled on upgrade to wily

/etc/apt/sources.list.d/octave-ubuntu-stable-wily.list

     1 # deb http://ppa.launchpad.net/octave/stable/ubuntu xenial main # disabled on upgrade to xenial
     2 # deb-src http://ppa.launchpad.net/octave/stable/ubuntu wily main

/etc/apt/sources.list.d/ethereum-ubuntu-ethereum-dev-wily.list

     1 # deb-src http://ppa.launchpad.net/ethereum/ethereum-dev/ubuntu wily main
     2 # deb-src http://ppa.launchpad.net/ethereum/ethereum-dev/ubuntu wily main

/etc/apt/sources.list.d/webupd8team-ubuntu-java-wily.list

     1 # deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main # disabled on upgrade to xenial
     2 # deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu wily main

/etc/apt/sources.list

     1
     2 # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     3 # newer versions of the distribution.
     4 deb http://archive.ubuntu.com/ubuntu xenial main restricted
     5 deb-src http://archive.ubuntu.com/ubuntu xenial main restricted
     6
     7 ## Major bug fix updates produced after the final release of the
     8 ## distribution.
     9 deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted
    10 deb-src http://archive.ubuntu.com/ubuntu xenial-updates main restricted
    11
    12 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    13 ## team. Also, please note that software in universe WILL NOT receive any
    14 ## review or updates from the Ubuntu security team.
    15 deb http://archive.ubuntu.com/ubuntu xenial universe
    16 deb-src http://archive.ubuntu.com/ubuntu xenial universe
    17 deb http://archive.ubuntu.com/ubuntu xenial-updates universe
    18 deb-src http://archive.ubuntu.com/ubuntu xenial-updates universe
    19
    20 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    21 ## team, and may not be under a free licence. Please satisfy yourself as to
    22 ## your rights to use the software. Also, please note that software in
    23 ## multiverse WILL NOT receive any review or updates from the Ubuntu
    24 ## security team.
    25 deb http://archive.ubuntu.com/ubuntu xenial multiverse
    26 deb-src http://archive.ubuntu.com/ubuntu xenial multiverse
    27 deb http://archive.ubuntu.com/ubuntu xenial-updates multiverse
    28 deb-src http://archive.ubuntu.com/ubuntu xenial-updates multiverse
    29
    30 ## N.B. software from this repository may not have been tested as
    31 ## extensively as that contained in the main release, although it includes
    32 ## newer versions of some applications which may provide useful features.
    33 ## Also, please note that software in backports WILL NOT receive any review
    34 ## or updates from the Ubuntu security team.
    35 deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
    36 deb-src http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
    37
    38 deb http://archive.ubuntu.com/ubuntu xenial-security main restricted
    39 deb-src http://archive.ubuntu.com/ubuntu xenial-security main restricted
    40 deb http://archive.ubuntu.com/ubuntu xenial-security universe
    41 deb-src http://archive.ubuntu.com/ubuntu xenial-security universe
    42 deb http://archive.ubuntu.com/ubuntu xenial-security multiverse
    43 deb-src http://archive.ubuntu.com/ubuntu xenial-security multiverse
    44
    45 ## Uncomment the following two lines to add software from Canonical's
    46 ## 'partner' repository.
    47 ## This software is not part of Ubuntu, but is offered by Canonical and the
    48 ## respective vendors as a service to Ubuntu users.
    49 deb http://archive.canonical.com/ubuntu xenial partner
    50 deb-src http://archive.canonical.com/ubuntu xenial partner
    51 deb http://archive.ubuntu.com/ubuntu xenial-proposed main universe restricted multiverse
    52 # deb http://llvm.org/apt/trusty/ llvm-toolchain-trusty-3.7 main # disabled on upgrade to xenial
    53 # deb-src http://llvm.org/apt/trusty/ llvm-toolchain-trusty-3.7 main
massi@massi-pc:~$ sudo dpkg --audit
The following packages are in a mess due to serious problems during
installation. They must be reinstalled for them (and any packages
that depend on them) to function properly:
 libsystemd0:amd64 systemd utility library

The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
 apt-utils package management related utility programs
 gnome-font-viewer font viewer for GNOME
 libapt-inst2.0:amd64 deb package format runtime library
 nautilus file manager and graphical shell for GNOME

The following packages have been triggered, but the trigger processing
has not yet been done. Trigger processing can be requested using
dselect or dpkg --configure --pending (or dpkg --triggers-only):
 dbus simple interprocess messaging system (daemon and utilitie
 systemd system and service manager

massi@massi-pc:~$

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu apt Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :
#1

Your system is in a strange state. The systems claims to be 16.04, but several packages are still on the version for Ubuntu 15.10
I see two possibilities:
1. restart from scratch by creating backup copies of your private files, doing a new clean installation of xenial, and restoring your private files from backup
or
2. Try getting the dependency problems solved by manually downloading and installing packages.

If you want to try option 2,
I guess that the output of the following commands will be helpful:
apt-cache policy libsystemd0 libsystemd0:i386 libsystemd0:amd64
dpkg -l | grep libsystemd0

Revision history for this message
terzim (ma-terzi) said :
#2

Hi Manfred, thanks a lot for your courtesy. I would like to pursue option 2 as it will be very difficult to do another clean installation (due to UEFI boot issues and 32 / 64 bit compatibility, it was very difficult to install the first time).

And you are exactly right. The system believes it is on 16.04 but I think some components weren't upgraded!

This is the output of the two commands you suggested:

massi@massi-pc:~$ apt-cache policy libsystemd0 libsystemd0:i386 libsystemd0:amd64
libsystemd0:
  Installed: 229-4ubuntu4
  Candidate: 229-4ubuntu4
  Version table:
 *** 229-4ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ xenial/main amd64 Packages
        100 /var/lib/dpkg/status
libsystemd0:i386:
  Installed: 229-4ubuntu4
  Candidate: 229-4ubuntu4
  Version table:
 *** 229-4ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ xenial/main i386 Packages
        100 /var/lib/dpkg/status
libsystemd0:
  Installed: 229-4ubuntu4
  Candidate: 229-4ubuntu4
  Version table:
 *** 229-4ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ xenial/main amd64 Packages
        100 /var/lib/dpkg/status
massi@massi-pc:~$ dpkg -l | grep libsystemd0
rUR libsystemd0:amd64 229-4ubuntu4 amd64 systemd utility library
ii libsystemd0:i386 229-4ubuntu4 i386 systemd utility library
massi@massi-pc:~$

Revision history for this message
Manfred Hampl (m-hampl) said :
#3

Ok, let's try.
Issue the command

sudo apt-get install --reinstall libsystemd=229-4ubuntu4

and copy/paste all output.

Revision history for this message
terzim (ma-terzi) said :
#4

massi@massi-pc:~$ sudo apt-get install --reinstall libsystemd0=229-4ubuntu4
[sudo] password for massi:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies.
 apt-utils : Depends: apt (= 1.2.10ubuntu1) but 1.0.10.2ubuntu2 is to be installed
             Depends: libapt-pkg5.0 (>= 1.1~exp15) but it is not going to be installed
 gnome-font-viewer : Depends: libgnome-desktop-3-12 (>= 3.17.92) but it is not going to be installed
 libalgorithm-diff-xs-perl : Depends: perlapi-5.20.0 but it is not installable
 libapt-inst2.0 : Depends: libapt-pkg5.0 (>= 1.1~exp9) but it is not going to be installed
 libapt-pkg-perl : Depends: perlapi-5.20.2 but it is not installable
 libb-hooks-op-check-perl : Depends: perlapi-5.20.0 but it is not installable
 libbareword-filehandles-perl : Depends: perlapi-5.20.0 but it is not installable
 libc-dev-bin : Depends: libc6 (< 2.22) but 2.23-0ubuntu3 is to be installed
 libc6-dbg : Depends: libc6 (= 2.21-0ubuntu4.1) but 2.23-0ubuntu3 is to be installed
 libc6-dev : Depends: libc6 (= 2.21-0ubuntu4.1) but 2.23-0ubuntu3 is to be installed
 libclass-c3-xs-perl : Depends: perlapi-5.20.0 but it is not installable
 libdevel-caller-perl : Depends: perlapi-5.20.0 but it is not installable
 libdevel-lexalias-perl : Depends: perlapi-5.20.0 but it is not installable
 libfcgi-perl : Depends: perlapi-5.20.1 but it is not installable
 libglib-perl : Depends: perlapi-5.20.2 but it is not installable
 libio-pty-perl : Depends: perlapi-5.20.0 but it is not installable
 liblist-moreutils-perl : Depends: perlapi-5.20.2 but it is not installable
 libmultidimensional-perl : Depends: perlapi-5.20.0 but it is not installable
 libnet-dns-perl : Depends: perlapi-5.20.1 but it is not installable
 libnet-libidn-perl : Depends: perlapi-5.20.0 but it is not installable
 libpackage-stash-xs-perl : Depends: perlapi-5.20.0 but it is not installable
 libpango-perl : Depends: perlapi-5.20.1 but it is not installable
 libparams-util-perl : Depends: perlapi-5.20.0 but it is not installable
 libperlio-gzip-perl : Depends: perlapi-5.20.0 but it is not installable
 libsocket6-perl : Depends: perlapi-5.20.0 but it is not installable
 libtext-charwidth-perl : Depends: perlapi-5.20.0 but it is not installable
 libtext-iconv-perl : Depends: perlapi-5.20.0 but it is not installable
 libtext-soundex-perl : Depends: perlapi-5.20.0 but it is not installable
 libunicode-utf8-perl : Depends: perlapi-5.20.0 but it is not installable
 libxml-parser-perl : Depends: perlapi-5.20.0 but it is not installable
 nautilus : Depends: libgnome-desktop-3-12 (>= 3.18.1) but it is not going to be installed
 python3 : Depends: libpython3-stdlib (= 3.4.3-4ubuntu1) but 3.5.1-3 is to be installed
           PreDepends: python3-minimal (= 3.4.3-4ubuntu1) but 3.5.1-3 is to be installed
 systemd : Depends: libsystemd0 (= 225-1ubuntu9.1) but 229-4ubuntu4 is to be installed
 udev : Depends: libudev1 (= 225-1ubuntu9.1) but 229-4ubuntu4 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
massi@massi-pc:~$

Revision history for this message
Manfred Hampl (m-hampl) said :
#5

Ok, no surprise that it failed. Try with

sudo apt-get install --reinstall libsystemd0=229-4ubuntu4 -f

and copy/paste the output as before.

If this fails again, then download the file http://archive.ubuntu.com/ubuntu/pool/main/s/systemd/libsystemd0_229-4ubuntu4_amd64.deb to your computer (e.g. to the Downloads folder) and try (re-)installing it manually with

sudo dpkg -i Downloads/libsystemd0_229-4ubuntu4_amd64.deb

and report the outcome.

Revision history for this message
terzim (ma-terzi) said :
#6

Hi Manfred, the manual installation seems to have been going smooth. Any advice what to do next?

massi@massi-pc:~$ cd ~/Downloads
massi@massi-pc:~/Downloads$ ls
[....]

massi@massi-pc:~/Downloads$ cd ~
massi@massi-pc:~$ sudo dpkg -i ~/Downloads/libsystemd0_229-4ubuntu4_amd64.deb
Selecting previously unselected package libsystemd0:amd64.
(Reading database ... 230978 files and directories currently installed.)
Preparing to unpack .../libsystemd0_229-4ubuntu4_amd64.deb ...
Unpacking libsystemd0:amd64 (229-4ubuntu4) over (229-4ubuntu4) ...
Setting up libsystemd0:amd64 (229-4ubuntu4) ...
Processing triggers for libc-bin (2.23-0ubuntu3) ...
massi@massi-pc:~$

Revision history for this message
Manfred Hampl (m-hampl) said :
#7

Ok, now try

sudo apt-get install -f

and report the outcome as before.
If you get a failure, please provide also the output of

sudo dpkg --audit

(after trying apt-get).

Can you help with this problem?

Provide an answer of your own, or ask terzim for more information if necessary.

To post a message you must log in.