computer freezes after update got stuck

Asked by Adria

Hello, I was running an Ubuntu update and suddenly it made the computer freeze. Cursor was not responding neither was any key combination command (AltF4 or Ctrl+Alt+Del for instance) to restart my laptop. I did then a hard reset, but the computer started on a terminal screen. I tried rebooting a few times, but I get the same situation.
Last screen I´ve been getting is as follows:

wn-block(0.0)
[ 0.724802 ] CPU: 1 PID: 1 Comm: swapper/0 Tainted: G I 3.13.0-74-generic #118-Ubuntu
[ 0.724852 ] Hardware name: Acer Aspire 3810TZ/Aspire 3810TZ, BIOS V1.17 10/21/2009
[ 0.724900 ] 0000000000008001 ffff8800b6ebddf0 ffffffff81724b70 ffffffff81a3e3c0
[ 0.725079 ] ffff8800b6edbe68 ffffffff8171d9f3 ffffffff00000010 ffff8800b6edbe78
[ 0.725258 ] ffff8800b6edbe18 ffffffff8171e51e ffff8800b6edbe88 0000000000000098
[ 0.725436 ] Call trace:
[ 0.725482 ] [<ffffffff81724b70>] dump_stack+0x45/0x56
[ 0.725529 ] [<ffffffff8171d9f3>] panic+0xc8/0x1d7
[ 0.725574 ] [<ffffffff8171e51e>] ? printk+0x67/0x69
[ 0.725622 ] [<ffffffff81d3546a>] mount_block_route+0x225/0x2b0
[ 0.725668 ] [<ffffffff81d35692>] mount_route+0x53/0x56
[ 0.725714 ] [<ffffffff81d35801>] prepare_namespace+0x16c/0x1a4
[ 0.725761 ] [<ffffffff81d3516e>] kernel_init_freeable+0x1f3/0x200
[ 0.725807 ] [<ffffffff81d348e5>] ? do_early_param+0x88/0x88
[ 0.725854 ] [<ffffffff81712b80>] ? rest_init+0x80/0x80
[ 0.725900 ] [<ffffffff81712b8e>] kernel_init+0xe/0x130
[ 0.725946 ] [<ffffffff817356a8>] ret_form_fork+0x58/0x90
[ 0.725992 ] [<ffffffff81712b80>] ? rest_init+0x80/0x80

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu apt Edit question
Assignee:
No assignee Edit question
Solved by:
Adria
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Have you tested your RAM using Memtest86 from GRUB?

Revision history for this message
Adria (balataoxa) said :
#2

Hello @actionparsnip, I did and got the message *****Pass complete, no errors, press Esc to exit*****

The Memory SPD info shows
- Slot 0: 2048 MB PC3-8500 - Samsung M471B5673EH1-CF8
- Slot 1: 1024 MB PC3-8500 - Elpida EBJ11UE6BAU0-AE-E

Revision history for this message
Manfred Hampl (m-hampl) said :
#3

Can you try booting an older version of the kernel (from 'Advanced Option' in the grub menu)? Does this work, or fail the same way?

Revision history for this message
Adria (balataoxa) said :
#4

Hello @Manfred Hampl, thank you for the suggestion, I did and it worked. Now I will remove the broken version that was causing the problem, any idea of a command script for that? This newbie really appreciates you guys help!

Thank you!

Revision history for this message
Manfred Hampl (m-hampl) said :
#5

To identify the broken and the functioning versions of the kernel, issue the following commands in a terminal window:

uname -a
lsb_release -crid
dpkg -l | grep ' linux-i'

and copy/paste all output onto this question document.